Closed Bug 828465 Opened 7 years ago Closed 7 years ago

Turn metrofx on for Win64 builds and test

Categories

(Firefox for Metro Graveyard :: Build Config, defect)

x86_64
Windows 8.1
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jimm, Assigned: mbrubeck)

References

Details

Attachments

(1 file)

We've never enabled metrofx in win64 builds. We probably should and test them to see if there are issues.
Duplicate of this bug: 846778
Duplicate of this bug: 844522
It'd be nice to get this going.
Attached patch patchSplinter Review
Pushed to Try (hope my TryChooser syntax works) so we can download and test out a build before landing this:
https://tbpl.mozilla.org/?tree=Try&rev=a969e7cd2013
Assignee: nobody → mbrubeck
Status: NEW → ASSIGNED
Attachment #726729 - Flags: review?(jmathies)
I tested out both the Metro and desktop UI in the Try build just for basic functionality and did not notice any problems.
It's been working in desktop and metro since about 14th Mar. I uninstalled and reinstalled using Nightly x64. I then made Nightly default browser in Desktop mode and Nightly is now default in Metro. Win8 Metro only supports one browser so IE reverts to Desktop only(by MS design!).
Works just fine for me.
Attachment #726729 - Flags: review?(jmathies) → review+
https://hg.mozilla.org/mozilla-central/rev/cf2e050c092c
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.