alert(), prompt() and confirm() cause exceptions in pop out tabs

RESOLVED DUPLICATE of bug 827084

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 827084
5 years ago
5 years ago

People

(Reporter: Bram Speeckaert, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
STR:
1) Have a window open with at least two tabs (so moving one tab out of the window will create a new window)
2) Pop a tab out of the window, creating a second window
3) Open the Web Console on the tab
4) Try executing "alert('')", "confirm('')" or "prompt()"

The functions will wrongfully give back an exception:
[17:39:32.055] alert('')
[17:39:32.057] [Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIDOMWindow.alert]"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: Web Console :: <TOP_LEVEL> :: line 1"  data: no]
(Reporter)

Comment 1

5 years ago
This was found using the latest Nightly build (21.0a1 2013-01-09).
This worked for me on MacOS X 10.8.2 on Nightly 21.0a1 (2013-01-09).

Comment 3

5 years ago
maybe duplication of Bug 827084
Agreed
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 827084
You need to log in before you can comment on or make changes to this bug.