IMAP interop: "move to trash" is not working for some specific IMAP server

VERIFIED WONTFIX

Status

--
major
VERIFIED WONTFIX
18 years ago
10 years ago

People

(Reporter: yann.liebaert, Assigned: mscott)

Tracking

({imap-interop})

Trunk
x86
Linux
imap-interop

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
When I want to delete my imap messages using the "move to trash" option, I
always have the answer "The current command did not succeed. The mail server
responded : UID Copy Failed : Not a valid Maildir mailbox : Trash".
As messages can not be removed using "mark it as deleted", because they're
coming back all the time, and not moved to the trash, it is quite difficult to
enjoy Mail&News.
You can have a test at :
imap.free.fr
Account : yannyann
Passwd : testtest (should be open in approx 1 hr)

Comment 1

18 years ago
Created attachment 36691 [details]
attach this account folder pane view

Comment 2

18 years ago
Created attachment 36692 [details]
attach imap log for removing msgs to trash problem

Comment 3

18 years ago
updating the summary since problem is only occurring on some specific IMAP 
server. adding interop for the keywords, changing the status to new since I can 
reproduce this problem too....and I am wondering to know what kind of the IMAP 
server are you using??? (I see "imap1-1.free.fr IMAP4rev1 v12.264 server ready" 
on the IMAP log....)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: interop
Summary: IMAP "move to trash" is not working → IMAP interop: "move to trash" is not working for some specific IMAP server
(Reporter)

Comment 4

18 years ago
Sent to my ISP today :

Bonjour,

Votre serveur IMAP a des problèmes de communication avec Mozilla. D'où vient le
bug, je ne sais pas (serveur IMAP ou Mozilla ?).

Vous trouverez le thread relatif à ce problème à l'adresse suivante :
http://bugzilla.mozilla.org/show_bug.cgi?id=82850

Afin de résoudre ce problème, et d'assurer comme vous le faites depuis le début
une compatibilité multi-plateformes, pourriez-vous m'éclairer, ainsi que M.
Huang sur le type de serveur que vous utilisez ?

D'avance, merci
Yann Liebaert

PS : Free e-mail adresse : yann.liebaert@free.fr

[English Translation]
Hello,

Your IMAP server has communication problems with Mozilla. Where does this bug
come from, I don't know (Imap server or Mozilla ?)

You'll find the thread relative to this problem at the following URL :
http://bugzilla.mozilla.org/show_bug.cgi?id=82850

To solve this problem, and assure a multi-OS compatibility, as you're doing
since the beginning, should you inform myself and M. Huang on the kind of server
you're using ?

Thanks
Yann Liebaert

PS : Free e-mail address : yann.liebaert@free.fr
(Reporter)

Comment 5

18 years ago
Just received a mail about this pronlem by my postmaster. He told me that the
trash folder under the yannyann account wasn't valid. There's no cur
subdirectory and no .uidvalidity file. He fixed it by hand. He already
encountered this bug which has been declared as n°67415, but hasn't been followed.
He also told me that the imap server is Washington University IMAP server,
release 4.7c

I didn't get back to the account address I gave you. I let you go and see what's
going on. If what the postmaster did fixed the problem, I'll open another empty
account for you to check the creation of a trash folder using morilla.

Comment 6

18 years ago
OK. It seems that this is server problem...
Marking as wontfix based on Yann's previous comments. 
Please log bug in the future if you see client problem again....
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WONTFIX

Comment 7

18 years ago
And Yann, -- thanks for the update info. 
Marking as verified.
Status: RESOLVED → VERIFIED

Comment 8

18 years ago
>I'll open another empty account for you to check the creation of a trash folder 
>using mozilla.

Please open another account(userid: huang) and email to me, so I can do more 
further testing. Thanks.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.