Last Comment Bug 82851 - ~user does not load user's home directory
: ~user does not load user's home directory
Status: RESOLVED WORKSFORME
: helpwanted
Product: SeaMonkey
Classification: Client Software
Component: UI Design (show other bugs)
: Trunk
: x86 Linux
: -- enhancement (vote)
: ---
Assigned To: jag (Peter Annema)
: Paul Wyskoczka
:
Mentors:
Depends on: 93141
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-26 05:02 PDT by Dennis Haney
Modified: 2009-10-14 06:57 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Dennis Haney 2001-05-26 05:02:18 PDT
The open-dialogboxes doesn't support ~user as a valid input.

~user should switch to "user"'s homedir.
Comment 1 James Green 2001-05-26 05:52:48 PDT
~user is a bash-ism, possibly other shells also implement it.

'~' in the filepicker DOES go to the user's home directory.

'~jg' complains that /home/jg/jg doesn't exist, which is correct.

Don't see why this is a UI bug. More like filepicker, re-assigning to bryner and
setting severity to enhancement, also updating summary.
Comment 2 James Green 2001-05-26 05:53:37 PDT
Really re-assign to bryner.
Comment 3 sairuh (rarely reading bugmail) 2001-05-29 11:27:32 PDT
even though ~subdir doesn't work, ~/subdir does work for me.
Comment 4 Dennis Haney 2001-05-31 12:17:28 PDT
The handling of ~someone is not surposed to enter a subdir in YOUR homedir, but
enter "someone"'s homedir. ~/dir correctly switches to a subdir in YOUR homedir.
Comment 5 sairuh (rarely reading bugmail) 2001-05-31 14:15:25 PDT
oops, duh! thx, i forgot about that...
Comment 6 Jeremy M. Dolan 2001-07-31 19:53:04 PDT
Is this only covering the save dialog and such, or also file:// in the address bar.

It's very annoying to have to type in my full home directory path to load
~/x.html, when I'm doing a simple test case.
Comment 7 Dennis Haney 2001-08-01 13:33:14 PDT
That is a completly different bug ;)
File it! Please ;)
Comment 8 benc 2001-09-26 11:22:24 PDT
I know some of these conventions are shell conventions, so is there a way for 
the UNIX verions to ask the OS to do conversions (or maybe read the user shell 
and do the conversion?).
Comment 9 Brian Ryner (not reading) 2002-07-06 19:04:24 PDT
-> boris
Comment 10 Boris Zbarsky [:bz] (still a bit busy) 2002-07-06 19:22:55 PDT
Futuring until someone suggests a decent way of doing this that works across all
unices and does not require parsing /etc/passwd entries or something ridiculous
like that.
Comment 11 Boris Zbarsky [:bz] (still a bit busy) 2004-01-06 16:25:44 PST
No plans to work on this any time in the foreseeable future, so to default owner.
Comment 12 Robert Kaiser 2009-06-14 07:30:08 PDT
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Comment 13 Robert Kaiser 2009-06-14 07:34:34 PDT
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Comment 14 Robert Kaiser 2009-06-14 07:47:53 PDT
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Comment 15 Robert Kaiser 2009-06-14 07:50:49 PDT
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Comment 16 Robert Kaiser 2009-06-14 07:51:10 PDT
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Comment 17 Robert Kaiser 2009-06-14 07:55:22 PDT
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Comment 18 Robert Kaiser 2009-06-14 07:58:32 PDT
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Comment 19 Martin Stránský 2009-10-14 06:57:55 PDT
Works fine now (seamonkey uses GTK file dialog now).

Note You need to log in before you can comment on or make changes to this bug.