RIL: Cellbroadcast is not working.

RESOLVED WORKSFORME

Status

()

Core
DOM: Device Interfaces
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: brg, Assigned: m1)

Tracking

Trunk
All
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(blocking-b2g:tef+, blocking-basecamp:-)

Details

(Whiteboard: [triage:1/17])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Testing Cellbroadcast functionality in Berlin under O2-de coverage is not working.
I tested it with the help of Jose Antonio who changed the setting paremeters to activate it properly and in the suitable channel. He will include the log later.

The suitable behaviour was observed in other platform device who shows the message broadcasted by network, it was an ID with this type: 379576582731 or other numbers but it is a 12 number ID.
(Reporter)

Comment 1

5 years ago
This is mandatory for launching the product in Brasil, regulatory requirement. Nominating for BB.
blocking-basecamp: --- → ?
(Reporter)

Updated

5 years ago
Blocks: 819528
Component: DOM → DOM: Device Interfaces
Created attachment 700234 [details]
Logcat output with RIL debug enabled.

No UNSOLICITED_RESPONSE_NEW_BROADCAST_SMS events.

I/Gecko   (  107): RIL Worker: Cell Broadcast search lists: {"MMI":[221,222],"CBMIR":null,"CBMI":[]}
I/Gecko   (  107): RIL Worker: Cell Broadcast search lists(merged): [221,222]

Nothing about REQUEST_GSM_SMS_BROADCAST_ACTIVATION parcel.
|adb logcat -b radio| is showing:

D/RILC    (  111): UI <--- RIL_REQUEST_GSM_SET_BROADCAST_SMS_CONFIG (90) Complete --- RIL [RID 0, Token 60, Generic Failure, Len 0 ]
Summary: Cellbroadcast is not working → RIL: Cellbroadcast is not working.
blocking-b2g: --- → tef+
blocking-basecamp: ? → -
Re-nominating. This is causing partner problems for certification. Will get RIL team to address.
blocking-b2g: tef+ → ---
blocking-basecamp: - → ?
tef+ seems the right state for certification bugs that we need to address for 1.0, but not before 1/15.  Our partners have been made aware that such bugs filed Monday 1/6 onwards are tef+.
blocking-b2g: --- → tef+
blocking-basecamp: ? → -
Ok. Vicamo is going to work with Jaoo to look at this while we're 1) in the same room and 2) in a place where it's reproducible.
(In reply to Dietrich Ayala (:dietrich) from comment #6)
> Ok. Vicamo is going to work with Jaoo to look at this while
> we're 1) in the same room and 2) in a place where it's
> reproducible.

Yes, talked to Jaoo, need a TEF sim card for this. I'll still try without the sim card, manually turn on channel 221 for test.
(In reply to Vicamo Yang [:vicamo][:vyang] from comment #7)
> Yes, talked to Jaoo, need a TEF sim card for this. I'll still
> try without the sim card, manually turn on channel 221 for test.

I'm managed to reproduce this issue without TEF sim.
(Reporter)

Comment 9

5 years ago
(In reply to Vicamo Yang [:vicamo][:vyang] from comment #8)
> (In reply to Vicamo Yang [:vicamo][:vyang] from comment #7)
> > Yes, talked to Jaoo, need a TEF sim card for this. I'll still
> > try without the sim card, manually turn on channel 221 for test.
> 
> I'm managed to reproduce this issue without TEF sim.

I guess you can test with any SIM card but you must be under O2 coverage. We can guarantee it with Movistar (TEF Spain) SIM card.

Comment 10

5 years ago
Can't test it with Unagi and can't test it in Taiwan. 
Suggest to tef? and see if we should tef+. 

Michael, is this what you will handle? Thanks.
blocking-b2g: tef+ → tef?
Flags: needinfo?(mvines)
This is a blocker, without this, we cannot sell a device in Brazil because it is Brazilian regulatory requirement. Can you plus it again. By the way, which criteria are you following to re-triage? I've just spotted two ones I am pretty sure are blockers, can you schedule a re-triage session where TEF is represented?
(Assignee)

Comment 12

5 years ago
Yes we are validating cell broadcast as a part of our testing
Flags: needinfo?(mvines)

Updated

5 years ago
blocking-b2g: tef? → tef+

Comment 13

5 years ago
(In reply to Daniel Coloma:dcoloma from comment #11)
> This is a blocker, without this, we cannot sell a device in Brazil because
> it is Brazilian regulatory requirement. Can you plus it again. By the way,
> which criteria are you following to re-triage? I've just spotted two ones I
> am pretty sure are blockers, can you schedule a re-triage session where TEF
> is represented?

We are focusing on tef+ & nobody cases and see what cases could be owned by Mozilla Taipei. This case was tef+ before this week, and we thought it might need to be re-triaged again. Sorry about this. 

Since we've Gaia triage for EU + TPE and TEF is represented, should we have another platform triage for EU + TPE and TEF can join as well? Maybe we can do it right before the EU + TPE Gaia triage. How do you feel? 

I'm fine if we don't need to have EU + TPE platform triage. In this case, I will host TPE platform triage and review tef+ & nobody cases only.
Assignee: nobody → vyang
Whiteboard: [triage:1/16]
It seems like this bug should be assigned to Michael as they're testing cell broadcast with the shipping RIL.

Vicamo, should we open a bug to fix the issues making cell broadcast not work with the B2G RIL?
Assignee: vyang → mvines
Flags: needinfo?(vyang)
Whiteboard: [triage:1/16] → [triage:1/17]
(In reply to Andrew Overholt [:overholt] from comment #14)
> Vicamo, should we open a bug to fix the issues making cell
> broadcast not work with the B2G RIL?

But B2G RIL CB works on SGS2 in Brasil. I just don't know what steps, configurations does QC need.
Flags: needinfo?(vyang)
Successfully verified end-to-end using commercial RIL.  Sorry for the delay, there were some setup/configuration issues to deal with.  All set now.
Thanks.  So can we close this now?
Okay, please re-open if we have more issues here.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.