If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Kickstart 64 seamicro nodes

RESOLVED FIXED

Status

mozilla.org Graveyard
Server Operations
RESOLVED FIXED
5 years ago
3 years ago

People

(Reporter: cshields, Assigned: Aj)

Tracking

Details

(Reporter)

Description

5 years ago
we have 64 seamicro xeons that need kickstarted with rhel6.  They are already in dns and inventory (including their proper dhcp setup):

node[0-63].bunker.scl3.mozilla.com

inventory links are found here:  https://inventory.mozilla.org/en-US/systems/racks/?location=0&status=&rack=167&allocation=
(Assignee)

Comment 1

5 years ago
In order to have a 100% unattended installation of the nodes, need to make sure that all the nodes have "DHCP option Host Name" set in inventory.
Assignee: server-ops → afernandez
running the script now to set nic.X.option_hostname.0 to correspond to each system correctly. I will update this when it's complete.
(Assignee)

Comment 3

5 years ago
rtucker update the inventory entries with the correct IPs and DHCP option Host Name settings.
Netops (casey) fixed an misconfiguration on the network side.

node0.bunker.scl3.mozilla.com is up and installed (test bed), now nodes 1-63 are currently being installed.
(Assignee)

Comment 4

5 years ago
All 64 nodes kickstarted, currently puppetizing in batches of 16.
(Assignee)

Comment 5

5 years ago
On a side notes, seems nodes 40-63 didn't have disks assigned but were assigned when I noticed. Seems this was caused by Bug 811726

Also set the description (ie hostname) for all 63 nodes.

All nodes have been puppetized and basic nagios checks added.

The chassis (seamicro-a1.r102-3.console.scl3.mozilla.com) was not being monitored but is now.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.