Do not capitalize localizable text

VERIFIED FIXED

Status

Firefox OS
Gaia
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: willyaranda, Assigned: willyaranda)

Tracking

({l12y})

unspecified
x86
Mac OS X

Firefox Tracking Flags

(blocking-b2g:tef+, blocking-basecamp:-, b2g18+ fixed, b2g18-v1.0.0 fixed)

Details

Attachments

(1 attachment)

Keywords: l12y
Attachment #700073 - Attachment is patch: true
blocking-basecamp: --- → ?
Are all our en-US strings Capitalized accordingly? 

Also, this is basically the follow-up bug to bug 823087 comment 14?
(In reply to Axel Hecht [:Pike] from comment #2)
> Are all our en-US strings Capitalized accordingly?

Yes, just checked, at least "The first letter of each phrase"

> 
> Also, this is basically the follow-up bug to bug 823087 comment 14?

Yes, but this has been introduced after the other bug was fixed, as I didn't find this patch's strings there.
We will not block V1, but we would take a patch.
blocking-basecamp: ? → -
tracking-b2g18: --- → +
Assignee: nobody → willyaranda
Comment on attachment 700073 [details] [diff] [review]
Patch

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: Strings look weird on Spanish and Portuguese
Testing completed: 
Risk to taking this patch (and alternatives if risky): Low, checked en-US strings and they have capitalized phrases
Attachment #700073 - Flags: approval-gaia-master?(21)
Comment on attachment 700073 [details] [diff] [review]
Patch

This patch needs a code review before approval-gaia-master can be granted, and some more assurance that it definitely doesn't cause any capitalisation regressions would be great!
Attachment #700073 - Flags: approval-gaia-master?(21) → approval-gaia-master-
It is BB-, but I'm nominating as tef?

UX team has raised some concerns about this.
blocking-b2g: --- → tef?
Gaia triage : we should make sure that we are not going back and forth on localization bugs having to be capitalized or not capitalized so that the system itself is uniform.  ie. bug 803952

Having said that, we are + based on cleaning up the UI.
blocking-b2g: tef? → tef+
Attachment #700073 - Flags: review?(igonzaleznicolas)
Attachment #700073 - Flags: review?(igonzaleznicolas) → review+
Blocks: 830453
Comment on attachment 700073 [details] [diff] [review]
Patch

Re-requesting approval‑gaia‑master now that the patch has been reviewed and because localizers are complaining.

l10n-wise, we should *not* rely on CSS to capitalize text.
Attachment #700073 - Flags: approval-gaia-master- → approval-gaia-master?(21)
Duplicate of this bug: 830453
Comment on attachment 700073 [details] [diff] [review]
Patch

I don't think approval-gaia-master is needed for tef+ bugs.
Attachment #700073 - Flags: approval-gaia-master?(21)
https://github.com/mozilla-b2g/gaia/commit/f2ec7506639c15ca211a4928eb81a1ad6e63fbe6
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Updated

6 years ago
status-b2g18: --- → fixed
Landed on mozilla-b2g18/gaia master prior to the 1/25 branching to mozilla-b2g18_v1_0_0/v1.0.0, updating status-b2g-v1.0.0 to fixed.
status-b2g18-v1.0.0: --- → fixed

Comment 14

5 years ago
Issue is not reproducing anymore.

Verified on Unagi 
Build ID: 201302014070203
Kernel: Dec 5
Gecko:  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/d1288313218e
Gaia:   6544fdb8dddc56f1aefe94482402488c89eeec49
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.