If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[LAYER]Webvan category tree not displayed

VERIFIED WONTFIX

Status

Tech Evangelism Graveyard
English US
P2
normal
VERIFIED WONTFIX
17 years ago
3 years ago

People

(Reporter: Matt Seitz, Assigned: bc)

Tracking

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9+) Gecko/20010525
BuildID:    2001052520

Webvan.com should display a selection tree for browsing the various departments.
 Mozilla dispays a blank white space where the tree should be.

Reproducible: Always
Steps to Reproduce:
1.  Go to www.webvan.com
2.  Select the Grocery & Fresh Market tab


Actual Results:  Mozilla diaplays a blank area below the tabs

Expected Results:  The top level browing categories should appear in a column
beneath the tabs.

Comment 1

17 years ago
Works for me in the May 29th build (2001052904).

Comment 2

17 years ago
It does NOT work for me on Win98 Build 2001053004. There is a blank area under
the category that under IE is filled with a dynamic menu.

Comment 3

17 years ago
I see this as well, if its your first time there you have to choose your zipcode
etc but after that just follow the instructions on here. Its a javascript code
piece so lets try there first. No errors show up in the Javascript Console so we
must not be doing something properly. 

I tested on 0.9 btw so its not a regression.

Marking NEW.
Assignee: karnaze → rogerl
Status: UNCONFIRMED → NEW
Component: Layout → Javascript Engine
Ever confirmed: true
QA Contact: petersen → pschwartau

Comment 4

17 years ago
Confirming bug with Mozilla binary 2001052708 WinNT.
It boils down to this URL: 

http://www000108.webvan.com/wv/marketing/inc/cat1112901.asp?SelectedTab=10&Invok
eCatID=1112901

This URL loads correctly in NN4.7, but in Mozilla it comes up blank in the 
center. No errors in JavaScript console.
Component: Javascript Engine → Layout

Comment 5

17 years ago
The URL directly above uses a <LAYER> tag to show the menu:

<LAYER  WIDTH='100%' SRC='/wv/base/shopping/menu.asp?InvokeCatID=1112901' 
HEIGHT='331.5'></LAYER>


The absolute URL for this is: 
http://www000108.webvan.com/wv/base/shopping/menu.asp?InvokeCatID=1112901

Comment 6

17 years ago
If you try the layer URL directly above in NN4.7, you will see the 
menu in question. If you try the URL in Mozilla, it still won't come up,
because <LAYER> tags are employed here as well. 

To summarize: 

1. The parent HTML uses a <LAYER> tag
2. The URL for this itself uses a <LAYER> tag


The browser detection for this site is at: 

http://www000103.webvan.com/wv/i/js/browserdetect.js

Comment 7

17 years ago
Sample of the browser detection:

var agt=navigator.userAgent.toLowerCase(); 
var is_major = parseInt(navigator.appVersion); 
var is_minor = parseFloat(navigator.appVersion); 
var is_nav  = ((agt.indexOf('mozilla')!=-1) && (agt.indexOf('spoofer')==-1) 
&& (agt.indexOf('compatible') == -1) && (agt.indexOf('opera')==-1) 
&& (agt.indexOf('webtv')==-1)); 
var is_nav2 = (is_nav && (is_major == 2)); 
var is_nav3 = (is_nav && (is_major == 3)); 
var is_nav4 = (is_nav && (is_major == 4)); 
var is_nav4up = (is_nav && (is_major >= 4)); 
var is_navonly      = (is_nav && ((agt.indexOf(";nav") != -1) || 
(agt.indexOf("; nav") != -1)) ); 
var is_nav5 = (is_nav && (is_major == 5)); 
var is_nav5up = (is_nav && (is_major >= 5)); 

Comment 8

17 years ago
I can't prove it conclusively yet, but this is almost certainly a 
problem with layers and insufficient or unused browser detection code.

Someone will have to see if they actually use the browser-sniffing file.
When I load the site and try javascript:alert(is_nav), it generates
an error in the JavaScript console: "is_nav is not defined".

At any rate, this is certainly not a JS Engine bug. 
Based on the evidence so far, reassigning to Evangelism component -
Assignee: rogerl → bclary
Component: Layout → Evangelism
QA Contact: pschwartau → zach
Summary: Webvan category tree not displayed → [LAYER]Webvan category tree not displayed

Comment 9

17 years ago
Also see problem on Linux (as one would expect). OS --> All.
OS: Windows 98 → All
(Reporter)

Comment 10

17 years ago
I just tried accessing this site using Netscape 6.1PR1 [Mozilla/5.0 (Windows; U;
Win98; en-US; rv:0.9.1) Gecko/20010607 Netscape6/6.1b1] and the menu appeared
correctly.  In the Mozilla 0.9.1 browser [Mozilla/5.0 (Windows; U; Win98; en-US;
rv:0.9.1) Gecko/20010607] the menu still does not appear.  So for some reason
Netscape works and Mozilla doesn't, even though they are apparently using the
same version of Gecko.
(Assignee)

Updated

17 years ago
Priority: -- → P2

Comment 11

17 years ago
This has been happening under the last few Mac milestones as well (0.8, 0.9, 0.9.1 and 
0.9.2), so I recommend changing Platform to "All".

Should this get the evangelism keyword, also? Shouldn't they not be using LAYER at this 
point?

Comment 12

17 years ago
Oops, it already has evangelism. Sorry, my bad.
(Reporter)

Comment 13

16 years ago
Webvan has shut down their web site and announced bankruptcy, so this bug is now
moot.
(Assignee)

Comment 14

16 years ago
yeehaw! I love the new economy! -> WONTFIX
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
(Assignee)

Comment 15

16 years ago
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified

Comment 16

16 years ago
Verified per instructions at http://mozilla-evangelism.bclary.com/evangelism.html
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.