Error applying Incomplete Tasks filter in Task View [Error: getRidKey(...) is null]

RESOLVED FIXED in 2.2

Status

Calendar
Internal Components
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: mmecca, Assigned: mmecca)

Tracking

({regression})

Lightning 2.2
regression

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Attempting to switch to the Incomplete Tasks filter in Lightning 2.2a2 fails and results in multiple occurrences of:

Error: getRidKey(...) is null
Source File: resource://calendar/modules/calUtils.jsm -> file:///.../calendar-js/calRecurrenceInfo.js
Line: 352
(Assignee)

Comment 1

5 years ago
Additionally the unit test test_recur.js is failing with:

TEST-UNEXPECTED-FAIL | xpcshell/head.js | [Exception... "'[JavaScript Error: "getRidKey(...) is null" {file: "resource://calendar/modules/calUtils.jsm -> file:///.../calendar-js/calRecurrenceInfo.js" line: 352}]' when calling method: [calIRecurrenceInfo::getNextOccurrence]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: /home/main/mozilla/obj-i686-pc-linux-gnu-comm-central/mozilla/_tests/xpcshell/calendar/test/unit/test_recur.js :: test_recur :: line 191"  data: yes]
(Assignee)

Comment 2

5 years ago
Regression likely caused by Bug 734245
Blocks: 734245
(Assignee)

Comment 3

5 years ago
Created attachment 700175 [details] [diff] [review]
Fix v1

Handle null return from getRidKey()
Assignee: nobody → matthew.mecca
Status: NEW → ASSIGNED
Attachment #700175 - Flags: review?(philipp)
Attachment #700175 - Flags: approval-calendar-aurora?(philipp)
Attachment #700175 - Flags: review?(philipp)
Attachment #700175 - Flags: review+
Attachment #700175 - Flags: approval-calendar-aurora?(philipp)
Attachment #700175 - Flags: approval-calendar-aurora+
(Assignee)

Comment 4

5 years ago
https://hg.mozilla.org/comm-central/rev/b3ab7e13840b
https://hg.mozilla.org/releases/comm-aurora/rev/c7cf156f150a
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.2
You need to log in before you can comment on or make changes to this bug.