YouTube content loads much slower than before

VERIFIED WORKSFORME

Status

P2
normal
VERIFIED WORKSFORME
6 years ago
6 years ago

People

(Reporter: clee, Assigned: djf)

Tracking

({regression})

unspecified
x86
Mac OS X
regression

Firefox Tracking Flags

(b2g18+)

Details

(Reporter)

Description

6 years ago
I'm on today's 1/9 build and the YouTube experience is much better.  However, the loading of content is taking much longer than previously.

STR:

*Launch the e.me YouTube app
*Select any video to play

Expected:

*Video progressively loads in <5 secs (regression as this previously was much quicker)

Actual:

*Actual loading time sometimes exceeds 10 secs
We will not block V1, but we would take a patch.
blocking-basecamp: ? → -
tracking-b2g18: --- → +
Keywords: regression
Priority: -- → P2

Comment 2

6 years ago
I can confirm this, and in fact took closer to 20-25 seconds between the time i tapped play, and watched it launch video player, find the file, and start playing back.   

i believe this is a regression as well.   but wouldnt bb+ this since 1) youtube isnt a default app, 2) there's at least a loading throbber and 3) video eventually does play.
(In reply to Tony Chung [:tchung] from comment #2)
> I can confirm this, and in fact took closer to 20-25 seconds between the
> time i tapped play, and watched it launch video player, find the file, and
> start playing back.   
> 
> i believe this is a regression as well.   but wouldnt bb+ this since 1)
> youtube isnt a default app, 2) there's at least a loading throbber and 3)
> video eventually does play.

[1] is wrong. YouTube does plan to be a preloaded app. Maybe that might imply this is tef+ possibly.
blocking-basecamp: - → ?

Updated

6 years ago
blocking-b2g: --- → tef?
Just to get my wording clear, I'm arguing for:

basecamp-, tef+
Putting needsinfo on kward to confirm my statements about YouTube being a preloaded app.
Flags: needinfo?(kward)
blocking-b2g: tef? → tef+
blocking-basecamp: ? → -
(Reporter)

Comment 6

6 years ago
I would say this is a blocker -- given YouTube may be a default app.

I am confirming with BD if YouTube will be a default app.

Comment 7

6 years ago
I confirm that YouTube is a Pre-installed app for Telefonica.
Flags: needinfo?(kward)
(Reporter)

Comment 8

6 years ago
Per comment 7, this should be a blocker.  

Drivers, can we assign this out asap to have someone investigate?  Thanks.
blocking-basecamp: - → ?
(In reply to Chris Lee [:clee] from comment #8)
> Per comment 7, this should be a blocker.  
> 
> Drivers, can we assign this out asap to have someone investigate?  Thanks.

I think there's agreement this blocks, but not Jan 15th. Dietrich I recall mentioning on a side thread that preload issues could be taken care of after Jan 15th. Am I wrong to assume that?
(Reporter)

Comment 10

6 years ago
Preload yes can be addressed afterwards, however, I'm calling this out in case there's a platform change that caused this regression.  I'd be surprised if this was a change that YouTube made that slowed the loading of videos.
We can't reproduce this. tracking to keep in the radar.
blocking-basecamp: ? → -

Updated

6 years ago
Component: Gaia → Gaia::Video
QA Contact: mozillamarcia.knous
(Assignee)

Comment 12

6 years ago
The speed seems okay to me, I'm not sure how to reproduce this one. Setting qaneeded for help figuring out if this is still reproducible.

I'm the one who modified the youtube playback code most recently. Some code moved from chrome to the video app, but that shouldn't have slowed things down.   Unless somehow we're now downloading a higher-quality larger stream or something, but I don't think so.

Do you notice a difference between playback from e.me and when you just use the browser and go to m.youtube.com?  I see that the e.me version displays a crawling ants animation where the browser doesn't. That might affect the speed a bit.
Keywords: qawanted
(Assignee)

Comment 13

6 years ago
If this continues to be a problem, another approach we can try is to first download a poster image for the video, and display that while waiting for the video itself. When I first attempted this, it did not work trivially (poster image came out the wrong size), and the video was starting to play quickly, so I didn't pursue that option.

But really, for me, on a wifi connection, videos load quickly enough.

clee: were you in Berlin when you filed this bug? Using shared wifi?  Could that have been the problem?
Flags: needinfo?(clee)
Assignee: nobody → dflanagan
blocking-basecamp: - → ---
If we're not able to reproduce, or this only happens intermittently, this is not critical enough to fix for 1.0.0.

Chris will comment.
blocking-b2g: tef+ → tef?
(Reporter)

Comment 15

6 years ago
I'm unable to repro this in today's build (jan 15) so I will close this bug.
Flags: needinfo?(clee)
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
blocking-b2g: tef? → ---

Updated

6 years ago
Status: RESOLVED → VERIFIED
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.