Reviewer tools cert script doesn't work on a UNIX-like OS (Mac or Linux)

RESOLVED DUPLICATE of bug 824198

Status

RESOLVED DUPLICATE of bug 824198
6 years ago
6 years ago

People

(Reporter: krupa.mozbugs, Unassigned)

Tracking

Points:
---

Details

(Reporter)

Description

6 years ago
steps to reproduce:
1. Make sure you are on the latest gaia build
2. Go to the prod reviewer tools via the browser
3. Pick a packaged app and try to install it from the reviewer tools page


expected behavior:
App installs from the reviewer tools works fine.

observed behavior:
App installs from the reviewer tools fail with "Download stopped" error message. The app ends up being partially installed.

logcat shows-
01-09 17:44:50.682 E/GeckoConsole(  108): Content JS INFO at app://system.gaiamobile.org/js/app_install_manager.js:187 in ai_handleDownloadError: downloadError event, error code is INVALID_SIGNATURE

This indicates a problem with the signing service.
1. Did you install the prod reviewer cert onto the device? No reviewer cert is trusted by default by the device.

2. Please attach an app signed with the prod reviewer cert so I can test the client end.
blocking-basecamp: --- → ?
I'll take a look at this at the work week with bsmith to see we can reproduce.
Keywords: qawanted
QA Contact: jsmith

Updated

6 years ago
Component: Reviewer Tools → General
Product: Marketplace → Boot2Gecko
Target Milestone: 2013-01-10 → ---
Version: 1.0 → unspecified
I'm going to operate first under the assumption that this is a gecko bug for safety. If we end up finding out that is wrong, then let's move the bug back.

That way, b2g triage will see this on their radar. Cause if this is confirmed to not work and ends up being a gecko problem, then this definitely blocks.

Updated

6 years ago
Flags: needinfo?(jsmith)
Talked with bsmith about this - the script he wrote only targets Windows, Krupa ran the script on Mac, which won't work correctly.

So it's a script bug. No need to raise to basecamp blocking then.
blocking-basecamp: ? → ---
Component: General → Reviewer Tools
Flags: needinfo?(jsmith)
Keywords: qawanted, regression
Product: Boot2Gecko → Marketplace
Version: unspecified → 1.0

Updated

6 years ago
Summary: Reviewer tools cert doesn't work on my unagi phone → Reviewer tools cert script doesn't work on a UNIX-like OS (Mac or Linux)
I am going to use bug 824198 to fix these issues.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 824198
You need to log in before you can comment on or make changes to this bug.