[Open_][Freetest][Voicemail]Unable to dial voicemail number via "1" on dialpad.(EC:617001923585)

RESOLVED FIXED

Status

P1
normal
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Firefox_Mozilla, Assigned: jaoo, NeedInfo)

Tracking

({regression})

unspecified
regression

Firefox Tracking Flags

(blocking-b2g:shira+, b2g18 verified, b2g18-v1.0.1 verified)

Details

(Whiteboard: [triaged:1/22] QARegressExclude)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Steps:
longpress "1" on dialpad

Expected result:
Should dial voicemail number successfully.(prompt user message if voicemail number not setted)

Actual result:
Unable to dial voicemail number via "1" on dialpad,and there is no any voicemail setting item related in Settings.
(Reporter)

Updated

6 years ago
OS: Gonk (Firefox OS) → All
Hardware: Other → All
Triage: long press 1 does not go to voice mail. Need to block this.
blocking-basecamp: --- → ?
not working on 20130110080534
Keywords: regression
Which SIM Card are you using?
Flags: needinfo?(Firefox_Mozilla)
Can reproduce with T-Mobile (de) SIM card on today's build.
It works with a Movistar SIM Card, but the way to get the Voice Mail differs across operators and SIM CArds. Jose Antonio, can you do a quick test with TMobile SIM or VIVO SIM Card?
Flags: needinfo?(josea.olivera)
i am using the T-Mobile (DE) sim right now on my build. i cannot dial voice mail by long pressing 1
(Assignee)

Comment 7

6 years ago
(In reply to Firefox_Mozilla from comment #0)
> Steps:
> longpress "1" on dialpad
> 
> Expected result:
> Should dial voicemail number successfully.(prompt user message if voicemail
> number not setted)
> 
> Actual result:
> Unable to dial voicemail number via "1" on dialpad,and there is no any
> voicemail setting item related in Settings.

Could you add the commit hashes for Gecko and Gaia please?
Flags: needinfo?(josea.olivera)
(Assignee)

Comment 8

6 years ago
(In reply to Daniel Coloma:dcoloma from comment #5)
> It works with a Movistar SIM Card, but the way to get the Voice Mail differs
> across operators and SIM CArds. Jose Antonio, can you do a quick test with
> TMobile SIM or VIVO SIM Card?

Apparently It works with VIVO and Movistar SIM cards. That's not the case for T-Mobile (de) SIM card. Was that working (T-Mobile case) on previous builds? If the VM number is not in the ICC card and we don't have the VM number for T-Mobile (mcc/mnc 262/1) in the fallback mechanism implemented through the operator variant logic this feature won't work never. Taking a look to verify the latter.
(Assignee)

Comment 9

6 years ago
Got it. The VM is not in the T-Mobile SIM card and the fallback mechanism implemented through the operator variant logic doesn't have the VM for this (mcc/mnc 262/1) operator. The solution would be to add it in the fallback mechanism.
Not blocking then for target markets, un-nominating. If the bug affects a target market please re-nominate.
blocking-basecamp: ? → ---
Triage: partner Movistar contact person mentioned that not all Movistar SIMs have voice mail number in the SIM. Just to be extra careful, do you need to have a double confirmation? :dcoloma?
blocking-b2g: --- → tef?
tracking-b2g18: --- → ?
Flags: needinfo?(Firefox_Mozilla) → needinfo?(dcoloma)
If the SIM Card does not have the voicemail number stored in the card, the operator variant will be able to determine which is the voicemail phone number. Indeed, most of Movistar SIM Cards do not have the voicemail number stored there and this feature is working in Spain.
Flags: needinfo?(dcoloma)
blocking-b2g: tef? → shira?
Moving to shira? since this will affect German users.
blocking-b2g: shira? → shira+
Whiteboard: [triaged:1/22]

Updated

6 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Group: partner-confidential → mozilla-corporation-confidential
Group: mozilla-corporation-confidential
talked to Kev to find out v1.0.1 testing support to confirm bug for v1.0.1
Flags: needinfo?(kev)
Want to make sure everyone knows that Shira is targeting 2/15 code freeze. 
Shira+ bugs needs more attention for unassigned, needinfo?,  review?
Full regression test is planned on 2/6. Need to have shira+ bugs landed by the end of 2/5 to be covered in full regression testing. Thanks

Updated

6 years ago
tracking-b2g18: ? → ---

Updated

6 years ago
Assignee: nobody → josea.olivera
tracking-b2g18: --- → ?
(In reply to Lukas Blakk [:lsblakk] from comment #13)
> Moving to shira? since this will affect German users.

Since this affects German users I'd need to know the MCC and MNC codes for those ICC cards that don't have the VM number stored in the ICC card. The fallback mechanism implemented through the operator variant logic relies on these codes to let the dialer knows the VM number if it's not stored in the ICC card.
I saw dailer only get voicemail number from mozSettings 'ril.iccInfo.mbdn', looks we don't have fallback mechanism in gaia.

does the mechanism exist in gecko?
(In reply to Yuren Ju [:yurenju] from comment #17)
> I saw dailer only get voicemail number from mozSettings 'ril.iccInfo.mbdn',
> looks we don't have fallback mechanism in gaia.
> 
> does the mechanism exist in gecko?

The dialer apps get the VM number from mozVoicemMail API, on the other hand there is a fallback mechanism (operaator variant mechanism) which assign the VM in the `ril.iccInfo.mbdn` setting if the VM is not stored in the SIM. The problem here is that the operator variant mechanism doesn't have the VM number for the SIM card (the one used to reproduce this bug) from T-Mobile Germany.

I *only* need the MCC and MNC codes for the T-Mobile SIMs in Germany.

If nobody else provide me this codes I'll go forward and look for them in the Internet. Anyone from QA who can help me?
T-Mobile DE SIM that i used in Germany
MCC: 262
MNC: 01
Cool, patch's comming. Thx!
Created attachment 710129 [details]
Pointer to Github PR: https://github.com/mozilla-b2g/gaia/pull/7964

Kaze, this PR is about adding the voice mail number for T-Mobile Germany SIM to the operator_variant.xml database. It seems the SIM from that operator/country does not have it stored in the SIM a we need to add the VM number to the operator variant mechanism database. Thanks!
Attachment #710129 - Flags: review?(kaze)
(In reply to José Antonio Olivera Ortega [:jaoo] from comment #21)
> Created attachment 710129 [details]
> Pointer to Github PR: https://github.com/mozilla-b2g/gaia/pull/7964

Oop, forget something important in my last comment. I've already tested these changes with a T-mobile Germany SIM. It seems to work but a double-check from someone currently in Germany (T-Mobile user) would be nice.
:andreas.utrap, do you think you could provide the information needed for voicemail speed dial for all the v1.0.1 target markets? thanks
Flags: needinfo?(kev) → needinfo?(andreas.utrap)
Canceling tracking request, already nom'd for Shira.
tracking-b2g18: ? → ---
Comment on attachment 710129 [details]
Pointer to Github PR: https://github.com/mozilla-b2g/gaia/pull/7964

Sounds good. I feel like things we're adding in the operator_variant should be upstreamed at some point because if we need to add them here it means the gnome database does not have it. But this is way out of the scope of this bug.
Attachment #710129 - Flags: review?(kaze) → review+
(In reply to Vivien Nicolas (:vingtetun) (:21) from comment #25)
> Comment on attachment 710129 [details]
> Pointer to Github PR: https://github.com/mozilla-b2g/gaia/pull/7964
> 
> Sounds good. I feel like things we're adding in the operator_variant should
> be upstreamed at some point because if we need to add them here it means the
> gnome database does not have it. But this is way out of the scope of this
> bug.

Done, see https://bugzilla.gnome.org/show_bug.cgi?id=693589 please.
(In reply to Vivien Nicolas (:vingtetun) (:21) from comment #26)
> https://github.com/mozilla-b2g/gaia/commit/
> 344db19fba185a05916d5b42fafabf3f10d87574

Has this landed to v1-train? If so, let's mark status-b2g18 as fixed.
v1-train: 9db28611a4d1c41c3f7b2976d1cfb5b3e0549e88
v1.0.1: 2dc7c447f54712806254938082af0a591fe628a1
status-b2g18: --- → fixed
status-b2g18-v1.0.1: --- → fixed
Duplicate of this bug: 841703
Verified:
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/dc3add076016
Gaia   1e1c8c0ff2bc7f252fbe95016f108e38ece691a9
BuildID 20130314070204
Version 18.0
Unagi
status-b2g18: fixed → verified

Comment 32

6 years ago
Only able to verified the fix Unagi Device with USA AT&T and T-mobile sim cards

Verified fixed on 
Unagi Build ID: 20130329070203
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/56c922308fd1
Gaia: 0a9f78bffafda93a159c1f502e8b110c2f49a500

and 

Unagi Build ID: 20130329070203
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/56c922308fd1
Gaia: 0a9f78bffafda93a159c1f502e8b110c2f49a500
status-b2g18-v1.0.1: fixed → verified

Comment 33

6 years ago
Do apologies I mistakenly put the same two device...  here are the correct ones.  

Only able to verified the fix Unagi Device with USA AT&T and T-mobile sim cards
Verified fixed on 
Unagi Build ID: 20130329070203
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/56c922308fd1
Gaia: 0a9f78bffafda93a159c1f502e8b110c2f49a500

and

Unagi Build ID: 20130329070203
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/5cc5df16447a
Gaia: 26b463f14caa11e0fc64fda09a17054da4bea68b

Comment 34

6 years ago
Here in Korea, it's not working on d300.
For the test, I added voicemail number information in apn.json, operator_variant.xml, service_providers.xml files.

Mcc/Mnc : 450/00

jaoo, can you check this out for me?

Thanks
(In reply to leo.bugzilla.gecko from comment #34)
> Mcc/Mnc : 450/00

Ugh, I think the current code base considers a null MNC code as invalid. :-/
(In reply to leo.bugzilla.gecko from comment #34)
> Mcc/Mnc : 450/00

There is no information about that carrier (MCC/MNC) in existing APN databases, is it a virtual one?

Comment 37

6 years ago
(In reply to José Antonio Olivera Ortega [:jaoo] from comment #36)
> (In reply to leo.bugzilla.gecko from comment #34)
> > Mcc/Mnc : 450/00
> 
> There is no information about that carrier (MCC/MNC) in existing APN
> databases, is it a virtual one?

hmm. It's not commonly used by customers. But it used for test internally in korea.

I think that problem is came from when we use customization build.

I'll figure it out deeper and leave comment soon.

Updated

6 years ago
Whiteboard: [triaged:1/22] → [triaged:1/22] QARegressExclude

Comment 38

6 years ago
Cannot verify, we do not have access to check with all affected SIM cards.
You need to log in before you can comment on or make changes to this bug.