[bluetooth] Successfully Paired device shows wrong state

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Settings
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: marcia, Unassigned)

Tracking

({unagi})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 700181 [details]
Screenshot of issue

Seen while running unagi, using

Gecko: 3808444b9923
Gaia: 03cdcbfecb2c

STR:
1. Turn on Bluetooth in Settings and pair a Plantronics headset
2. Confirm you can receive an incoming call successfully.
3. Observe the attached screenshots 

The two main issues is that settings shows the incorrect state when the device is successfully connected, and generates the error message in the second screenshot when the device is successfully connected.
(Reporter)

Comment 1

5 years ago
Bug 827884 cover the error screen issue.
Summary: [bluetooth] Successfully Paired device still shows an error screen as well as wrong state → [bluetooth] Successfully Paired device shows wrong state
Depends on: 850157
Can anyone help to verify this bug with the latest build?
Whiteboard: qawanted

Updated

4 years ago
Keywords: qawanted
Whiteboard: qawanted

Comment 3

4 years ago
I could NOT reproduce this issue with the 11/15/13 1.2 and 1.3 builds. The state displayed correctly for all three devices that are available to us for testing.

Bluetooth devices tested:
-Rocketfish RF-QX4
-Go Groove AirBand GG-AIR-BAND2
-Jabra SP200


- 1.2 BUILD -
Environmental Variables:
Device: Buri v1.2 COM RIL
BuildID: 20131115004003
Gaia: a6484b1e6fc07cf6bd8d6fcf9aeebb14b7e8869d
Gecko: ff2c7c9d01d6
Version: 26.0
Firmware Version: 20131104

- 1.3 BUILD -
Environmental Variables:
Device: Buri v1.3 MOZ RIL
BuildID: 20131115040200
Gaia: ac42cb33f21b3f13595432c965f44615daae2225
Gecko: b2fab608772f
Version: 28.0a1
Firmware Version: 20131104
Keywords: qawanted
QA Contact: mvaughan

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.