Closed Bug 828811 Opened 7 years ago Closed 7 years ago

[bluetooth] Cannot send file twice

Categories

(Core :: DOM: Device Interfaces, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla21
blocking-basecamp +
Tracking Status
firefox19 --- wontfix
firefox20 --- wontfix
firefox21 --- fixed
b2g18 --- fixed

People

(Reporter: iliu, Assigned: gyeh)

Details

Attachments

(1 file)

Repro:
1) install 20130109070203 unagi nightly
2) settings -> bluetooth -> pair a device
3) sending a file to other paired unagi
4) wait transferring task completely
5) repeat step 3)

Expected:
- It should send file normally.

Actual:
- Cannot send file in the second time.


Reference comment from:
https://bugzilla.mozilla.org/show_bug.cgi?id=806277#c5
I enable the debug message in Bluetooth app. Then, we can see..
E/GeckoConsole(  527): Content JS LOG at app://bluetooth.gaiamobile.org/js/transfer.js:60 in debug: [Bluetooth APP Send File]: Can not get adapter connect!

It looks like that Bluetooth app cannot get the adapter connect again.
The issue should be bb+.
Note:
The issue can be reproduced on Unagi -> Unagi.
The issue cannot be reproduced on Unagi -> SS GALAXY Tab 7.7.

According Gina's mention, it's a know issue about connected/disconnected socket actively when bluetooth sent file completely. Some of the device will disconnect socket actively. So, the issue cannot be reproduced.(Such as SS GALAXY Tab 7.7)
It could be a platform issue.
Confirmed. Nominate as a bb+ since it's 100% reproduciable.
Assignee: iliu → echou
Component: Gaia::Bluetooth File Transfer → DOM: Device Interfaces
Product: Boot2Gecko → Core
QA Contact: wachen
Confirmed. And, the only solution to send another file is restart the phone. It should be bb+
blocking-basecamp: ? → +
Please see comment for more information.
Assignee: echou → gyeh
Attachment #700303 - Flags: review?(echou)
Comment on attachment 700303 [details] [diff] [review]
Patch 1(v1): Cannot send file twice

Review of attachment 700303 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, but please describe more in the commit description.

::: dom/bluetooth/BluetoothOppManager.cpp
@@ +171,5 @@
> +      return;
> +    }
> +
> +    if (sInstance->
> +          GetConnectionStatus() == SocketConnectionStatus::SOCKET_CONNECTED) {

Nit: breaking the line after '==' would be better

if (sInstance->GetConnectionStatus() ==
      SocketConnectionStatus::SOCKET_CONNECTED) {
Attachment #700303 - Flags: review?(echou) → review+
https://hg.mozilla.org/releases/mozilla-b2g18/rev/f935eaf068d3
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla21
Verified fixed on Unagi build 201301120702022.
Was able to bluetooth transfer a music file from Unagi to Unagi, then a photo file.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.