Settings view should have a done button on the right instead of a cross closing icon on the left

VERIFIED FIXED

Status

Firefox OS
Gaia::Contacts
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Jose Manuel Cantera, Assigned: Jose Manuel Cantera)

Tracking

unspecified
x86
Mac OS X

Firefox Tracking Flags

(b2g18+ fixed, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 fixed)

Details

(Whiteboard: UX-P1, TEF_REQ)

Attachments

(2 attachments, 2 obsolete attachments)

Comment hidden (empty)
(Assignee)

Updated

5 years ago
tracking-b2g18: --- → ?
Summary: In → Settings view should have a done button on the right instead of a cross closing icon on the left

Comment 1

5 years ago
I have fixed this, pull request link: https://github.com/mozilla-b2g/gaia/pull/7777

Comment 2

5 years ago
Can you provide a screenshot?
tracking-b2g18: ? → +
Tracking, please provide screenshot and approval nomination request for uplift consideration.
(Assignee)

Comment 4

5 years ago
(In reply to sergey.rossokha from comment #1)
> I have fixed this, pull request link:
> https://github.com/mozilla-b2g/gaia/pull/7777

Sergey please could you ask me for a review? You can attach your PR similarly as it has been done for instance in bug 835555 and then put the r? flag over it

thanks!

Comment 5

5 years ago
Hi Joe, how I can do this? Sorry I'm new in BZ :(

Comment 6

5 years ago
Hi Jose, how I can do this? Sorry I'm new in BZ :(

Comment 7

5 years ago
Created attachment 710973 [details]
Contact settings page with "Done" button

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed: 
Risk to taking this patch (and alternatives if risky): 
String or UUID changes made by this patch:

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed: 
Risk to taking this patch (and alternatives if risky):
Attachment #710973 - Flags: review?(jmcf)
Attachment #710973 - Flags: approval-mozilla-b2g18?

Comment 8

5 years ago
Created attachment 710983 [details]
Pointer to GH 7777 PR

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed: 
Risk to taking this patch (and alternatives if risky):
Attachment #710983 - Flags: review?(jmcf)
Attachment #710983 - Flags: approval-gaia-v1?

Updated

5 years ago
Attachment #710983 - Attachment mime type: text/plain → text/html
status-b2g18: --- → affected
status-b2g18-v1.0.0: --- → wontfix
(Assignee)

Comment 9

5 years ago
Comment on attachment 710973 [details]
Contact settings page with "Done" button

Sergei,

Before merging this, Please we need you to change the commit message to be equal to the bug number + description as it happens with other commits. If you don't know how to do do that please ask me by e-mail or IRC 'joseCantera'

thanks!
Attachment #710973 - Flags: review?(jmcf) → review+
Comment on attachment 710983 [details]
Pointer to GH 7777 PR

Assuming the r+ was meant for this code change, approving for v1.0.1.
Attachment #710983 - Flags: approval-gaia-v1? → approval-gaia-v1+
Comment on attachment 710973 [details]
Contact settings page with "Done" button

Clearing the approval flag on this screenshot.
Attachment #710973 - Flags: approval-mozilla-b2g18?
status-b2g18-v1.0.1: --- → affected
Created attachment 712854 [details]
The same but with correct commit message
Attachment #710983 - Attachment is obsolete: true
Attachment #710983 - Flags: review?(jmcf)
Attachment #712854 - Flags: review?(jmcf)
(Assignee)

Updated

5 years ago
Attachment #712854 - Flags: review?(jmcf) → review+
https://github.com/mozilla-b2g/gaia/commit/a22bac2a4e4542a01654b9d3b7ae1bd50afd7199
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 14

5 years ago
Comment on attachment 712854 [details]
The same but with correct commit message

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: UX global consistency will suffer
Testing completed: yes
Risk to taking this patch (and alternatives if risky): very low, only presentation changed
Attachment #712854 - Flags: approval-gaia-v1?

Comment 15

5 years ago
Created attachment 712877 [details]
Contact settings page with "Done" button

I've updated the reference screenshot because it was using some outdated visual elements
Attachment #710973 - Attachment is obsolete: true

Comment 16

5 years ago
It's important to land this patch asap because it has a huge impact in the app experience. As far as we are not saving the state when the user makes a change, but we are applying it immediately, it makes no sense to have an "X" and a "Done" button in the header because both of them do the same thing. The recommendation is to leave the "Done" button and remove the "X".
(Assignee)

Comment 17

5 years ago
patch landed on master today and hopefully will do so in train once we get an approval

Updated

5 years ago
Whiteboard: UX-P1, TEF_REQ

Updated

5 years ago
Attachment #712854 - Flags: approval-gaia-v1? → approval-gaia-v1+
v1-train: 72d348085bf20a68cacc5825374ef23a99d9522a
status-b2g18: affected → fixed
status-b2g18-v1.0.1: affected → fixed
Batch edit: bugs fixed on b2g18 since 1/25 branch of v1.0 are fixed on v1.0.1

Comment 20

5 years ago
Verified with 02/18 build: Gecko-0ecc076.Gaia-4164424
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.