Accessing the "Synced" section when is empty closes the tab menu

VERIFIED FIXED in Firefox 20

Status

()

Firefox for Android
General
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Paul Feher, Assigned: sriram)

Tracking

20 Branch
Firefox 21
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox20 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Nightly 20.0a2 2012-01-10
Device: Samsung Galaxy R
OS: Android 2.3.4

Steps to reproduce:
1. Open Firefox for Android with a clean profile( No sync session was set-up before)
2. Open tab menu.
3. Select "Synced" section.

Expected results:
Selecting Synced section should keep the tab menu opened because the user might want to initiate another operation in tab menu section. Also selecting the "Private" option doesn’t close the tab menu if it's empty.

Actual results:
Selecting Synced section closes the tab menu.
Actually, if the Synced section is empty, the tab should never appear.
Assignee: nobody → sriram
Depends on: 828329
(Assignee)

Comment 2

5 years ago
Created attachment 709935 [details] [diff] [review]
Patch

This removes automatically closing the tabs, when sync is not set up.
Attachment #709935 - Flags: review?(mark.finkle)
Attachment #709935 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 3

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/d300f7bb08c1
(Assignee)

Comment 4

5 years ago
Comment on attachment 709935 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Iconified tabs.
User impact if declined: Sync, when not set up, will close the tabs-panel.
Testing completed (on m-c, etc.): Landed in m-i on 02/12
Risk to taking this patch (and alternatives if risky): None. We return early, instead of hiding it.
String or UUID changes made by this patch: None.
Attachment #709935 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/d300f7bb08c1
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21

Updated

5 years ago
Keywords: verifyme

Updated

5 years ago
Attachment #709935 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 6

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/9e4a356f693e

Updated

5 years ago
status-firefox20: --- → fixed

Comment 7

5 years ago
Verified fixed on:
-build: Firefox for Android 20.0a2 (2013-02-15), Firefox for Android 21.0a1 (2013-02-15)
-device: Samsung Galaxy Tab 2 7.0
-OS: Android 4.0.4
Status: RESOLVED → VERIFIED

Updated

5 years ago
status-firefox20: fixed → verified

Updated

5 years ago
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.