If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[FTU] Feedback on imported contacts should be shown using a Banner

VERIFIED FIXED

Status

Firefox OS
Gaia::First Time Experience
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Sergi, Assigned: Jose Manuel Cantera)

Tracking

({late-l10n})

unspecified
x86
Mac OS X
late-l10n

Firefox Tracking Flags

(blocking-b2g:-, b2g18+ fixed)

Details

(Whiteboard: visual design, incorrect implementation)

Attachments

(2 attachments, 3 obsolete attachments)

(Reporter)

Description

5 years ago
Created attachment 700243 [details]
Import Contacts Feedback

We should use the "Banner" building block to notify the user about the result of the action, in this case importing contacts from the SIM.

IN the attached screenshot you will see the message at the bottom of the screen, that will automatically disappear. In case there's no contacts to import in the SIM, the banner will appear showing something like "No contacts found"
(Reporter)

Comment 1

5 years ago
This behavior should be the same used in Contact Settings
Component: Gaia::Contacts → Gaia::First Time Experience
QA Contact: isabelrios
Summary: [Contact] Feedback on imported contacts should be shown using a Banner → [FTU] Feedback on imported contacts should be shown using a Banner
(Reporter)

Updated

5 years ago
Whiteboard: visual design, incorrect implementation
(Assignee)

Updated

5 years ago
Assignee: nobody → jmcf
(Assignee)

Updated

5 years ago
Status: NEW → ASSIGNED
(Reporter)

Comment 2

5 years ago
Created attachment 701062 [details]
Import Contacts Feedback
Attachment #700243 - Attachment is obsolete: true
(Assignee)

Updated

5 years ago
blocking-b2g: --- → tef?
Perhpas not blocking, but it's necessary to implement the same behaviour than the implemented in Contact setting as UX is pointing out. 
Sure, it must be tracking-b2g18
tracking-b2g18: --- → ?
(Assignee)

Updated

5 years ago
Blocks: 831222
blocking-b2g: tef? → -
tracking-b2g18: ? → +
(Assignee)

Comment 4

5 years ago
Created attachment 704217 [details]
Pointer to GH 7690 PR
Attachment #704217 - Flags: review?(igonzaleznicolas)
Attachment #704217 - Flags: review?(fernando.campo)
Attachment #704217 - Flags: review?(igonzaleznicolas) → review+
(Assignee)

Comment 5

5 years ago
Comment on attachment 704217 [details]
Pointer to GH 7690 PR

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed: 
Risk to taking this patch (and alternatives if risky):
Attachment #704217 - Flags: approval-gaia-master?(francisco.jordano)
(Reporter)

Comment 6

5 years ago
Created attachment 704811 [details]
Import Contacts Feedback
Attachment #701062 - Attachment is obsolete: true
(Reporter)

Comment 7

5 years ago
Created attachment 704820 [details]
Import Contacts Feedback
Attachment #704811 - Attachment is obsolete: true
(Assignee)

Updated

5 years ago
Attachment #704217 - Flags: review?(stas)
(Assignee)

Comment 8

5 years ago
We need an additional review from L10n team as the title of the import section has been shortened as per UX and Tyler's recommendations.
Attachment #704217 - Flags: review?(fernando.campo) → review+
Keywords: late-l10n
Comment on attachment 704217 [details]
Pointer to GH 7690 PR

r=me

As Jose pointed out to me on IRC, "noSimMsg" is taken from contacts.properties which is included in the FTU.
Attachment #704217 - Flags: review?(stas) → review+
Comment on attachment 704217 [details]
Pointer to GH 7690 PR

Mostly markup change, the only js added is to show or hide the banner.

Tried on the phone and working ok.

a=me
Attachment #704217 - Flags: approval-gaia-v1?(francisco.jordano) → approval-gaia-v1+
Landed

https://github.com/mozilla-b2g/gaia/commit/2f535c6f63abe3a58acc5b95aa7309b35700a455
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
status-b2g18: --- → fixed
Verified fixed in 2013-02-05-07-02-01 pvt nightly b2g18 build
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.