Closed Bug 828870 Opened 7 years ago Closed 7 years ago

[DIALER][CONTACTS] When you try to add a contact from dialer, adding photos from camera or gallery are causing the process to finish unspectedly

Categories

(Firefox OS Graveyard :: General, defect, P3)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-basecamp:+, firefox19 wontfix, firefox20 wontfix, firefox21 fixed, b2g18 fixed)

VERIFIED FIXED
B2G C4 (2jan on)
blocking-basecamp +
Tracking Status
firefox19 --- wontfix
firefox20 --- wontfix
firefox21 --- fixed
b2g18 --- fixed

People

(Reporter: carlosmartinez, Assigned: bent.mozilla)

Details

(Whiteboard: testrun 2)

Attachments

(4 files)

Tested in unagi with Gecko-257e1c1 Gaia-ea325f7.

STR:
1-Open dialer app
2-Type a phone number
3-Tap in the add new contact button
4-Try to add a photo to the new contact (from camera or gallery)

Expected result --> Camera or gallery is opened and you can add a photo

Actual result --> Camera and gallery crashes and you´re redirected to dialer. No new contact created.
blocking-basecamp: --- → ?
Whiteboard: testrun 2
blocking-basecamp: ? → +
Priority: -- → P3
Target Milestone: --- → B2G C4 (2jan on)
Assignee: nobody → francisco.jordano
With today's build it's working for me.

Tried several times and the gallery or camera never crashes and we are able to create the contact with the photo.

Please reopen if we can reproduce.

Thanks,
Francisco
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Attached file logcat output
This seems easily reproducible.  In my logcat, I see this:

F(  468:0x1d4) Assertion failure: !isMutable, at /home/mikeh/dev/mozilla/m-c/inbound-src/dom/ipc/StructuredCloneUtils.cpp:55
F(  468:0x1d4) Fatal signal 11 (SIGSEGV) at 0x00000000 (code=1)

468:0x1d4 seems to be the window manager, based on: "E(  468:0x1d4) Content JS INFO at app://system.gaiamobile.org/js/window_manager.js:1087 in createFrame: %%%%% Launching Contacts as remote (OOP)"
(In reply to Francisco Jordano [:arcturus] from comment #1)
>
> With today's build it's working for me.

Hmm, my build is from very early this morning.  Will refresh and try to reproduce.
This still occurs on the current mozilla-inbound.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Attached file more logcat output
logcat:
I(  474:0x1da) [Child 474] ###!!! ASSERTION: op == PL_DHASH_LOOKUP || RECURSION_LEVEL(table) == 0: 'op == PL_DHASH_LOOKUP || RECURSION_LEVEL(table) == 0', file /home/mikeh/dev/mozilla/btg019/objdir-gecko-inbound-debug/xpcom/build/pldhash.cpp, line 575
F(  108:0x6c) Assertion failure: !isMutable, at /home/mikeh/dev/mozilla/m-c/inbound-src/dom/ipc/StructuredCloneUtils.cpp:55
F(  108:0x6c) Fatal signal 11 (SIGSEGV) at 0x00000000 (code=1)

474:0x1da - camera process Main Thread
108:0x6c - window manager
Backtrace of the ASSERTION in the camera process (with artificially induced MOZ_CRASH()):

Program received signal SIGSEGV, Segmentation fault.
0x41217688 in PL_DHashTableOperate (table=0x443efcac, key=0x4479c800, op=PL_DHASH_ADD)
    at /home/mikeh/dev/mozilla/btg019/objdir-gecko-inbound-debug/xpcom/build/pldhash.cpp:577
577	        MOZ_CRASH();
(gdb) bt
#0  0x41217688 in PL_DHashTableOperate (table=0x443efcac, key=0x4479c800, op=PL_DHASH_ADD)
    at /home/mikeh/dev/mozilla/btg019/objdir-gecko-inbound-debug/xpcom/build/pldhash.cpp:577
#1  0x40a9e654 in nsTHashtable<nsBaseHashtableET<nsPtrHashKey<mozilla::dom::AudioChannelAgent>, mozilla::dom::AudioChannelService::AudioChannelAgentData> >::PutEntry (this=0x443efca0, aAgent=0x4479c800, 
    aElementHidden=false) at ../../dist/include/nsTHashtable.h:184
#2  nsTHashtable<nsBaseHashtableET<nsPtrHashKey<mozilla::dom::AudioChannelAgent>, mozilla::dom::AudioChannelService::AudioChannelAgentData> >::PutEntry (this=0x443efca0, aAgent=0x4479c800, aElementHidden=false)
    at ../../dist/include/nsTHashtable.h:170
#3  nsBaseHashtable<nsPtrHashKey<mozilla::dom::AudioChannelAgent>, mozilla::dom::AudioChannelService::AudioChannelAgentData, mozilla::dom::AudioChannelService::AudioChannelAgentData>::Put (this=0x443efca0, 
    aAgent=0x4479c800, aElementHidden=false) at ../../dist/include/nsBaseHashtable.h:147
#4  nsBaseHashtable<nsPtrHashKey<mozilla::dom::AudioChannelAgent>, mozilla::dom::AudioChannelService::AudioChannelAgentData, mozilla::dom::AudioChannelService::AudioChannelAgentData>::Put (this=0x443efca0, 
    aAgent=0x4479c800, aElementHidden=false) at ../../dist/include/nsBaseHashtable.h:141
#5  mozilla::dom::AudioChannelServiceChild::GetMuted (this=0x443efca0, aAgent=0x4479c800, 
    aElementHidden=false)
    at /home/mikeh/dev/mozilla/m-c/inbound-src/dom/audiochannel/AudioChannelServiceChild.cpp:78
#6  0x40a9e8d2 in mozilla::dom::AudioChannelAgent::NotifyAudioChannelStateChanged (this=0x4479c800)
    at /home/mikeh/dev/mozilla/m-c/inbound-src/dom/audiochannel/AudioChannelAgent.cpp:111
#7  0x40a9d5c6 in mozilla::dom::AudioChannelService::NotifyEnumerator (aAgent=0x0, aData=..., 
    aUnused=<value optimized out>)
    at /home/mikeh/dev/mozilla/m-c/inbound-src/dom/audiochannel/AudioChannelService.cpp:283
#8  0x40a9d6a0 in nsBaseHashtable<nsPtrHashKey<mozilla::dom::AudioChannelAgent>, mozilla::dom::AudioChannelService::AudioChannelAgentData, mozilla::dom::AudioChannelService::AudioChannelAgentData>::s_EnumReadStub
    (table=<value optimized out>, hdr=<value optimized out>, number=<value optimized out>, 
    arg=<value optimized out>) at ../../dist/include/nsBaseHashtable.h:400
#9  0x412173ae in PL_DHashTableEnumerate (table=0x443efcac, etor=<value optimized out>, 
    arg=<value optimized out>)
    at /home/mikeh/dev/mozilla/btg019/objdir-gecko-inbound-debug/xpcom/build/pldhash.cpp:720
#10 0x40a9df20 in nsBaseHashtable<nsPtrHashKey<mozilla::dom::AudioChannelAgent>, mozilla::dom::AudioChannelService::AudioChannelAgentData, mozilla::dom::AudioChannelService::AudioChannelAgentData>::EnumerateRead (
    this=<value optimized out>) at ../../dist/include/nsBaseHashtable.h:190
#11 mozilla::dom::AudioChannelService::Notify (this=<value optimized out>)
    at /home/mikeh/dev/mozilla/m-c/inbound-src/dom/audiochannel/AudioChannelService.cpp:293
#12 0x40fdffb4 in mozilla::dom::ContentChild::RecvAudioChannelNotify (this=<value optimized out>)
    at /home/mikeh/dev/mozilla/m-c/inbound-src/dom/ipc/ContentChild.cpp:456
#13 0x410c69e2 in mozilla::dom::PContentChild::OnMessageReceived (this=0x4262c818, __msg=...)
    at /home/mikeh/dev/mozilla/btg019/objdir-gecko-inbound-debug/ipc/ipdl/PContentChild.cpp:2325
#14 0x41002716 in mozilla::ipc::AsyncChannel::OnDispatchMessage (this=0x4262c820, msg=...)
    at /home/mikeh/dev/mozilla/m-c/inbound-src/ipc/glue/AsyncChannel.cpp:473
#15 0x4100900c in mozilla::ipc::RPCChannel::OnMaybeDequeueOne (this=0x4262c820)
    at /home/mikeh/dev/mozilla/m-c/inbound-src/ipc/glue/RPCChannel.cpp:402
#16 0x40fd9548 in DispatchToMethod<mozilla::dom::ContentParent, void (mozilla::dom::ContentParent::*)()> (
    this=<value optimized out>)
    at /home/mikeh/dev/mozilla/m-c/inbound-src/ipc/chromium/src/base/tuple.h:383
#17 RunnableMethod<mozilla::dom::ContentParent, void (mozilla::dom::ContentParent::*)(), Tuple0>::Run (
    this=<value optimized out>)
    at /home/mikeh/dev/mozilla/m-c/inbound-src/ipc/chromium/src/base/task.h:307
#18 0x4100745e in mozilla::ipc::RPCChannel::RefCountedTask::Run (this=0x443bda00)
    at ../../dist/include/mozilla/ipc/RPCChannel.h:425
#19 mozilla::ipc::RPCChannel::DequeueTask::Run (this=0x443bda00)
    at ../../dist/include/mozilla/ipc/RPCChannel.h:448
#20 0x4128400a in MessageLoop::RunTask (this=0xbede98a4, task=0x443bda00)
    at /home/mikeh/dev/mozilla/m-c/inbound-src/ipc/chromium/src/base/message_loop.cc:333
#21 0x41284834 in MessageLoop::DeferOrRunPendingTask (this=0x0, pending_task=<value optimized out>)
    at /home/mikeh/dev/mozilla/m-c/inbound-src/ipc/chromium/src/base/message_loop.cc:341
#22 0x41285586 in MessageLoop::DoWork (this=0xbede98a4)
    at /home/mikeh/dev/mozilla/m-c/inbound-src/ipc/chromium/src/base/message_loop.cc:441
#23 0x41006a7c in mozilla::ipc::DoWorkRunnable::Run (this=<value optimized out>)
    at /home/mikeh/dev/mozilla/m-c/inbound-src/ipc/glue/MessagePump.cpp:42
#24 0x4124e562 in nsThread::ProcessNextEvent (this=0x42607240, mayWait=<value optimized out>, 
    result=0xbede8daf) at /home/mikeh/dev/mozilla/m-c/inbound-src/xpcom/threads/nsThread.cpp:627
#25 0x412162d0 in NS_ProcessNextEvent_P (thread=0x0, mayWait=false)
    at /home/mikeh/dev/mozilla/btg019/objdir-gecko-inbound-debug/xpcom/build/nsThreadUtils.cpp:238
#26 0x41006c32 in mozilla::ipc::MessagePump::Run (this=0x426022e0, aDelegate=0xbede98a4)
    at /home/mikeh/dev/mozilla/m-c/inbound-src/ipc/glue/MessagePump.cpp:82
#27 0x41006dba in mozilla::ipc::MessagePumpForChildProcess::Run (this=0x426022e0, aDelegate=0xbede98a4)
    at /home/mikeh/dev/mozilla/m-c/inbound-src/ipc/glue/MessagePump.cpp:231
#28 0x412845be in MessageLoop::RunInternal (this=0xbede98a4)
    at /home/mikeh/dev/mozilla/m-c/inbound-src/ipc/chromium/src/base/message_loop.cc:215
#29 0x4128461e in MessageLoop::RunHandler (this=0xbede98a4)
    at /home/mikeh/dev/mozilla/m-c/inbound-src/ipc/chromium/src/base/message_loop.cc:208
#30 MessageLoop::Run (this=0xbede98a4)
    at /home/mikeh/dev/mozilla/m-c/inbound-src/ipc/chromium/src/base/message_loop.cc:182
#31 0x40f48062 in nsBaseAppShell::Run (this=0x432e3e80)
    at /home/mikeh/dev/mozilla/m-c/inbound-src/widget/xpwidgets/nsBaseAppShell.cpp:163
#32 0x4043baae in XRE_RunAppShell ()
    at /home/mikeh/dev/mozilla/m-c/inbound-src/toolkit/xre/nsEmbedFunctions.cpp:656
#33 0x41006d24 in mozilla::ipc::MessagePumpForChildProcess::Run (this=0x426022e0, aDelegate=0xbede98a4)
    at /home/mikeh/dev/mozilla/m-c/inbound-src/ipc/glue/MessagePump.cpp:198
#34 0x412845be in MessageLoop::RunInternal (this=0xbede98a4)
    at /home/mikeh/dev/mozilla/m-c/inbound-src/ipc/chromium/src/base/message_loop.cc:215
#35 0x4128461e in MessageLoop::RunHandler (this=0xbede98a4)
    at /home/mikeh/dev/mozilla/m-c/inbound-src/ipc/chromium/src/base/message_loop.cc:208
#36 MessageLoop::Run (this=0xbede98a4)
    at /home/mikeh/dev/mozilla/m-c/inbound-src/ipc/chromium/src/base/message_loop.cc:182
#37 0x4043c3c2 in XRE_InitChildProcess (aArgc=2, aArgv=0xbede99b4, aProcess=1113769984)
    at /home/mikeh/dev/mozilla/m-c/inbound-src/toolkit/xre/nsEmbedFunctions.cpp:494
#38 0x00008540 in main (argc=7, argv=0xbede9a24)
    at /home/mikeh/dev/mozilla/m-c/inbound-src/ipc/app/MozillaRuntimeMain.cpp:48

Looks like something may be up with the AudioChannelService.
Flags: needinfo?(mchen)
(Interestingly, the addition of the MOZ_CRASH() bombing out the camera app prevents the process running window_manager.js from crashing.)
With the artificial MOZ_CRASH() removed, this is the backtrace of the main b2g process when it MOZ_ASSERT()s:

Program received signal SIGSEGV, Segmentation fault.
0x415c698c in Read (aCx=0x4037e370, aReader=0xbe8ae520, aTag=4294934533, aData=3196773352, aClosure=0xbe8ae940) at /home/mikeh/dev/mozilla/m-c/inbound-src/dom/ipc/StructuredCloneUtils.cpp:87
87	        MOZ_ASSERT(!isMutable);
(gdb) bt
#0  0x415c698c in Read (aCx=0x4037e370, aReader=0xbe8ae520, aTag=4294934533, aData=3196773352, aClosure=0xbe8ae940) at /home/mikeh/dev/mozilla/m-c/inbound-src/dom/ipc/StructuredCloneUtils.cpp:87
#1  0x41aefbc4 in JSStructuredCloneReader::startRead (this=0xbe8ae520, vp=0xbe8ae4b0) at /home/mikeh/dev/mozilla/m-c/inbound-src/js/src/jsclone.cpp:1085
#2  0x41af0e62 in JSStructuredCloneReader::read (this=0xbe8ae520, vp=<value optimized out>) at /home/mikeh/dev/mozilla/m-c/inbound-src/js/src/jsclone.cpp:1184
#3  0x41af2356 in js::ReadStructuredClone (cx=<value optimized out>, data=<value optimized out>, nbytes=<value optimized out>, vp=0x7b, cb=0x4245dd80, cbClosure=0xbe8ae940) at /home/mikeh/dev/mozilla/m-c/inbound-src/js/src/jsclone.cpp:143
#4  0x41ab522c in JS_ReadStructuredClone (cx=0x4037e370, buf=0x47415b60, nbytes=232, version=1, vp=0xbe8ae780, optionalCallbacks=0x4245dd80, closure=0xbe8ae940) at /home/mikeh/dev/mozilla/m-c/inbound-src/js/src/jsapi.cpp:6328
#5  0x415c6abc in mozilla::dom::ReadStructuredClone (aCx=0x7b, aData=0xbe8adf70, aDataLength=3467875002, aClosure=<value optimized out>, aClone=0xbe8ae780) at /home/mikeh/dev/mozilla/m-c/inbound-src/dom/ipc/StructuredCloneUtils.cpp:175
#6  0x40e4095a in ReadStructuredClone (this=<value optimized out>, aTarget=<value optimized out>, aMessage=<value optimized out>, aSync=<value optimized out>, aCloneData=0xbe8ae938, aObjectsArray=0x482a0a60, aJSONRetVal=0x0, aContext=0x0)
    at ../../../dist/include/mozilla/dom/StructuredCloneUtils.h:45
#7  nsFrameMessageManager::ReceiveMessage (this=<value optimized out>, aTarget=<value optimized out>, aMessage=<value optimized out>, aSync=<value optimized out>, aCloneData=0xbe8ae938, aObjectsArray=0x482a0a60, aJSONRetVal=0x0, aContext=0x0)
    at /home/mikeh/dev/mozilla/m-c/inbound-src/content/base/src/nsFrameMessageManager.cpp:560
#8  0x40e40dc8 in nsFrameMessageManager::ReceiveMessage (this=0x474afec0, aTarget=<value optimized out>, aMessage=<value optimized out>, aSync=<value optimized out>, aCloneData=0xbe8ae938, aObjectsArray=0x0, aJSONRetVal=0x0, aContext=0x0)
    at /home/mikeh/dev/mozilla/m-c/inbound-src/content/base/src/nsFrameMessageManager.cpp:637
#9  0x415c0876 in mozilla::dom::ContentParent::RecvAsyncMessage (this=<value optimized out>, aMsg=<value optimized out>, aData=...) at /home/mikeh/dev/mozilla/m-c/inbound-src/dom/ipc/ContentParent.cpp:1970
#10 0x4163204a in mozilla::dom::PContentParent::OnMessageReceived (this=0x4869e400, __msg=...) at /home/mikeh/dev/mozilla/btg019/objdir-gecko-inbound-debug/ipc/ipdl/PContentParent.cpp:2246
#11 0x415e5716 in mozilla::ipc::AsyncChannel::OnDispatchMessage (this=0x4869e408, msg=...) at /home/mikeh/dev/mozilla/m-c/inbound-src/ipc/glue/AsyncChannel.cpp:473
#12 0x415ec00c in mozilla::ipc::RPCChannel::OnMaybeDequeueOne (this=0x4869e408) at /home/mikeh/dev/mozilla/m-c/inbound-src/ipc/glue/RPCChannel.cpp:402
#13 0x415bc548 in DispatchToMethod<mozilla::dom::ContentParent, void (mozilla::dom::ContentParent::*)()> (this=<value optimized out>) at /home/mikeh/dev/mozilla/m-c/inbound-src/ipc/chromium/src/base/tuple.h:383
#14 RunnableMethod<mozilla::dom::ContentParent, void (mozilla::dom::ContentParent::*)(), Tuple0>::Run (this=<value optimized out>) at /home/mikeh/dev/mozilla/m-c/inbound-src/ipc/chromium/src/base/task.h:307
#15 0x415ea45e in mozilla::ipc::RPCChannel::RefCountedTask::Run (this=0x487bdf80) at ../../dist/include/mozilla/ipc/RPCChannel.h:425
#16 mozilla::ipc::RPCChannel::DequeueTask::Run (this=0x487bdf80) at ../../dist/include/mozilla/ipc/RPCChannel.h:448
#17 0x41866fda in MessageLoop::RunTask (this=0x4032f0c0, task=0x487bdf80) at /home/mikeh/dev/mozilla/m-c/inbound-src/ipc/chromium/src/base/message_loop.cc:333
#18 0x41867804 in MessageLoop::DeferOrRunPendingTask (this=0x7b, pending_task=<value optimized out>) at /home/mikeh/dev/mozilla/m-c/inbound-src/ipc/chromium/src/base/message_loop.cc:341
#19 0x41868556 in MessageLoop::DoWork (this=0x4032f0c0) at /home/mikeh/dev/mozilla/m-c/inbound-src/ipc/chromium/src/base/message_loop.cc:441
#20 0x415e9a7c in mozilla::ipc::DoWorkRunnable::Run (this=<value optimized out>) at /home/mikeh/dev/mozilla/m-c/inbound-src/ipc/glue/MessagePump.cpp:42
#21 0x41831532 in nsThread::ProcessNextEvent (this=0x40304390, mayWait=<value optimized out>, result=0xbe8af6cf) at /home/mikeh/dev/mozilla/m-c/inbound-src/xpcom/threads/nsThread.cpp:627
#22 0x417f92d0 in NS_ProcessNextEvent_P (thread=0x7b, mayWait=false) at /home/mikeh/dev/mozilla/btg019/objdir-gecko-inbound-debug/xpcom/build/nsThreadUtils.cpp:238
#23 0x415e9c32 in mozilla::ipc::MessagePump::Run (this=0x40302430, aDelegate=0x4032f0c0) at /home/mikeh/dev/mozilla/m-c/inbound-src/ipc/glue/MessagePump.cpp:82
#24 0x4186758e in MessageLoop::RunInternal (this=0x4032f0c0) at /home/mikeh/dev/mozilla/m-c/inbound-src/ipc/chromium/src/base/message_loop.cc:215
#25 0x418675ee in MessageLoop::RunHandler (this=0x4032f0c0) at /home/mikeh/dev/mozilla/m-c/inbound-src/ipc/chromium/src/base/message_loop.cc:208
#26 MessageLoop::Run (this=0x4032f0c0) at /home/mikeh/dev/mozilla/m-c/inbound-src/ipc/chromium/src/base/message_loop.cc:182
#27 0x4152b062 in nsBaseAppShell::Run (this=0x4362f6a0) at /home/mikeh/dev/mozilla/m-c/inbound-src/widget/xpwidgets/nsBaseAppShell.cpp:163
#28 0x41418e84 in nsAppStartup::Run (this=0x437a0730) at /home/mikeh/dev/mozilla/m-c/inbound-src/toolkit/components/startup/nsAppStartup.cpp:288
#29 0x40a182d2 in XREMain::XRE_mainRun (this=0xbe8af964) at /home/mikeh/dev/mozilla/m-c/inbound-src/toolkit/xre/nsAppRunner.cpp:3823
#30 0x40a1aede in XREMain::XRE_main (this=0xbe8af964, argc=<value optimized out>, argv=0xbe8b1b64, aAppData=<value optimized out>) at /home/mikeh/dev/mozilla/m-c/inbound-src/toolkit/xre/nsAppRunner.cpp:3890
#31 0x40a1b092 in XRE_main (argc=1, argv=0xbe8b1b64, aAppData=0x21184, aFlags=<value optimized out>) at /home/mikeh/dev/mozilla/m-c/inbound-src/toolkit/xre/nsAppRunner.cpp:4093
#32 0x0000a2f8 in do_main (argc=1, argv=0xbe8b1b64) at /home/mikeh/dev/mozilla/m-c/inbound-src/b2g/app/nsBrowserApp.cpp:164
#33 main (argc=1, argv=0xbe8b1b64) at /home/mikeh/dev/mozilla/m-c/inbound-src/b2g/app/nsBrowserApp.cpp:249
Note that the block containing the MOZ_ASSERT() is only included in DEBUG builds:
http://mxr.mozilla.org/mozilla-central/source/dom/ipc/StructuredCloneUtils.cpp#87
F(  429:0x1ad) Assertion failure: !isMutable, at /home/mikeh/dev/mozilla/m-c/inbound-src/dom/ipc/StructuredCloneUtils.cpp:55
F(  429:0x1ad) Fatal signal 11 (SIGSEGV) at 0x00000000 (code=1)
Confirmed: with the MOZ_ASSERT() in comment 10 and an additional one at StructuredCloneUtils.cpp:55 removed, debug builds do not crash.

The image taken in the camera shows up in the contact picture field as mostly grey (with some subtle texture variations from the taken picture); saving the contact, returning to the phone, and tapping on the contact list button shows the contact pictures as all-black.  Tapping on an individual contact, however, shows the correct image at the top of the contact.

(This may be related to bug 826620.)
Flags: needinfo?(mchen)
:bent, what are the implications of failing the MOZ_ASSERT() calls at StructuredCloneUtils.cpp:55 and 87?
Flags: needinfo?(bent.mozilla)
The amount of JS stacks in this bug makes me thing this is a platform bug. Switching components to reflect that.
Component: Gaia::Dialer → General
As Vivien commented this seems like a backend component, so reassigning to a proper backend guy ;)

Thanks!
Assignee: francisco.jordano → mhabicher
Attached patch Patch, v1Splinter Review
This should work.
Assignee: mhabicher → bent.mozilla
Status: REOPENED → ASSIGNED
Flags: needinfo?(bent.mozilla)
Yep, that fixed it!  r=me, if you need.
Backed out on inbound for what appears to be failing all tests on OS X. Either this patch or the one for bug 827749 is the cause.

https://hg.mozilla.org/integration/mozilla-inbound/rev/85b09d1c1cdc
Please reland this when the tree reopens. It turned out to be an infra issue, sorry. https://bugzilla.mozilla.org/show_bug.cgi?id=829169
(Assuming you want to buddy-land this and bug 827749.)
marking resolved fixed per new jst rules.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
Working fine in Gecko-cfad7c9.Gaia-6c53dfd.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.