All Day Events is broken in the Week View

VERIFIED FIXED in B2G C4 (2jan on)

Status

Firefox OS
Gaia::Calendar
P2
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: kgrandon, Assigned: kgrandon)

Tracking

({regression})

unspecified
B2G C4 (2jan on)
x86
Mac OS X
regression

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Assignee)

Description

5 years ago
STR - 

1 - Create a obnoxiously long event that spans 3 days.
2 - Tap week view.

Observed - 
Event time is properly filled out for days 1 and 3. Day 2 is empty

Expected - 
Day 2 will have the proper time filled in.

Appears this is some height calculation issue.
(Assignee)

Comment 1

5 years ago
I might try to take a stab at this - probably something we should fix.
Assignee: nobody → kgrandon

Updated

5 years ago
blocking-basecamp: --- → ?
Keywords: regression, regressionwindow-wanted
Kevin showed me this directly.

Looks like the 2nd day portion of the 3-day event doesn't even render except for a small orange line.
(Assignee)

Comment 3

5 years ago
Turns out that the display of "All Day" events is simply broken in the week view.

Updated

5 years ago
Summary: Week view is broken for long events → All Day Events is broken in the Calendar App

Updated

5 years ago
Summary: All Day Events is broken in the Calendar App → All Day Events is broken in the Week View
blocking-basecamp: ? → +
Priority: -- → P2
Target Milestone: --- → B2G C4 (2jan on)
https://github.com/mozilla-b2g/gaia/commit/a2811f24100af04d875a1fc237f43c75d6049d9c

This was a regression from a typo that was fixed here.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Keywords: regressionwindow-wanted → verifyme

Comment 5

5 years ago
Verified fixed on Unagi build 20130112070202
Status: RESOLVED → VERIFIED

Updated

5 years ago
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.