The undocked Developer Tools window remains open after closing Firefox

VERIFIED FIXED in Firefox 21

Status

DevTools
Framework
P2
normal
VERIFIED FIXED
6 years ago
a month ago

People

(Reporter: alindeac, Assigned: paul)

Tracking

Trunk
Firefox 21
x86
All

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Mozilla/5.0 (Windows NT 6.1; rv:21.0) Gecko/20130110 Firefox/21.0
Build ID: 20130110030939

Steps to reproduce:
1. Launch Firefox and open one tab
2. Open the toolbox and undock
3. Close Firefox by clicking on the 'X' button.

Expected results:
The undocked developer tools window is closed along with the browser.

Actual results:
The developer tools window remains open after closing Firefox from the 'X' button. If Firefox is dismissed from the File menu -> Exit, the developer tools window is also closed.
Blocks: 816946
No longer depends on: 816946
Doesn't the same thing happen with other windows, like the Error Console?
(Assignee)

Comment 2

6 years ago
Created attachment 700972 [details] [diff] [review]
v1
Assignee: nobody → paul
Status: NEW → ASSIGNED
Attachment #700972 - Flags: review?(jwalker)
Attachment #700972 - Flags: review?(jwalker) → review+
Priority: -- → P2
Whiteboard: [has-patch]
(Assignee)

Updated

6 years ago
Whiteboard: [has-patch] → [land-in-fx-team]
(Assignee)

Comment 3

6 years ago
Apparently, this doesn't work if the last tab is closed with ctrl-w. Followup: bug 829553.
https://hg.mozilla.org/integration/fx-team/rev/e608febcff45
Whiteboard: [land-in-fx-team] → [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/e608febcff45
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 21
Will this fix make it on the Aurora branch?

Updated

5 years ago
Duplicate of this bug: 865962

Updated

5 years ago
OS: Windows 7 → All

Comment 8

5 years ago
Reproduced with firefox-20.0b7.es-ES.linux64.

WFM with 21.0 Beta and 2013-04-30-03-09-41-mozilla-central-firefox-23.0a1.en-US.linux-x86_64
Status: RESOLVED → VERIFIED

Updated

a month ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.