If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Email. UX VD] Composing message: Text in the email subject field is missaligned

VERIFIED FIXED

Status

Firefox OS
Gaia::E-Mail
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: vicky, Assigned: dkuo)

Tracking

unspecified
x86
Mac OS X

Firefox Tracking Flags

(b2g18 verified)

Details

(Whiteboard: uxbranch, landed in uxbranch, ux-tracking, hanzo, visual-tracking)

Attachments

(7 attachments)

(Reporter)

Description

5 years ago
Created attachment 700462 [details]
Shows visual bug

Should sit lower.
(Reporter)

Updated

5 years ago
Assignee: nobody → schung
Whiteboard: interaction, visual, UX-P2, BerlinWW
(Assignee)

Updated

5 years ago
Assignee: schung → dkuo
(Assignee)

Comment 1

5 years ago
Created attachment 701757 [details]
adjust and remove some styles in *.css of email

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed: 
Risk to taking this patch (and alternatives if risky):
Attachment #701757 - Flags: review?(schung)
Attachment #701757 - Flags: approval-gaia-master?(21)
(Assignee)

Comment 2

5 years ago
Created attachment 701760 [details]
Adjusted compose page of Email app
Comment on attachment 701757 [details]
adjust and remove some styles in *.css of email

Sounds like polish issue. Let's land that on the UX branch then.
Attachment #701757 - Flags: approval-gaia-master?(21) → approval-gaia-master-
(Assignee)

Comment 4

5 years ago
Thanks Vivien, I closed the one in master branch and open a new one in UX branch:
https://github.com/gordonbrander/gaia/pull/90

Let's wait for UX branch to cherry pick this.
(Assignee)

Updated

5 years ago
Attachment #701757 - Flags: review?(schung)

Comment 5

5 years ago
Landed in uxbranch: https://github.com/gordonbrander/gaia/commit/78e29744473db5fc4f2888a6c72e050fc435ec1f
Whiteboard: interaction, visual, UX-P2, BerlinWW → interaction, visual, UX-P2, BerlinWW, uxbranch, landed in uxbranch
Created attachment 703097 [details]
screenshot w/ change

The alignment still seems slightly off; looks *3 times better though!
Created attachment 703214 [details]
1/16 Build Screenshot
Based on Josh's input, I am marking this as qa-verified and will open a nitpick alignment for all lines in the to, cc, bcc, subject lines to align with the label.
Follow up bug 831700
Created attachment 706032 [details]
screenshot

Found that in a different language, the alignment is off in a more recent build...
decided that this wasn't completely fixed due to this...
Created attachment 706035 [details]
screenshot

Here's a screenshot of pt-BR

This has instructions on how to add other locales:
https://wiki.mozilla.org/L10n:B2G/Localizers
For some reason it does look like it dipped a lot from the 1/16th build... not sure what caused it.  I'm seeing the issue in English as well w/ building today.


Gaia commit 05c1026284406ee83fbfa504a32344c1c3e39b8f
(Assignee)

Comment 13

5 years ago
It might be the reason that different language will use different line-height in table-cell(CSS style that email used to do vertical align).
So let me find out what are the rest styles we should apply to adjust this.

Comment 14

5 years ago
Bug still present on yesterdays build.   This is from a newly flashed phone using english.
Duplicate of this bug: 841281
Still present in beta 3/12 build.
Whiteboard: interaction, visual, UX-P2, BerlinWW, uxbranch, landed in uxbranch → u=user c=email s=ux-most-wanted, visual, uxbranch, landed in uxbranch

Updated

5 years ago
Whiteboard: u=user c=email s=ux-most-wanted, visual, uxbranch, landed in uxbranch → u=user c=email s=ux-most-wanted visual, uxbranch, landed in uxbranch

Comment 17

5 years ago
https://github.com/mozilla-b2g/gaia/commit/e45b5592bf5b82ddbeda5be2be18a26b191d55fb
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
The gaia part landed to v1-train as part of the Big Bug 851124 uplift.
(but not to v1.0.1).
status-b2g18: --- → fixed
Master build : 2013-03-26-07-02-04
"mozilla-central" revision="28b048ffb7a7"
"integration/gaia-central" revision="44f6a17f24d4"
"gecko.git"revision="a800f14ea7022a78966f7fe14a9b0d11c569b151"
"gaia.git" revision="ace1eb32a313da1232bbdf9cff2581a4b036356d"

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/28b048ffb7a7
Gaia   ace1eb32a313da1232bbdf9cff2581a4b036356d
BuildID 20130326070204
Version 18.0
Unagi
Status: RESOLVED → VERIFIED
status-b2g18: fixed → verified

Updated

4 years ago
Whiteboard: u=user c=email s=ux-most-wanted visual, uxbranch, landed in uxbranch → uxbranch, landed in uxbranch, ux-tracking

Updated

4 years ago
Whiteboard: uxbranch, landed in uxbranch, ux-tracking → uxbranch, landed in uxbranch, ux-tracking, hanzo, visual-tracking
You need to log in before you can comment on or make changes to this bug.