Firefox 18 in win 8 won't play the Fox News videos that played well in Firefox 17.1 with all the same addons and plugins.

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: martin.77084, Unassigned)

Tracking

({steps-wanted})

18 Branch
x86_64
Windows 8
steps-wanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2013-09-18])

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0
Build ID: 20121128204232

Steps to reproduce:

In firefox 17.1, running in win 8 64 bit, checked for updates and installed the version 18 release without making any changes in installed extensions and plugins. (the latest version of Flash Player is installed)


Actual results:

Everything worked as it had in version 17.1 except for playing the Fox News videos. They just put up the black space for the video to play in, but no video appears. All videos in all the other news sites play properly.


Expected results:

The video in Fox News should have appeared in the black space and automatically played as it did with Firefox 17.1 (and as it does in Firefox 18 running in win 7 with the same extensions and plugins).
Please try it in the firefox safemode
- http://support.mozilla.org/en-US/kb/Safe+Mode
No Issues here trying http://video.foxnews.com/v/2088230848001/ with either

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0 ID:20130104151925 and
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130111 Firefox/21.0 ID:20130111030906
(Reporter)

Comment 3

5 years ago
(In reply to XtC4UaLL [:xtc4uall] from comment #2)
> No Issues here trying http://video.foxnews.com/v/2088230848001/ with either
> 
> Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0
> ID:20130104151925 and
> Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130111 Firefox/21.0
> ID:20130111030906

How does that relate to Firefox 18 running in Win 8 not playing the Fox News videos? I thought I had made it pretty clear that the problem occurs in Firefox 18 running in win 8, not in Firefox 18 running in win 7 or earlier, and not in Firefox 17 running win 8.
(Reporter)

Comment 4

5 years ago
(In reply to Matthias Versen [:Matti] from comment #1)
> Please try it in the firefox safemode
> - http://support.mozilla.org/en-US/kb/Safe+Mode

Since I had stated that it plays all the other news videos properly, what would you expect to be improved in safe mode over the capability to play all the other news videos that require Flash to play?
How did it work for you in safe mode?
And, yes, I checked to see that the computer was plugged in and turned on.
Following the steps to reproduce from comment 0 I could play the videos using Adobe Flash 11.5
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0
Build ID: 20121128204232

and upgraded to Firefox 18.0 from "Help>About Firefox"
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130104151925

still no issues found.

martin.77084, please try again playing the videos from Fox News using a new clean profile and report back. http://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Martin, can you still reproduce it? 

It is passed a long time and as for comment 5 it seems that this could be set as WORKFORME.
Flags: needinfo?(martin.77084)
Whiteboard: closeme?
(Reporter)

Comment 7

5 years ago
(In reply to Tiziana Sellitto [:tiziana] from comment #6)
> Martin, can you still reproduce it? 
> 
> It is passed a long time and as for comment 5 it seems that this could be
> set as WORKFORME.

Yes, I have reproduced it many times with version 18, and then again with each later version that has been released. I have tried it with a new, clean profile and only Flash Player installed, with no success. After each failure have reinstalled version 17.01, which doesn't have the problem.
Flags: needinfo?(martin.77084)
Please, could you verify if you have the problem on the latest nightly?
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central/
(Reporter)

Comment 9

5 years ago
(In reply to Tiziana Sellitto [:tiziana] from comment #8)
> Please, could you verify if you have the problem on the latest nightly?
> http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-
> central/

Yes. The videos in all the other news sites play properly, but not Fox news. I have restored to version 17.01 again.
Component: Untriaged → Plug-ins
Product: Firefox → Core
I don't see any problems with videos on that site.

Martin, does this still happen for you? 
Can you provide a specific video where this reproduces?
Does it work in safe-mode? (you might have addons active or some setting that interferes here)
What Flash version are you using?
Flags: needinfo?(martin.77084)
(Reporter)

Comment 11

5 years ago
(In reply to Georg Fritzsche [:gfritzsche] from comment #10)
> I don't see any problems with videos on that site.
> 
> Martin, does this still happen for you? 
> Can you provide a specific video where this reproduces?
> Does it work in safe-mode? (you might have addons active or some setting
> that interferes here)
> What Flash version are you using?

There are no problems with videos on that site. The problem is with firefox not playing them.
Yes, it still happens with any version of firefox above 17.01.
Yes, I can provide a specific video where this reproduces...all of them on fox news...whichever ones they happen to have on at the time. 
Yes, the problem is still there in safe mode.
Which addons or settings do you suggest that will prevent fox news videos from playing while allowing the videos on all other sites to play normally?
I have used numerous versions of flash...whatever was the latest one at the time, since firefox 18 came out.

I do have several other browsers that play the videos in fox news very well. I just find it irritating to have to switch to one of them to see the videos in fox news.
Flags: needinfo?(martin.77084)
I can't reproduce this with either Fx 22 or Nightly, using Flash 11.8.800.94.
Addons might interfere with this in multiple ways, but are disabled in Safe Mode, so those are not the problem.

Does it work when you reset Firefox [1] or try it in a new profile [2]?

If not, when you go to about:support, is there anything plugin-related in the "Important Modified Preferences" section?

[1] https://support.mozilla.org/en-US/kb/reset-firefox-easily-fix-most-problems
[2] https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
(Reporter)

Comment 13

5 years ago
I have reset and tried new profiles with no success.

I don't have one of the non-functional versions installed right now, so will have to wait 'til later to look at about:support, but I don't expect to see anything in "Important Modified Preferences" when running in safe mode with a new, clean profile, and only flash player plugin installed.
Right, it should not be a setting then either.

As apparently no-one else can reproduce so far, can you try to find a regression window using mozregression [1]?
As your problems start with Fx 18, you would start with --good=2012-08-26

[1] http://mozilla.github.io/mozregression/
Keywords: steps-wanted

Updated

5 years ago
Whiteboard: closeme?
(Reporter)

Comment 15

5 years ago
I just don't have more time to mess with this issue right now. I'm getting by very nicely with 17.01.

Thanks.
Let's see then if anyone can provide more information here and close it if not.
Whiteboard: [closeme 2013-09-18]
WFM in nightly 25.0a1 (2013-08-04) Win 8 x64, Flash Player 11.8.800.94.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.