[NEWS]UI: Edit | Delete Message should turn into Edit | Cancel Message

VERIFIED FIXED in mozilla0.8

Status

SeaMonkey
MailNews: Message Display
P3
normal
VERIFIED FIXED
19 years ago
13 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
mozilla0.8

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta1+])

as in 4.x, the menu's should change if we are reading news.
Status: NEW → ASSIGNED
Target Milestone: M9
moving to m9

Updated

19 years ago
QA Contact: lchiang → nbaca
Hardware: PC → All
Target Milestone: M9 → M10
I'm not sure the infrastructure is there to support this feature yet.

I'm started looking into it.

moving to m10.
Target Milestone: M10 → M11
adding alecf and hangas to the cc list.

I talked with alecf, and he said he and hangas are working on the infrastructure
for this.

alecf, is there a bug for that, so I can make this bug dependant on that one?

until them, moving to m11.

Comment 4

19 years ago
Would the shortcut key remain as Del?

Comment 5

19 years ago
I don't believe there is a shortcut for Cancel Message.  That's how it is in
4.x.  I'll cc: Jennifer to verify.
FYI:  in the 4.x XFE it was Alt+D for delete message and cancel message.

Comment 7

19 years ago
Edit menu, "Delete Message" when in mail a message has focus.  Shortcut is
"Del".  When in news and news posting is selected should be "Cancel Message",
no shortcut. Shouldn't "Cancel Message" only be enabled if the user is the
author of the selected posting?
data point:  its Alt+D for all cases on the XFE in 4.x (even cancel message.)

the check for author is done at cancel time:  either by the server (if it
supports that extension) or by our application, it loops through the identities
to see if one of them matches the author of the article.

I'd be all for making it Del for all platforms all the time.
(And, once we support alternate hot keys for alternate platforms, making it
Alt+D for UNIX, and something else, if necessary, for the Mac.)

Until we have that infrastructure, I'd just make it Del for all platforms, in
all cases, and move on.

Comment 9

19 years ago
Another data point - I remember that in 4.5, we were supposed to remove the
shortcut when it was cancel message, but there wasn't an easy way to do that in
the XFE...

Comment 10

19 years ago
of course I think removing the shortcut key will be only a tiny bit less
difficult ... we should just probably leave it so that del/alt+d is
delete/cancel all the time.

Comment 11

19 years ago
Triage to M15

Comment 12

18 years ago
*** Bug 22912 has been marked as a duplicate of this bug. ***
Assignee: sspitzer → hangas
Status: ASSIGNED → NEW
re-assign to hangas.

this is right up his alley.

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M15 → M14

Comment 14

18 years ago
M16
Target Milestone: M14 → M16

Updated

18 years ago
Summary: [NEWS] Edit | Delete Message should turn into Edit | Cancel Message → [NEWS]UI: Edit | Delete Message should turn into Edit | Cancel Message

Comment 15

18 years ago
Not beta2 stopper.  Marking M18.  Please let me know if you disagree.
Target Milestone: M16 → M18

Comment 16

18 years ago
OK, but needs to be in for final product.

Comment 17

18 years ago
Mass move mailnews bugs to Putterman.  Ouch.
Assignee: hangas → putterman
Status: ASSIGNED → NEW

Comment 18

18 years ago

*** This bug has been marked as a duplicate of 43300 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 19

18 years ago
*** Bug 43300 has been marked as a duplicate of this bug. ***

Comment 20

18 years ago
I'm reopening this one and marking the other one a dup of this one.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 21

18 years ago
nsbeta3 correctness.
Keywords: correctness, nsbeta3

Comment 22

18 years ago
mail triage team is marking this nsbeta3-
Whiteboard: [nsbeta3-]
Target Milestone: M18 → Future

Comment 23

17 years ago
Add mail3 keyword so bug considered for 6.5
Keywords: mail3

Comment 24

17 years ago
reassigning to sspitzer
Assignee: putterman → sspitzer
Status: REOPENED → NEW
accepting.
Status: NEW → ASSIGNED

Comment 26

17 years ago
marking nsbeta1+ and moving to mozilla.9
Keywords: nsbeta3 → nsbeta1
Whiteboard: [nsbeta3-] → [nsbeta1+]
Target Milestone: Future → mozilla0.9

Comment 27

17 years ago
moving to mozilla0.8 milestone.
Target Milestone: mozilla0.9 → mozilla0.8
fix in hand, bienvenu is sr= it.

my fix also makes it so if multiple news messages are selected, we show "Cancel
Message" and disable the menu item.
fixed.  there is a minor UI bug exposed by this, I'll go log it.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → FIXED

Comment 30

17 years ago
Build 2001-010804: NT4
Build 2001-010808: Linux 6.2, Mac 9.04
Verified Fixed.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.