audi.de - JavaScript error: document.all has no properties (same for audi.be)

RESOLVED FIXED

Status

Tech Evangelism Graveyard
German
P4
normal
RESOLVED FIXED
17 years ago
3 years ago

People

(Reporter: wing-tung Leung, Unassigned)

Tracking

Details

(Whiteboard: [PROPRIETARY-DOM][havecontact], URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
(using CVS version)

I don't know wether this is due to bad JavaScript code or to a bug in Mozilla.
Fact is that the lower part of the page is not drawn. It shows up fine in
Netscape 4.x.

This debug output shows up:
===========================
Enabling Quirk StyleSheet
Opening file cookperm.txt failed
###!!! ASSERTION: You can't draw an image with a 0 width or height!: 'aSWidth > 
###!!! Break: at file nsImageGTK.cpp, line 536
JavaScript error:
http://www.audi.de/static/page_script.js line 75: document.all has no properties

Document http://www.audi.de/audi_a2/audi_a2_de.html loaded successfully
JavaScript error:
http://www.audi.de/static/page_script.js line 665: document.dokument has no
properties

Comment 1

17 years ago
Confirming on 2001052608 Win2k, setting OS=All and over to Evangelism as they
use a faulty browser sniffing:

 var ns = navigator.appName == 'Netscape';
 var ie = !ns;
 var version = parseInt(navigator.appVersion);
 var ie3= ie && version < 4;

 var NS4 = (document.layers) ? 1 : 0;
 var IE4 = (document.all) ? 1 : 0;
Assignee: rogerl → bclary
Status: UNCONFIRMED → NEW
Component: Javascript Engine → Evangelism
Ever confirmed: true
OS: Linux → All
QA Contact: pschwartau → zach
Priority: -- → P4
-> Intl
Assignee: bclary → nitot
QA Contact: zach → momoi

Updated

17 years ago
Component: Evangelism → European
Product: Browser → Tech Evangelism
Version: other → unspecified

Comment 3

17 years ago
Also, the site blocks access to Netscape 6.x browsers. The user is redirected to 
http://www.audi.de/versionmismatch_de.html
See also http://bugscape/show_bug.cgi?id=4455 on this topic.

Contacted webmaster@audi.de, sending the evangelism web letter.
Accepting bug.
Status: NEW → ASSIGNED

Comment 4

17 years ago
Moving to new component "West Europe".  European component is being removed. 
See bug 95808 for details.
Status: ASSIGNED → NEW
Component: European → West Europe
QA Contact: momoi → caillon
Summary: JavaScript error: document.all has no properties → audi.de - JavaScript error: document.all has no properties

Comment 5

17 years ago
re-sent evangelism letter to webmaster@audi.de.

If anyone knows someone at Audi who could help, please feel free to volunteer !
Status: NEW → ASSIGNED

Comment 6

17 years ago
The web page works for me now with current CVS build on Linux. Maybe they've got
it fixed? Still, lots of other JS warnings, though ...

Comment 7

17 years ago
No this isn't fixed.  They still have a ton of refs to layers and document.all
and the console errors out with:

Error: document.dokument has no properties
Source File: http://www.audi.de/static/page_script.js
Line: 665
Whiteboard: [PROPRIETARY-DOM][LAYER]

Comment 8

17 years ago
No response from Audi -> Resolved Remind
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → REMIND
Target Milestone: --- → Dec

Comment 9

17 years ago
Reopening and setting to future.
Status: RESOLVED → REOPENED
Resolution: REMIND → ---
Target Milestone: Dec → Future

Comment 10

17 years ago
I had no problem at all visiting the site.

Caillon: can you confirm?
(Reporter)

Comment 11

17 years ago
The page seems to have been changed, problem has went away for me on Mozilla
0.9.6 GNU/Linux i386.

Comment 12

17 years ago
I have a feeling that they have some tabs either on the right side or up on top.
 Both areas look kind of odd to me.

The page has indeed changed, but I now get this error:

Error: this.tabs[0] has no properties
Source File: http://www.audi.com/include/js/crossfeature.js
Line: 81

Can someone test this on MSIE and compare to Moz?  Clearing target milestone
until we can analyze this better.
Hardware: PC → All
Target Milestone: Future → ---

Comment 13

17 years ago
Dammit, Caillon, you're right :-(
Links on the right hand bar do not show up in N621 and Moz 096 for the home page
http://www.audi.com/de/de/home.jsp .

Comment 14

17 years ago
*** Bug 116948 has been marked as a duplicate of this bug. ***

Comment 15

17 years ago
> Links on the right hand bar do not show up in N621 and Moz 096 

This missing menu is given by the following HTML at the site:

      <div id="menuNs" class="shiftleft">


By using the Mozilla DOM Inspector, I was able to find the URL 
containing the CSS class "shiftleft":

      http://www.audi.com/include/css/style_ns_pc_de.css


Among other things, this class defines |visiblity| = "hidden"
By toggling this property in the DOM Inspector, I was able to 
see the menu. It looks like the site authors try to do this via
an invalid use of document.layers (not supported in Moz): see

      http://www.audi.com/include/js/init.js


function init()
{       
  for (var i = 0; i < initObjs.length; i++) 
                eval(initObjs[i]);                                                      

  cf.cl(0);                                                                                         
  if (is.ie)                                                                             
  {
    redoIE(true);                                                           
    window.onresize = redoIE;
  }
        
  if(is.ns)
  {                                                                              
    origWidth = innerWidth;
    origHeight = innerHeight;
    window.onresize = redoNS; 

    // Fix bug where menu was showed while page was loading. Jose
    document.layers["menuNs"].visibility = "show"; 
   
    // Fix bug where the rollover did not work. Jose 
    document.layers["bCumb"].visibility = "show";  


                    etc.
  }



So it looks like that's where the problem is. The error involving 
"this.tabs[0] has no properties" (Comment #12 above) looks like 
something else, which may be caused by the document.layers error - 

Comment 16

17 years ago
Also see Netscape internal bug http://bugscape/show_bug.cgi?id=11076
where the same problem is reported for the American site, http://www.audi.com
I am using the 2002 updated home version of Windows XP with Mozilla build
2002010508 which is Mozilla version 0.9.7+ and on the page
http://www.univision.com/ I am also experiencing the document.all has no properties

Error: document.all has no properties
Source File:
http://www.univision.com/content/channel.jhtml?chid=5&schid=1082&secid=0
Line: 33

Error: document.all has no properties
Source File: http://www.univision.com/portal.jhtml?chid=1&schid=0&secid=0
Line: 34

Error: document.all has no properties
Source File:
http://www.univision.com/content/channel.jhtml?chid=5&schid=1082&secid=0
Line: 38 

Error: document.all has no properties
Source File: http://www.univision.com/portal.jhtml?chid=1&schid=0&secid=0
Line: 39
Error: document.all has no properties
Source File: http://www.enix.com/home.html
Line: 52

Comment 19

17 years ago
When we started to build this site (the new release), Netscape 6 was just
released and was to buggy to support. 
Future versions of this site will support Netscape 6/Mozilla, but at the moment
nothing is planned. 
If you you resize the window in IE the modules move to a new position, when we
tried to do this in the lastest Netscape release, it hanged for several minutes.
So probably it will be static as the Netscape 4 version.
Error: document.all has no properties
Source File: http://www.mgm.com/
Line: 102

Error: document.all has no properties
Source File: http://www.mgm.com/
Line: 111

Comment 21

16 years ago
This same bug is exhibited at 
http://www.fairmont.com/FA/en/CDA/Home/CDHomePage/

The Javascript file involved is:
http://www.fairmont.com/FA/en/CDA/Home/CDjsGlobNavScriptDom/0,3743,,00.js
The errors occur at lines 737 and 770 in the code.
The code appears to be drawing some kind of multi-level menu.

*** Bug 140287 has been marked as a duplicate of this bug. ***
*** Bug 121612 has been marked as a duplicate of this bug. ***
*** Bug 155534 has been marked as a duplicate of this bug. ***

Comment 25

16 years ago
Created attachment 105579 [details]
Another place where bug shows up

I've found another occurence for this bug. Unfortunately the site needs a login
to it but I've saved a copy and filtered out 95% of the rubbish in it (if need
be I'll send the full source). This form is used to send free sms via internet,
when you type in the message box, the number of characters left should start
decrementing (works fine with opera, IE works too I believe) but in Moz it
triggers the document.all has no properties error. The line in question is line
480. Let me know if I can help in any other way

Comment 26

16 years ago
I've contacted the owners of www.go.com.mt re their use of document.all (see
previous attached file). I sent them a polite email even showing them a possible
fix but alas they seem to be unwilling to do any changes. Their comments follow:
---
Thank you for your e-mail. In reply to your queries both Mygo and go mobile's
website are designed for IE5 and upwards and this is Company policy. [snip]
 
We are aware that not everyone uses IE. However, IE offers certain features
which other browsers do not. Using these, we are able to use a greater array of
features which allow us to design better interfaces. 84.3 per cent of the
internet population uses Internet Explorer. More than 98 percent of the hits on
go mobile's website originate from IE.
---

Can someone send another "official" complaint too? 

Comment 27

16 years ago
> More than 98 percent of the hits on
> go mobile's website originate from IE.

No doubt, if thats the only browser that works. I mean, if I would run a chinese
website i shouldn't be surprised that 98% of the visitors prefer chinese. This
is unfortunately always the problem with the proprietary websites. (scnr)
move...
Assignee: nitot → german
Status: REOPENED → NEW
Component: Europe: West → German
QA Contact: z-caillon-obsolete2 → german
Whiteboard: [PROPRIETARY-DOM][LAYER] → [PROPRIETARY-DOM][havecontact]

Comment 29

15 years ago
The URL https://banking.diba.de also shows this error.

This is the Mozilla error message:

Error: document.all has no properties
Source File: https://banking.diba.de/DIBA?REQUEST_HANDLER=STARTUP&ZIEL=main
Line: 140

This is the source function.

function init()
        {
	 for (var i=1; i<4; ++i){
	  eval('document.all.'+'num'+i).style.visibility = "visible";

	 document.forms[0]._USER.focus();
	}
}

The problem shows up with Mozilla 1.4 under SUSE Linux 8.1. It don't shows up
with Netscape 4.7 under Linux.

Comment 30

14 years ago
(In reply to comment #13)
> Dammit, Caillon, you're right :-(
> Links on the right hand bar do not show up in N621 and Moz 096 for the home page
> http://www.audi.com/de/de/home.jsp .

WFM with Mozilla 1.7a/Firefox 0.8. 
I see no difference between IE5.0 and Mozilla on this page. They work now also
with getElementById and sniffing for DOM/Gecko browsers (for example:
http://www.audi.com/include/js/global.js). Could be resolved?

Comment 31

14 years ago
Tested on www.audi.be (choose any language) and it does not work even with
Mozilla 1.7a. However, I confirm the German (www.audi.de) version works for me.

Comment 32

14 years ago
www.audi.be still don't work with Firefox 1.0 PR.

Comment 33

13 years ago
*** Bug 284048 has been marked as a duplicate of this bug. ***

Comment 34

13 years ago
*** Bug 307732 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Summary: audi.de - JavaScript error: document.all has no properties → audi.de - JavaScript error: document.all has no properties (same for audi.be)

Comment 35

13 years ago
Asnwer from the web master of the www.audi.be website (summary in English at the
bottom)

*********************************
Cher Monsieur,

Nous vous remercions pour votre mail très complet dont nous avons bien pris
connaissance. Une initiative très positive dont nous vous remercions. Il s'agit
bien évidemment d'un problème qui nous préoccupe grandement et nous tenions tout
d'abord à nous excuser pour les désagréments occasionnés.

Conscients que nos sites ne sont optimisés que pour IE, nous avons mis en place
un projet de renouvellement du site Audi. Celui-ci sera compatible avec les
navigateurs Mozilla et Safari. Nous tiendrons donc de plus en plus compte des
sufeurs utilisant des plattes-formes alternatives.
Le nouveau site audi.be sera lancé au plus tard la veille de l'ouverture du
salon automobile de Bruxelles.

Dans l'attente de pouvoir encore mieux vous satisfaire, des analyses sont donc
en cours pour rendre notre site compatible à la majorités des browsers, tout en
tenant compte des contraintes financières de notre départements Internet.

En espérant vous avoir bien renseigné, nous restons à votre disposition,

Une agréable journée,

Votre webmaster
*********************************
Summary:
Sorry for the inconvenience.
The next version of www.audi.be will support Mozilla and Safari.  This new web
site should be online at the latest on the 10th of January 2006.  
In the meantime, they are considering fixing the current website (if budget
permit it).
I tested above URL with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1b1) Gecko/20060813 BonEcho/2.0b1 and everything seems to work correctly

Shall we close that one?
Peter: yes, thanks for checking on this one!
Status: NEW → RESOLVED
Last Resolved: 17 years ago12 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.