The default bug view has changed. See this FAQ.

Chat icon vertical align

RESOLVED FIXED in Thunderbird 21.0

Status

Thunderbird
Toolbars and Tabs
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Mariusz Kacki, Assigned: Paenglab)

Tracking

17 Branch
Thunderbird 21.0
x86
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

4 years ago
Created attachment 700696 [details]
vai.png

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:17.0) Gecko/20100101 Firefox/17.0
Build ID: 20121128204232



Actual results:

Wrong alignment.
(Assignee)

Comment 1

4 years ago
Created attachment 701444 [details] [diff] [review]
patch

Good catch Mariusz and thanks for the report.

This happens only in "Icons and Text" mode with Aero theme but it's good to apply on all modes except text only.

Mike, I've chosen you for review because you have a always working Win7 machine to check this bug.
Assignee: nobody → richard.marti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #701444 - Flags: ui-review?(mconley)
Attachment #701444 - Flags: review?(mconley)
Comment on attachment 701444 [details] [diff] [review]
patch

Hey Paenglab,

Code looks good! Just one visual nit - when I switch to Icons & Text, while I have the customize window open, the chat icon is still misaligned.

http://i.imgur.com/D31K8eE.png

Can we take care of that case too?

-Mike
Attachment #701444 - Flags: ui-review?(mconley)
Attachment #701444 - Flags: ui-review-
Attachment #701444 - Flags: review?(mconley)
Attachment #701444 - Flags: review+
(Assignee)

Comment 3

4 years ago
Created attachment 710679 [details] [diff] [review]
patch v2

Expanded the rule to work also in customize mode.
Attachment #701444 - Attachment is obsolete: true
Attachment #710679 - Flags: ui-review?(mconley)
Attachment #710679 - Flags: review?(mconley)
Comment on attachment 710679 [details] [diff] [review]
patch v2

Review of attachment 710679 [details] [diff] [review]:
-----------------------------------------------------------------

Yep, way better. Thanks Paenglab!
Attachment #710679 - Flags: ui-review?(mconley)
Attachment #710679 - Flags: ui-review+
Attachment #710679 - Flags: review?(mconley)
Attachment #710679 - Flags: review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/1f1db96d6571
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 21.0
You need to log in before you can comment on or make changes to this bug.