Closed Bug 829317 Opened 7 years ago Closed 7 years ago

Forwarding a plaintext message as inline adds a spurious file attachment "Attached message Part" in composition

Categories

(Thunderbird :: Untriaged, defect)

17 Branch
x86
Windows 7
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 745919

People

(Reporter: musiphil, Unassigned)

Details

(Keywords: regression)

Attachments

(1 file)

733 bytes, application/octet-stream
Details
Attached file WrongAttach.eml
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130104151925

Steps to reproduce:

When I forward a message as inline, the composition window sometimes includes a spurious attachment, even though the original message doesn't have any.

I have saved such a message that triggers the behaviour and simplified it a bit. Save the attachment as a file, select "File > Open Saved Message...", choose the saved file, and select "Message > Forward As > Inline".


Actual results:

There's an attachment named "Attached Message Part" in the composition window.


Expected results:

There should be no attachment.
confirming as in comment 0.
Apart from seeing the unwarranted "Attacched Message Part" in attachments pane, I also get "Unable to save your message as draft" errors.
Summary: Forwarding a message as inline includes a spurious attachment in composition → Forwarding a plaintext message as inline adds a spurious file attachment "Attached message Part" in composition
Confirmed in TB 17.02

This bug appears to be a regression of 745919

That bug is listed as fixed and no one appears to be monitoring the posts about this bug coming back.
Forgot to note that I have Inline Attachments set and have tested with all add-ons and security software disabled on a Win7 X64 machine
I have the same issue, and also if you "edit as new" the attachment is there.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Keywords: regression
Resolution: --- → DUPLICATE
Duplicate of bug: 745919
You need to log in before you can comment on or make changes to this bug.