Can't resume fullscreen mode when returning to app from homescreen

RESOLVED WONTFIX

Status

Firefox OS
Gaia::System::Window Mgmt
RESOLVED WONTFIX
5 years ago
2 months ago

People

(Reporter: djf, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
It used to be that the Home button would work to exit fullscreen mode. If you were running an app that was in fullscreen mode, you'd have to press the button twice to actually get back to the homescreen.

That has changed: now pressing home once exits fullscreen and goes to the homescreen. I'm filing this bug because I'm not sure if it is intentional or a regression.

It would be nice if the gallery app could resume where you left off.  If you were in fullscreen, then go to the homescreen, then back to the app, the app should be able to go back to fullscreen.  

But when I try this in the gallery app, I get this error in logcat:

[JavaScript Warning: "Request for full-screen was denied because requesting element is not in the currently focused tab." {file: "app://gallery.gaiamobile.org/index.html" line: 0}]

Curiously, if I'm running the gallery and sleep the phone, then wake it and unlock the lock screen, the gallery is able to go right back to fullscreen mode. Also, if I'm in fullscreen mode, and get a call, I leave fullscreen mode, but when the call is over the app is able to go back to fullscreen.

I don't know how mozRequestFullScreen() works, so I don't know if this is a gaia system app issue or a gecko issue.  Cc'ing Tim because he might know.
So I take it a work-around exists right now where the user would have to explicitly select to go back to fullscreen then if they return to the app, right?

If so, even though this is a regression, we'll probably to have live with it for v1 given that well...were a few days from code complete?
Component: Gaia → Gaia::System
Keywords: regression
> It used to be that the Home button would work to exit fullscreen mode. 
> If you were running an app that was in fullscreen mode, you'd have to 
> press the button twice to actually get back to the homescreen.

This is intentional. Except in very rare cases, the Home button should always take the user to the Home app. Altering it's behavior when a certain subtle condition is met (in the manner described) would 1) undermine consistency, and 2) be inappropriate in games, where fullscreen is the default and making users hit the Home button twice would only induce confusion and frustration.

> It would be nice if the gallery app could resume where you left off.
> If you were in fullscreen, then go to the homescreen, then back to the 
> app, the app should be able to go back to fullscreen.  

This does not work well if the user has not used the app in some time, however. Opening gallery and being confronted with a photo floating against black and zero on-screen UI has the potential to confuse users (where am I?). Better to err on the side of caution and always present the non-fullscreen mode when the app is opened.

Updated

5 years ago
Component: Gaia::System → Gaia::System::Window Mgmt

Comment 3

2 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.