B2G crash in mozilla::widget::PuppetWidget::DispatchEvent

RESOLVED DUPLICATE of bug 834760

Status

()

Core
Widget: Gonk
--
critical
RESOLVED DUPLICATE of bug 834760
5 years ago
5 years ago

People

(Reporter: marcia, Unassigned)

Tracking

({crash})

18 Branch
ARM
Gonk (Firefox OS)
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [b2g-crash], crash signature)

This bug was filed from the Socorro interface and is 
report bp-d86e8630-a6b5-4669-8e09-531e72130110 .
============================================================= 

Seen while running the latest unagi nightly, using:

Gecko: b626a918b9e4
Gaia: c9a778d8d9b5

Link to crashes: https://crash-stats.mozilla.com/report/list?signature=mozilla::widget::PuppetWidget::DispatchEvent

I am not sure how I hit it, but filing since I noticed there are a few crashes in crash stats with the same signature (by B2G standards, even though some are dupes)

Frame 	Module 	Signature 	Source
0 	libxul.so 	mozilla::widget::PuppetWidget::DispatchEvent 	PuppetWidget.cpp:289
1 	libxul.so 	mozilla::dom::TabChild::DispatchWidgetEvent 	TabChild.cpp:1576
2 	libxul.so 	mozilla::dom::TabChild::RecvRealMouseEvent 	TabChild.cpp:1352
3 	libxul.so 	mozilla::dom::PBrowserChild::OnMessageReceived 	PBrowserChild.cpp:1692
4 	libxul.so 	mozilla::dom::PContentChild::OnMessageReceived 	PContentChild.cpp:2255
5 	libxul.so 	mozilla::ipc::AsyncChannel::OnDispatchMessage 	AsyncChannel.cpp:473
6 	libxul.so 	mozilla::ipc::RPCChannel::OnMaybeDequeueOne 	RPCChannel.cpp:402
7 	libxul.so 	RunnableMethod<IPC::ChannelProxy::Context, void , Tuple0>::Run 	tuple.h:383
8 	libxul.so 	mozilla::ipc::RPCChannel::DequeueTask::Run 	RPCChannel.h:425
9 	libxul.so 	MessageLoop::RunTask 	message_loop.cc:333
10 	libxul.so 	MessageLoop::DeferOrRunPendingTask 	message_loop.cc:341
11 	libxul.so 	MessageLoop::DoWork 	message_loop.cc:441
12 	libxul.so 	mozilla::ipc::DoWorkRunnable::Run 	MessagePump.cpp:42
13 	libxul.so 	nsThread::ProcessNextEvent 	nsThread.cpp:620
14 	libxul.so 	NS_ProcessNextEvent_P 	nsThreadUtils.cpp:237
15 	libxul.so 	mozilla::ipc::MessagePump::Run 	MessagePump.cpp:117
16 	libxul.so 	mozilla::ipc::MessagePumpForChildProcess::Run 	MessagePump.cpp:231
17 	libxul.so 	MessageLoop::RunInternal 	message_loop.cc:215
18 	libxul.so 	MessageLoop::Run 	message_loop.cc:208
19 	libxul.so 	nsBaseAppShell::Run 	nsBaseAppShell.cpp:163
20 	libxul.so 	XRE_RunAppShell 	nsEmbedFunctions.cpp:646
21 	libxul.so 	mozilla::ipc::MessagePumpForChildProcess::Run 	MessagePump.cpp:198
22 	libxul.so 	MessageLoop::RunInternal 	message_loop.cc:215
23 	libxul.so 	MessageLoop::Run 	message_loop.cc:208
24 	libxul.so 	XRE_InitChildProcess 	nsEmbedFunctions.cpp:485
25 	plugin-container 	main 	MozillaRuntimeMain.cpp:48
26 	libc.so 	__libc_init 	libc_init_dynamic.c:114
27 		@0xb0001dc5

Updated

5 years ago
Whiteboard: [b2g-crash]
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 834760
You need to log in before you can comment on or make changes to this bug.