Error confirming email with Persona for marketplace.firefox.com

RESOLVED FIXED

Status

Marketplace
Consumer Pages
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: dbialer, Unassigned)

Tracking

({qawanted})

x86
Mac OS X
qawanted
Points:
---

Details

(Reporter)

Description

5 years ago
When I created a new account on my B2G phone, it sent me a confirmation message.  I opened this message and clicked on the link.  It asked me to type in my password.  I typed it in and submitted.  I get Sorry message. Details
We are very sorry. There has been an error!
Please close this window and try again.
Action: Verifying email address
Network Info: POST: /wsapi/complete_email_confirmation
Response Code - 400
Response Text: {"success":false,"reason":"pass: Error: String is not in range"}
Error Type: {"success":false,"reason":"pass: Error: String is not in range"}

Comment 1

5 years ago
That's a persona issue I believe.
is this an identity bug?
Flags: needinfo?(krupa.mozbugs)
Keywords: qawanted
That sounds like a string was too long or too short.

David, can you give me more information, both about the strings you used for email and password (or at least their length) and also about specifically which app you used to create an account?  Was this through marketplace-dev?

Thanks,
j
Flags: needinfo?(dbialer)
(Reporter)

Comment 4

5 years ago
(In reply to Jed Parsons [:jparsons] from comment #3)
> That sounds like a string was too long or too short.
> 
> David, can you give me more information, both about the strings you used for
> email and password (or at least their length) and also about specifically
> which app you used to create an account?  Was this through marketplace-dev?
> 
> Thanks,
> j

I used an 11 letter string with just lowercase and numbers I believe.  I created the account on my B2G phone using marketplace.  I was trying to see if email was verified or unverified for the path of creating an account using the login button on the bottom of the screen (found out it is verified).  Marketing has a question as to whether all B2G Firefox Accounts will have unverified emails (checking with you too - the answer seems to be no).
Flags: needinfo?(dbialer)

Comment 5

5 years ago
I used a 11 letter string as my password but was able to verify my account just fine. 

David, mind trying again to see if you can reproduce?

If this is reproducible, this is clearly an identity issue.

fyi, bug 829696 is happening now.
Flags: needinfo?(krupa.mozbugs)
(Reporter)

Comment 6

5 years ago
I just tried it 3 times before and it wasn't working correctly.  Persona thought I had an account but then marketplace would ask me to confirm it.   I would go to a confirm email that was triggered, and when I tried to confirm it tole me there was a problem.

So, I tried to record it, and when I was recording it, it started working.  Go figure.

It is either fixed or I can't reproduce now.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.