[Social API] ambient popup is displayed at center of screen when toolbar is in Text mode

VERIFIED FIXED in Firefox 20

Status

()

Firefox
SocialAPI
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: ANDO Yasushi, Assigned: jaws)

Tracking

Trunk
Firefox 21
Points:
---

Firefox Tracking Flags

(firefox18 unaffected, firefox19 unaffected, firefox20 verified, firefox21 verified)

Details

(Whiteboard: [testday-20130301])

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 700826 [details]
screenshot.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_4) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.97 Safari/537.11

Steps to reproduce:

1. Right-click on the toolbar
2. Select "Customize..."
3. Select the "Text" item from the Show: combobox
4. Click "Done"
5. Click "See all friend requests" item in the toolbar


Actual results:

A dialog which shows all friend requests is displayed at the center of the toolbar.


Expected results:

The dialog should be displayed below "See all friend requests" item in the toolbar.
Component: Untriaged → SocialAPI: Providers
This may be a side effect of bug 811835 (whose other symptoms are visible in the screenshot).
Component: SocialAPI: Providers → SocialAPI
Oh, though actually that looks like post-fix. So maybe there are still issues here related to popup positioning.
Assignee: nobody → jaws
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
OS: Mac OS X → All
Hardware: x86 → All
Created attachment 702885 [details] [diff] [review]
Patch
Attachment #702885 - Flags: review?(mixedpuppy)
Attachment #702885 - Flags: review?(felipc)
Firefox 18 and 19 should be unaffected because they don't use the standard toolbarbutton approach. Firefox 20 is affected because the patch that introduced the standard toolbarbutton approach got uplifted to Fx20Aurora.
status-firefox18: --- → unaffected
status-firefox19: --- → unaffected
status-firefox20: --- → affected
status-firefox21: --- → affected
Depends on: 811835
Attachment #702885 - Flags: review?(mixedpuppy) → review+
Attachment #702885 - Flags: review?(felipc)
https://hg.mozilla.org/integration/mozilla-inbound/rev/644a74f5904a
status-firefox21: affected → fixed
Comment on attachment 702885 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 811835
User impact if declined: misaligned popup panels for the SocialAPI
Testing completed (on m-c, etc.): locally, just landed on m-i
Risk to taking this patch (and alternatives if risky): low risk patch, very isolated
String or UUID changes made by this patch: none
Attachment #702885 - Flags: approval-mozilla-aurora?
Summary: [Social API] a dialog is poped up at wrong position → [Social API] ambient popup is displayed at center of screen when toolbar is in Text mode

Comment 7

5 years ago
https://hg.mozilla.org/mozilla-central/rev/644a74f5904a
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21
Comment on attachment 702885 [details] [diff] [review]
Patch

low risk, approving for aurora.
Attachment #702885 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/331b0a480586
status-firefox20: affected → fixed
Keywords: verifyme
Verified fixed on Firefox 20.0 beta 2 and Windows 7 64 bit.

I followed the reportes's steps to reproduce:

1. Right-click on the toolbar
2. Select "Customize..."
3. Select the "Text" item from the Show: combobox
4. Click "Done"
5. Click "See all friend requests" item in the toolbar

I could see the expected results:
The dialogue was displayed below "See all friend requests" item in the toolbar.
Whiteboard: [testday-20130301]
Thank you Gabriela. Could you please also test the latest Firefox 21.0a2 Aurora build?
status-firefox20: fixed → verified
Anthony, I just did. I verified fixed with the latest Aurora build too.
(In reply to Gabriela from comment #12)
> I verified fixed with the latest Aurora build too.

Thank you.
Status: RESOLVED → VERIFIED
status-firefox21: fixed → verified
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.