New “first launch” interactions for the Cost Control app

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: hello, Assigned: salva)

Tracking

({l12y, late-l10n})

unspecified
x86
Mac OS X
l12y, late-l10n

Firefox Tracking Flags

(blocking-b2g:-, b2g18+ fixed, b2g18-v1.0.1 fixed)

Details

(Whiteboard: interaction, [EU_TPE_TRIAGED])

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 700965 [details]
Wireframe with new strings
blocking-basecamp: --- → ?
For consistency, the back/next/… buttons should be in title case. Same thing for the titles, obviously.

“Controle” is not an English word, maybe you meant “Controlled”?

FWIW I don’t think these titles can fit in our headers without breaking the style consistency, and as an l10n devil I’d consider this as a blocker — when we talked about these CostControl screens, the point was precisely to allow a proper localization.
Keywords: late-l10n
(Reporter)

Comment 2

6 years ago
Yup. Uploaded this on behalf of Marco at Salva's request. Anyway, I'll ask him to chime in.
Use tef? + tracking-b2g? now. We've retired blocking-basecamp? as of mid-day Friday.
blocking-b2g: --- → tef?
blocking-basecamp: ? → ---
tracking-b2g18: --- → ?
Daniel, is it a blocker this comes late in the game.
Flags: needinfo?(dcoloma)
I assume this is only a localization change, and the WF are still the same, correct?
Flags: needinfo?(dcoloma)
No: it’s a (better but) different UI. On the localization front, I’m afraid neither the current UI nor this one can be properly localized because of the too long titles.

At the moment, each panel has one long and unclear title + one option, the rest of the screen being blank. If we want to ensure a proper internationalization with low risk, I’d suggest to stick to the current UI with shorter titles and add explanation texts in each panel. </my2¢>
(Reporter)

Updated

6 years ago
Keywords: l12y
blocking-b2g: tef? → tef+
(Reporter)

Comment 7

6 years ago
I've cc'd and passed this issue to Tyler, who's reviewing the strings (EN + ES)
Is this going to be a string change only?  If so, no need to tef+ but if there are code/UI changes required here please comment on the criticality of those fixes for v1.0
blocking-b2g: tef+ → tef?
Flags: needinfo?(kaze)
This requires code or markup but it is not a string change only at all.
Flags: needinfo?(kaze)
Daniel, do you want to go through these late and maybe risky changes based on comment 6 ? If so please renominate.
blocking-b2g: tef? → -
tracking-b2g18: ? → +
Flags: needinfo?(dcoloma)
Whiteboard: interaction → interaction, [EU_TPE_TRIAGED]
Comment on attachment 700965 [details]
Wireframe with new strings

What about the flow fort NON-VIVO SIMs?
Attachment #700965 - Flags: feedback?(marcoc)
Some of the issues I mentioned in comment #1 are still not addressed:

 • the back/next/… buttons should be in title case (i.e. Back/Next/…)
 • the panel titles should be in title case, too
 • “Controle” is not an English word, maybe you meant “Controlled”?

FTR I don’t think that “I’m prepaid / Controle” makes much sense. I understand the Spanish “Prepago” better — and you know how bad my Spanish is. ;-)
Summary: Add and update a few strings, EN & ES → New “first launch” interactions for the Cost Control app
(In reply to Fabien Cazenave [:kaze] from comment #12)
> Some of the issues I mentioned in comment #1 are still not addressed:
> 
>  • the back/next/… buttons should be in title case (i.e. Back/Next/…)

They are in title case in the implementation but not in the WF

>  • the panel titles should be in title case, too

Why? Is there a convention? If so, there is no problem changing it. Just clarifying why.

>  • “Controle” is not an English word, maybe you meant “Controlled”?

We are removing "controle" from the implementation as it is very dependent of VIVO. It is "prepaid" only.
(In reply to Salvador de la Puente González [:salva] from comment #13)
> Why? Is there a convention? If so, there is no problem changing it. Just
> clarifying why.

Yes, it’s a UX convention that has been applied on all Gaia apps (or should have).

> >  • “Controle” is not an English word, maybe you meant “Controlled”?
> 
> We are removing "controle" from the implementation as it is very dependent
> of VIVO. It is "prepaid" only.

Oh, so “Controle” is the name of the VIVO data plan? I’ll try to think of a way to let partners customize l10n strings… but that’s outside of the scope of this bug.

Comment 15

6 years ago
(In reply to Salvador de la Puente González [:salva] from comment #11)
> Comment on attachment 700965 [details]
> Wireframe with new strings
> 
> What about the flow fort NON-VIVO SIMs?

Salva,
From the attached flow use the 2 screens from the Postpaid flow (bottom line) and make the following header and copy adjustments as we are not tracking telephony usage:

1st. 
header: Phone and data report -> Data report
hint text: Receive reports about your phone and internet usage. -> Receive reports about your internet usage.

2nd. 
header: Data report (leave as is)
hint text: Set an alert to avoid using too much data. (leave as is)
Created attachment 705277 [details]
Adding hints to Cost Control FTE

Bug caused by (feature/regressing bug #): this one
User impact if declined: medium
Testing completed: yes
Risk to taking this patch (and alternatives if risky): low
Attachment #705277 - Flags: review?(stas)
Attachment #705277 - Flags: review?(francisco.jordano)
Attachment #705277 - Flags: approval-gaia-v1?(francisco.jordano)
Attachment #705277 - Flags: review?(francisco.jordano) → review+
Attachment #700965 - Flags: feedback?(marcoc)
Comment on attachment 705277 [details]
Adding hints to Cost Control FTE

So far, being a tracking-b2g18+ I think you don't need the approval anymore, any way, this changes are harmless
Attachment #705277 - Flags: approval-gaia-v1?(francisco.jordano)
Comment on attachment 705277 [details]
Adding hints to Cost Control FTE

This patch removes some strings and I'd like to know if it's going to be uplifted to 1.0.x?  If not, we need a version of the patch which doesn't remove any strings.
It is tracking-b2g18+ so I understand this will end in v1.0.1
Am I wrong?
Flags: needinfo?(21)

Comment 20

6 years ago
You'll need approval-gaia-v1 to land it on v1-train, unless it's tef+ or shira+.

Also, I'm rethinking l10n a tad just now as I get a better understanding of release trains, we shouldn't remove strings from the v1-train, at least for now.
Flags: needinfo?(21)
Comment on attachment 705277 [details]
Adding hints to Cost Control FTE

This should land on shira so asking for approval again.
Attachment #705277 - Flags: approval-gaia-v1?(francisco.jordano)

Comment 22

6 years ago
Please don't land this with the removal of the 1.0.0 strings.
So, what do you need Stas, a patch without removing former strings?
Flags: needinfo?(stas)
Once talked with Stas, we agree on leaving the former strings and open a followup bug asking for removing those strings.
Flags: needinfo?(stas)
Flags: needinfo?(dcoloma)
Comment on attachment 705277 [details]
Adding hints to Cost Control FTE

Thanks, Salva!
Attachment #705277 - Flags: review?(stas) → review+
Comment on attachment 705277 [details]
Adding hints to Cost Control FTE

dom change, harmless and will make the user to understand the app better.

a=me
Attachment #705277 - Flags: approval-gaia-v1?(francisco.jordano) → approval-gaia-v1+
Landed on master:
https://github.com/mozilla-b2g/gaia/commit/59429d56ab0a6827c70f53683cb3b4a3d46e72ae
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 29

6 years ago
(In reply to Francisco Jordano [:arcturus] from comment #27)
> Comment on attachment 705277 [details]
> Adding hints to Cost Control FTE
> 
> dom change, harmless and will make the user to understand the app better.
> 
> a=me

This is not a harmless DOM change, but an l10n impact rework piece. I don't think we should approve this lightly.
(In reply to Axel Hecht [:Pike] from comment #29)
> (In reply to Francisco Jordano [:arcturus] from comment #27)
> > Comment on attachment 705277 [details]
> > Adding hints to Cost Control FTE
> > 
> > dom change, harmless and will make the user to understand the app better.
> > 
> > a=me
> 
> This is not a harmless DOM change, but an l10n impact rework piece. I don't
> think we should approve this lightly.

Hi Axel, this is a harmless change in terms of not JS modified. Also the l10n impact has been reviewed already by :stas

Thanks!

Comment 31

6 years ago
A review should not be mistaken for an approval.

Neither stas nor I can or should do approvals, all we can do is do technical reviews on whether the strings as exposed are probably going to work when localized or not.
Comment on attachment 705277 [details]
Adding hints to Cost Control FTE

Hi Francisco - you may not have seen https://bugzilla.mozilla.org/show_bug.cgi?id=828476#c7, but all approvals should be completed during group triage with Mozilla involvement. Setting back to ?
Attachment #705277 - Flags: approval-gaia-v1+ → approval-gaia-v1?
(In reply to Alex Keybl [:akeybl] from comment #32)
> Comment on attachment 705277 [details]
> Adding hints to Cost Control FTE
> 
> Hi Francisco - you may not have seen
> https://bugzilla.mozilla.org/show_bug.cgi?id=828476#c7, but all approvals
> should be completed during group triage with Mozilla involvement. Setting
> back to ?

> This was not approved as part of triage. Placing back in nominate.

HI Alex,
first news about it, it is not the process explained in the meeting, wikis, or other communications... could you please clarify?

This bug was triaged with MOzilla team (as usual), Tef team attended that triage where it was flagged as tracking-b2g18+.So with approval-gaia-v1+ can be landed in v1-train.
Francisco Jordano has approval-gaia-v1 rights to do it.

I hope it's just a mistake because if something has changed in the process that's not the best way to communicate it.
(In reply to Alex Keybl [:akeybl] from comment #32)
> Comment on attachment 705277 [details]
> Adding hints to Cost Control FTE
> 
> Hi Francisco - you may not have seen
> https://bugzilla.mozilla.org/show_bug.cgi?id=828476#c7, but all approvals
> should be completed during group triage with Mozilla involvement. Setting
> back to ?

Hi Alex, definitely I didn't see it.
Is this looking to go to 1.0.1 or 1.1.0 - in the case of the former, then we will approve for v1-train landing, in the case of the latter landing to master branch has already occurred.
This is for the target market for 1.0.1. Please approve.
Comment on attachment 705277 [details]
Adding hints to Cost Control FTE

Approving for v1-train landing (v1.0.1)
Attachment #705277 - Flags: approval-gaia-v1? → approval-gaia-v1+
v1-train: 59e298933f10c6a3301833064001ff0a3dc98d5d
status-b2g18: --- → fixed
Something is unclear to me: Hints in Cost Control FTE are not localized in 2013-02-06-11-05-09 pvt nightly b2g18 build
Is this intentional?
Batch edit: bugs fixed on b2g18 since 1/25 branch of v1.0 are fixed on v1.0.1
status-b2g18-v1.0.1: --- → fixed
You need to log in before you can comment on or make changes to this bug.