Bad logic to select alarm-starting or alarm-select

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: willyaranda, Assigned: kgrandon)

Tracking

({late-l10n})

unspecified
x86
Mac OS X
late-l10n

Firefox Tracking Flags

(blocking-b2g:-, b2g18+ fixed)

Details

(Whiteboard: interaction [UX-P1], [TEF_REQ])

Attachments

(1 attachment)

On alarm.js, line 64:

// TODO: verify this is all we need to handle.
var type = (begins < now) ? 'alarm-starting' : 'alarm-started';

and 

# alarms
alarm-starting={{title}} started {{distance}}
alarm-started={{title}} starting in {{distance}}

The ternary if has switched values (if begins<now, it means that the event has started), but it's corrected on strings.

This should not block, but requesting just in case.
Adding l10n folks as this might require a minor string change and bump.
Keywords: late-l10n

Updated

6 years ago
blocking-b2g: --- → tef?
blocking-basecamp: ? → ---
tracking-b2g18: --- → ?
blocking-b2g: tef? → -
tracking-b2g18: ? → +
(Assignee)

Comment 2

6 years ago
Should be easy enough to clean up, not sure if it's worth landing at this time because it appears there would be zero functionality changes and more of a clean-up issue.
Assignee: nobody → kgrandon
(Assignee)

Comment 3

6 years ago
Created attachment 702187 [details]
Github pull request pointer

Don't think this needs to go for v1, but here's a pull request anyway.
Attachment #702187 - Flags: review?
(Assignee)

Comment 4

6 years ago
Comment on attachment 702187 [details]
Github pull request pointer

James - if you have nothing better to do take a minute and review this silly patch. Thanks!
Attachment #702187 - Flags: review? → review?(jlal)

Comment 5

6 years ago
[TEF_REQ] as Feature required for TEF build.
Whiteboard: interaction [UX-P1], [TEF_REQ]
(Assignee)

Comment 6

6 years ago
Just going through some old bugs and landed this minor fix. https://github.com/mozilla-b2g/gaia/commit/d4abaeae66db38cad25da0bff44aaddd4634aa0c
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Updated

6 years ago
Attachment #702187 - Flags: review?(jlal)
Uplifted commit d4abaeae66db38cad25da0bff44aaddd4634aa0c as:
v1-train: d624469787dbd6f24ad20c7abb76721854b70b81
status-b2g18: --- → fixed
(Assignee)

Updated

6 years ago
Duplicate of this bug: 814884
You need to log in before you can comment on or make changes to this bug.