Retina buttons are wrongly sized

RESOLVED FIXED in Firefox 20

Status

()

Firefox
Downloads Panel
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: mak, Assigned: mak)

Tracking

unspecified
Firefox 21
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(firefox20 fixed)

Details

Attachments

(2 attachments)

(Assignee)

Description

6 years ago
Created attachment 701039 [details]
sshot

I'm not sure if that's expected but download buttons on retina to me look too big... wonder if we messed up something with defining their size.
Attachment #701039 - Flags: feedback?(shorlander)
(Assignee)

Comment 1

6 years ago
so, the problem is that the images on the buttons are set with list-style-image and I'm not sure we can limit the size of that... I suppose we may limit the size of the buttons though.
Comment on attachment 701039 [details]
sshot

Yeah, it's not supposed to look like that :)

I think as long as the dimensions are specified then referencing the @2x image in a media-query should "just work".
Attachment #701039 - Flags: feedback?(shorlander) → feedback+
Assignee: nobody → mconley
(Assignee)

Updated

6 years ago
Summary: Retina buttons too big? → Retina buttons are wrong sized
(Assignee)

Updated

6 years ago
Assignee: mconley → mak77
Status: NEW → ASSIGNED
(Assignee)

Updated

6 years ago
Summary: Retina buttons are wrong sized → Retina buttons are wrongly sized
(Assignee)

Comment 3

6 years ago
Created attachment 701135 [details] [diff] [review]
patch v1.0
Attachment #701135 - Flags: review?(mconley)
Comment on attachment 701135 [details] [diff] [review]
patch v1.0

Looks good on the Retina MacBook I just tested with. Thanks!
Attachment #701135 - Flags: review?(mconley) → review+
(Assignee)

Comment 5

6 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/89b72b0cda19
Target Milestone: --- → Firefox 21
(Assignee)

Comment 6

6 years ago
Comment on attachment 701135 [details] [diff] [review]
patch v1.0

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Downloads panel feature
User impact if declined: giant buttons on retina
Testing completed (on m-c, etc.): m-i
Risk to taking this patch (and alternatives if risky): minimal and limited to feature
String or UUID changes made by this patch: none
Attachment #701135 - Flags: approval-mozilla-aurora?
Attachment #701135 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/89b72b0cda19
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
This doesn't look completely fixed, see bug 898473.
You need to log in before you can comment on or make changes to this bug.