Closed Bug 829633 Opened 7 years ago Closed 7 years ago

dbg-webapps-actors.js redeclares Cu and friends

Categories

(Firefox OS Graveyard :: General, defect)

defect
Not set

Tracking

(blocking-b2g:-, firefox19 wontfix, firefox20 wontfix, firefox21 fixed, b2g18+ fixed)

RESOLVED FIXED
B2G C4 (2jan on)
blocking-b2g -
Tracking Status
firefox19 --- wontfix
firefox20 --- wontfix
firefox21 --- fixed
b2g18 + fixed

People

(Reporter: past, Assigned: past)

References

Details

Attachments

(1 file, 1 obsolete file)

In my review for bug 828863 I missed the redeclaration of Cu and friends on top. Since actor files are all loaded in the same scope as the debugger server, all those constants are already there. Trying to test the debugger after this patch I get:

Error loading: chrome://browser/content/dbg-webapps-actors.js: TypeError: redeclaration of var Cu - @chrome://browser/content/dbg-webapps-actors.js:7
loadSubScript@resource://gre/modules/devtools/dbg-server.jsm:49
DH_addActors@chrome://global/content/devtools/dbg-server.js:180
debugger_start@chrome://browser/content/shell.js:872
@chrome://browser/content/settings.js:206
onsuccess@chrome://browser/content/settings.js:49
Attached patch Remove Cu and friends (obsolete) — Splinter Review
This works for me.
Attachment #701143 - Flags: review?(fabrice)
...just to be extra safe.
Attachment #701143 - Attachment is obsolete: true
Attachment #701143 - Flags: review?(fabrice)
Attachment #701154 - Flags: review?(fabrice)
Comment on attachment 701154 [details] [diff] [review]
Use let instead of const

Review of attachment 701154 [details] [diff] [review]:
-----------------------------------------------------------------

Sorry for the mistake!
Attachment #701154 - Flags: review?(fabrice) → review+
Comment on attachment 701154 [details] [diff] [review]
Use let instead of const

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 828863
User impact if declined: remote debugging and webapp installation will not work in b2g
Testing completed: in mozilla-b2g18 and m-i
Risk to taking this patch (and alternatives if risky): no risk, trivial patch
String or UUID changes made by this patch: none
Attachment #701154 - Flags: approval-mozilla-b2g18?
https://hg.mozilla.org/mozilla-central/rev/e1ea3c66164f
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Bug 828863 that caused this was flagged as bb+, so I think we should track this one, too.
tracking-b2g18: --- → ?
Do we want to fix this for v1?
blocking-b2g: --- → tef?
Attachment #701154 - Flags: approval-mozilla-b2g18? → approval-mozilla-b2g18+
blocking-b2g: tef? → -
You need to log in before you can comment on or make changes to this bug.