If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

empty line inserted in bugzilla attachment

RESOLVED FIXED in mozilla0.9.3

Status

()

Core
Networking: Cache
P1
normal
RESOLVED FIXED
17 years ago
16 years ago

People

(Reporter: sicking, Assigned: harishd)

Tracking

Trunk
mozilla0.9.3
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed and verified on trunk], URL)

Attachments

(1 attachment)

When viewing the attachment 36281 [details] mozilla sometimes inserts an empty line at
line 287.

Steps to reproduce:
1. Open attachment 36281 [details]
2. Go to line 287 (search for |FirstChildOf(nsIDOMNode* aNode,| )

Expected results:
The lines should look like
-----------8<-------------------
nsTreeWalker::FirstChildOf(nsIDOMNode* aNode,
                           PRBool aReversed,
                           nsIDOMNode** _retval)

----------->8-------------------

Actual results:
Lines look like
-----------8<-------------------
nsTreeWalker::FirstChildOf(nsIDOMNode* aNode,
                           PRBool aReversed,

                           nsIDOMNode** _retval)
----------->8-------------------

This isn't 100% reproducable, when I enter the url to the attachment in the
urlbar it loads fine, but if I then press reload the extra line is inserted

tested with 2001-05-28 tip and moz0.9
(Assignee)

Comment 1

17 years ago
I see this..
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0
(Assignee)

Comment 2

17 years ago
Data corruption: Moving to m0.9.2 list.
Target Milestone: mozilla1.0 → mozilla0.9.2

Updated

17 years ago
Priority: -- → P1
(Assignee)

Comment 3

17 years ago
Created attachment 38938 [details] [diff] [review]
patch v1.1 [ if the last character was a CR make sure to not lose that information ]
(Assignee)

Updated

17 years ago
Whiteboard: [fix in hand]

Comment 4

17 years ago
r/sr=vidur
r=heikki
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.2 → mozilla0.9.3
nsBranch ok, data corruption and simple fix. Get this on the trunk ASAP.
Keywords: nsBranch

Comment 7

16 years ago
Fix checked in to the TRUNK.
(Assignee)

Comment 8

16 years ago
Previous comment was from me not vidur's :-)

Updated

16 years ago
Keywords: vtrunk
Verified FIXED on today's trunk build on Win2k (I see the bug in NS6.1b1 on Win2k).
Whiteboard: [fix in hand] → [fixed and verified on trunk]

Comment 10

16 years ago
After discussing this further with Harish, we both think that it is too late for
this change to go into the branch. It will be hard to justify taking this fix to
the PDT. Removing nsBranch, vtrunk keywords.

Marking fixed because this is fixed on the trunk.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Keywords: nsBranch, vtrunk
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.