Browser causes space between td's after default set to zero

VERIFIED FIXED in Firefox 25

Status

()

Core
SVG
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: RDall, Assigned: xidorn)

Tracking

({regression, testcase})

17 Branch
mozilla25
regression, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox18 wontfix, firefox19-, firefox20-, firefox21-, firefox22 wontfix, firefox23 wontfix, firefox24- wontfix, firefox25 verified, firefox26 verified, firefox-esr17 wontfix)

Details

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 701350 [details]
td border Bug See Red Highlight

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130104151948

Steps to reproduce:

Viewed TD with no padding no border and showed white border around images in a td. 


Actual results:

It showed white border between images with td. See Screenshot See red highlighted region http://cl.ly/image/123h0L0M0L12 But the white space flickers on and off when you re-size the browser window. See dev site and scroll to Meet our Surgeons to see issue. http://dal.32spokes.com/


Expected results:

No spaces between the tds. See screenshot http://cl.ly/image/0K0W233B0Q3o. I have also checked this on Chrome, IE and no issue appears at all.
Please provide code, ideally a minimized test case that shows the issue.
(Reporter)

Comment 2

5 years ago
(In reply to Kevin Brosnan [:kbrosnan] from comment #1)
> Please provide code, ideally a minimized test case that shows the issue.

I have already provided a page where you can see the issue. 

http://dal.32spokes.com/

You can see all the CSS and HTML code I have used from there. This only happens in the FF browser. Not sure why I would need to take the time out to replicate the issue on another page when it only affects FF browser.
This is a Regression between (at least) Firefox 14 vs 17.
Keywords: regressionwindow-wanted
OS: Mac OS X → All

Comment 4

5 years ago
Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/6dae57cd2f85
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120720145842
Bad:
http://hg.mozilla.org/mozilla-central/rev/045c11dd41a6
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120720205642
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=6dae57cd2f85&tochange=045c11dd41a6

Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/a746aaa32b22
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120720114508
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/62f19ed60528
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120720115241
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=a746aaa32b22&tochange=62f19ed60528

Suspected; Bug 614723
Blocks: 614723
Status: UNCONFIRMED → NEW
status-firefox18: --- → affected
status-firefox-esr17: --- → affected
tracking-firefox19: --- → ?
tracking-firefox20: --- → ?
tracking-firefox21: --- → ?
Component: Untriaged → SVG
Ever confirmed: true
Keywords: regressionwindow-wanted → regression
Product: Firefox → Core
Version: 18 Branch → 17 Branch
If you disable

#surgeon-rl td a:link img.desaturate {
    filter: url("inc/desaturate.svg#greyscale");
}

in the Inspector the Issue of the White Gap is gone.

Comment 6

5 years ago
And the gap depend on browser width.
Blocks: 614732
No longer blocks: 614723

Comment 7

5 years ago
We'd accept a low risk fix here, but do not feel the need to track for upcoming releases given this is a regression in FF17 (unreported until 1.5 months after its release).
tracking-firefox19: ? → -
tracking-firefox20: ? → -
tracking-firefox21: ? → -
(Reporter)

Comment 8

5 years ago
Hi… I filed this report as I didn't see it disappear on the latest update… Also I tend to think if your not part of the solution your part of the problem… 

Also if the client mentions that they see the issue I can verify it isn't my HTML and CSS but the browser itself.

I hope to see it fixed at some point… (It would be over my head and knowledge as to how) But I do agree it isn't a huge priority.
Thanks for reporting the issue, RDall.
[adding "testcase-wanted" -- ideally it'd be great to have a testcase attached to this bug page, so that we can still test this in case the remote site ends up changing at some point]
Keywords: testcase-wanted

Comment 11

5 years ago
Created attachment 713480 [details]
reduced html zipfile
It looks like the gap appears at alternate pixels of browser width.
No gap when browser is N pixels wide; gap when it's N+1 pixels; no gap at N+2; gap at N+3, etc
Keywords: testcase-wanted → testcase
Hardware: x86 → All
A 260.99 KB zip file isn't my idea of a reduced testcase. ;) I don't have time to reduce it right now, but if someone else does that and attaches a (say, less than 1 KB unzipped) testcase, then I'm much more likely to be able to take a look at the issue.
(Reporter)

Comment 14

4 years ago
I am a little surprised this is still open after almost 9 months.  Can we get a refresh on this ticket???
If you want to help, comment 13 suggests that a more reduced testcase would be appreciated.

Comment 16

4 years ago
(In reply to Jonathan Watt [:jwatt] from comment #13)
> A 260.99 KB zip file isn't my idea of a reduced testcase. ;) I don't have
> time to reduce it right now, but if someone else does that and attaches a
> (say, less than 1 KB unzipped) testcase, then I'm much more likely to be
> able to take a look at the issue.

???
(Reporter)

Comment 17

4 years ago
Test case size seems fine to me… As I have said previously fixing the issue is well over my head as I am just a web designer… 

But I was going through an old email and I found the bug ticket so I though I would check the status and saw it wasn't closed or even assigned.
This seems to be WORKSFORME now on Nightly.
(In reply to Jonathan Watt [:jwatt] from comment #18)
> This seems to be WORKSFORME now on Nightly.

Confirmed. Also WFM against Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0 ID:20130831004004 CSet: 9dd5f0e7f716

Comment 20

4 years ago
Created attachment 798582 [details]
reduced 810Byte

Comment 21

4 years ago
I cannot reproduce in Aurora25.0a2 and later.

Fixed window(m-i)
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/b4402b6dba21
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20130724 Firefox/25.0 ID:20130724055940
Fixed:
http://hg.mozilla.org/integration/mozilla-inbound/rev/74633f25ca05
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20130724 Firefox/25.0 ID:20130724060938
Pushlg:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=b4402b6dba21&tochange=74633f25ca05

Fixed by:
	517eaa8ba87e	Xidorn Quan — Bug 786254 - SVG effects rendering doesn't pixel snap, causing faint vertical lines appear on some tabs. r=roc
status-firefox22: --- → affected
status-firefox23: --- → affected
status-firefox25: --- → unaffected
status-firefox26: --- → unaffected
tracking-firefox24: --- → ?
Depends on: 786254
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Thanks, Alice.
Probably late in the game to request uplift to beta for Fx24, but you can always ask in bug 786254. Looks like the patch is pretty simple and comes with a test.
Assignee: nobody → quanxunzhen
status-firefox18: affected → wontfix
status-firefox22: affected → wontfix
status-firefox23: affected → wontfix
status-firefox24: --- → affected
status-firefox25: unaffected → fixed
status-firefox26: unaffected → fixed
Target Milestone: --- → mozilla25
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #23)
> Probably late in the game to request uplift to beta for Fx24, but you can
> always ask in bug 786254. Looks like the patch is pretty simple and comes
> with a test.

How can I request the uplift? I really hope the bug can be fixed in release version ASAP since it affects my everyday use.
Request beta approval on the patch in the bug and answer the questions it asks you.
This should be resolved starting firefox 25 hence wontfixing Fx24 given we could not uplift https://bugzilla.mozilla.org/show_bug.cgi?id=786254 in our last two beta's left on Fx24.
status-firefox24: affected → wontfix
tracking-firefox24: ? → -
Keywords: verifyme
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0
Mozilla/5.0 (X11; Linux i686; rv:25.0) Gecko/20100101 Firefox/25.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:25.0) Gecko/20100101 Firefox/25.0

Verified as fixed on Firefox 25 beta 1 (20130917123208).
Status: RESOLVED → VERIFIED
status-firefox25: fixed → verified
QA Contact: petruta.rasa
Mozilla/5.0 (X11; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0
Mozilla/5.0 (Windows NT 6.0; rv:26.0) Gecko/20100101 Firefox/26.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:26.0) Gecko/20100101 Firefox/26.0

Verified as fixed on latest Aurora 26.0a2 (buildID: 20131003004003).
status-firefox26: fixed → verified
Keywords: verifyme
status-firefox-esr17: affected → wontfix
You need to log in before you can comment on or make changes to this bug.