If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

STK Send DTMF does not display any text

RESOLVED FIXED in B2G C4 (2jan on)

Status

Firefox OS
General
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: cyang, Assigned: frsela)

Tracking

unspecified
B2G C4 (2jan on)
ARM
Gonk (Firefox OS)
Bug Flags:
in-moztrap -

Firefox Tracking Flags

(blocking-b2g:tef+, b2g18 fixed, b2g18-v1.0.0 fixed)

Details

(Whiteboard: [cr 437312] [cr 438079], QARegressExclude)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
In GCF TC 27.22.4.24.1.2, the test is ran as follows:

- Start GCF test which prompts for device power up
- After power up and network registration is successful, GCF test will send a SEND_DTMF proactive command to display "Send DTMF"

At this point, nothing is displayed even though this is sent:

RILContentHelper: Received message 'RIL:StkCommand': {"commandNumber":1,"typeOfCommand":20,"commandQualifier":0,"options":{"text":"Send DTMF"}}
Blocks: 808607

Updated

5 years ago
blocking-b2g: --- → tef?
Yoshi, on DTMF command,I response you STK_RESULT_OK.

Is this correct? Is the DTMF sent by your platform code?
Assignee: nobody → frsela
Flags: needinfo?(allstars.chh)
(In reply to Fernando R. Sela [:frsela] from comment #1)
> Yoshi, on DTMF command,I response you STK_RESULT_OK.
> 
> Is this correct? Is the DTMF sent by your platform code?
Yes, I think it's correct
Yes, I think DTMF is sent on gecko side.

https://github.com/mozilla-b2g/gaia/blob/master/apps/settings/js/icc.js#L242

You also need to display it on screen, not only replying ok.
Flags: needinfo?(allstars.chh)
blocking-b2g: tef? → tef+
Created attachment 702222 [details] [diff] [review]
Showed optional message on STK_CMD_SEND_* commands

The optional message is now displayed.

Yoshi, could you verify the DTMF tone is sent by the platform?
Attachment #702222 - Flags: review?(21)
Attachment #702222 - Flags: feedback?(allstars.chh)
Flags: needinfo?(allstars.chh)
Duplicate of this bug: 829824
Comment on attachment 702222 [details] [diff] [review]
Showed optional message on STK_CMD_SEND_* commands

I also wonder if you want to update the comment above?
Attachment #702222 - Flags: review?(21) → review+
(In reply to Vivien Nicolas (:vingtetun) (:21) from comment #5)
> Comment on attachment 702222 [details] [diff] [review]
> Showed optional message on STK_CMD_SEND_* commands
> 
> I also wonder if you want to update the comment above?

Comment removed
PR: https://github.com/mozilla-b2g/gaia/pull/7634
Landed: https://github.com/mozilla-b2g/gaia/commit/332f707c72d56399a7740039cd85ba509586fb20
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Duplicate of this bug: 829819
(In reply to Fernando R. Sela [:frsela] from comment #3)
> Created attachment 702222 [details] [diff] [review]
> Showed optional message on STK_CMD_SEND_* commands
> 
> The optional message is now displayed.
> 
> Yoshi, could you verify the DTMF tone is sent by the platform?

For DTMF Tone, modem on Android has handled it so even gecko can only receive text message.
Flags: needinfo?(allstars.chh)
Attachment #702222 - Flags: feedback?(allstars.chh) → feedback+
(In reply to Yoshi Huang[:yoshi][:allstars.chh] from comment #8)
> (In reply to Fernando R. Sela [:frsela] from comment #3)
> > Created attachment 702222 [details] [diff] [review]
> > Showed optional message on STK_CMD_SEND_* commands
> > 
> > The optional message is now displayed.
> > 
> > Yoshi, could you verify the DTMF tone is sent by the platform?
> 
> For DTMF Tone, modem on Android has handled it so even gecko can only
> receive text message.

You mean the UI should manage the DTMF tone?
(In reply to Fernando R. Sela [:frsela] from comment #9)
> > For DTMF Tone, modem on Android has handled it so even gecko can only
> > receive text message.
> 
> You mean the UI should manage the DTMF tone?

No, neither Gecko nor Gaia should handle it, because they cannot. The tones are already handled in modem.
(In reply to Yoshi Huang[:yoshi][:allstars.chh] from comment #10)
> (In reply to Fernando R. Sela [:frsela] from comment #9)
> > > For DTMF Tone, modem on Android has handled it so even gecko can only
> > > receive text message.
> > 
> > You mean the UI should manage the DTMF tone?
> 
> No, neither Gecko nor Gaia should handle it, because they cannot. The tones
> are already handled in modem.

So, if no DTMF is sent, who should check this issue? RIL guys?
status-b2g18: --- → fixed
Target Milestone: --- → B2G C4 (2jan on)
Landed on mozilla-b2g18/gaia master prior to the 1/25 branching to mozilla-b2g18_v1_0_0/v1.0.0, updating status-b2g-v1.0.0 to fixed.
status-b2g18-v1.0.0: --- → fixed

Comment 13

5 years ago
Test case not needed in Moztrap for this issue.
Flags: in-moztrap-

Updated

5 years ago
Whiteboard: [cr 437312] [cr 438079] → [cr 437312] [cr 438079], QARegressExclude
You need to log in before you can comment on or make changes to this bug.