Build errors with VS2012 - nscore.h 'nullptr' : macro redefinition

RESOLVED WORKSFORME

Status

Firefox Build System
General
RESOLVED WORKSFORME
6 years ago
5 months ago

People

(Reporter: s793016, Unassigned)

Tracking

17 Branch
mozilla43
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0.2) Gecko/20120331 Firefox/10.0.2 SeaMonkey/2.7.2
Build ID: 20120401095132

Steps to reproduce:

python -OO /d/comm/mozilla/build/pymake/make.py -f client.mk build 2>&1 | tee -i ${mozdir}/log-build

Visual Studio 2012 update 1.


Actual results:

make.py[5]: Entering directory 'd:\mozilla\obj\suite\app'
Creating Resource file: module.res
Microsoft (R) Windows (R) Resource Compiler Version 6.2.9200.16384

Copyright (C) Microsoft Corporation.  All rights reserved.


nsSuiteApp.cpp

D:\VStudio\2012\VC\INCLUDE\xkeycheck.h(208) : warning C4005: 'nullptr' : macro redefinition

        d:\mozilla\obj\mozilla\dist\include\nscore.h(339) : see previous definition of 'nullptr'

D:\VStudio\2012\VC\INCLUDE\xkeycheck.h(242) : fatal error C1189: #error :  The C++ Standard Library forbids macroizing keywords. Enable warning C4005 to find the forbidden macro.


Expected results:

no error

Updated

6 years ago
Component: Build Config → Build Config
Product: SeaMonkey → Core
Version: SeaMonkey 2.14 Branch → 17 Branch

Comment 1

6 years ago
My version of nscore.h doesn't define nullptr, maybe you are trying to use an old checkout that doesn't support VS2012?
(Reporter)

Comment 2

6 years ago
Sorry, forgot include source information.

The problem source code is Seamonkey 2.14.1 release.

Comment 3

2 years ago
Something new here?
Flags: needinfo?(s793016)
(Reporter)

Comment 4

2 years ago
with seamonkey 2.40 & vs2015, the problem is gone.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(s793016)
Resolution: --- → WORKSFORME

Comment 5

2 years ago
thx. for good news!
Target Milestone: --- → mozilla43

Updated

5 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.