Error while closing web console.

RESOLVED FIXED in Firefox 21

Status

()

Firefox
Developer Tools: Console
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Optimizer, Assigned: msucan)

Tracking

unspecified
Firefox 21
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Using the latest fx-team, I see this error when I try to close Web Console in undocked Toolbox :

Timestamp: 1/12/2013 5:08:52 PM
Error: TypeError: popupset is null: WC_destroy@resource:///modules/HUDService.jsm:367
WCP_destroy@resource:///modules/WebConsolePanel.jsm:65
TBOX_destroy@resource:///modules/devtools/Toolbox.jsm:609
EventEmitter_emit@resource:///modules/devtools/EventEmitter.jsm:100
WindowHost.prototype._boundUnload@resource:///modules/devtools/ToolboxHosts.jsm:228

Source File: resource:///modules/devtools/EventEmitter.jsm
Line: 105
(Reporter)

Comment 1

5 years ago
If you open the toolbox docked, and then undock it, or do not undock it, then this error is not seen. But if you open the toolbox undocked, then you will see this error on closing of web console. And afterwards, toolbox won't open.
(Reporter)

Comment 2

5 years ago
Also this :

Timestamp: 1/12/2013 5:26:12 PM
Error: TypeError: aOutputNode.scrollBoxObject is undefined
Source File: chrome://browser/content/devtools/webconsole.js
Line: 3845
(Reporter)

Updated

5 years ago
Blocks: 820735
(Assignee)

Comment 3

5 years ago
Regression caused by Bug 827083.
Assignee: nobody → mihai.sucan
Status: NEW → ASSIGNED
Depends on: 827083
OS: Windows 7 → All
Hardware: x86_64 → All
(Assignee)

Comment 4

5 years ago
Created attachment 701470 [details] [diff] [review]
fix

The isLocalTab check wasn't sufficient - undocked toolboxes work with local tab targets. Now the browserWindow getter checks if the window is a browser window.
Attachment #701470 - Flags: review?(past)
Comment on attachment 701470 [details] [diff] [review]
fix

Review of attachment 701470 [details] [diff] [review]:
-----------------------------------------------------------------

Messy, but OK. I wish we had support for this kind of thing in the Target object.
Attachment #701470 - Flags: review?(past) → review+
(Assignee)

Comment 6

5 years ago
Thank you!

Landed:
https://hg.mozilla.org/integration/fx-team/rev/77190bcc870c
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/77190bcc870c
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 21
You need to log in before you can comment on or make changes to this bug.