The Skype website won't display my preferred language

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: KNTRO, Unassigned)

Tracking

15 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:15.3) Gecko/20121202 Firefox/15.3.2 PaleMoon/15.3.2
Build ID: 20121202170410

Steps to reproduce:

THE MAIN QUESTION HERE IS: "en-us" AND "en-US" ARE THE SAME THING OR THEY AREN'T?

So, this is how the issue begins...

I'm using Pale Moon 15.3.2 which is based on Firefox 17. My preferred languages for surfing the web under "Tools" > "Options" > "Content" > "Languages" are: "es-ar", "en-us", "es" and "en".

NOTE: In order to test this possible bug, you must delete current cookies —if any— from skype.com before trying to reproduce these steps. Also, you must change your preferred languages list to something similar to mine.

OK, with no cookies from Skype, enter just "skype.com" in the address bar and hit Enter.


Actual results:

Since the Skype site is not being offered in es-ar, it should check my second language: "en-us", right? Well, this did not happen. What happened instead is this: the Skype site redirected me to this URL: http://www.skype.com/intl/es/home and when you see the source code of that webpage —Ctrl + U— you can see this: <html lang="es-419" >

Yes, I know this is an IETF language tag and this does not follow ISO standards strictly.

So, from top menu from that Skype webpage —which currently says "Español (Latinoamérica)"—, I select "English (American)" and that takes me to this URL:
http://www.skype.com/intl/en-us/home

So, when now I check its source code, there's a surprise to me! It says:
<html lang="en-US" >


Expected results:

So, I don't get it. If there's an "en-US" locale version of that webpage, and "en-us" is second in my preferred language list, why this was not chosen instead of "es"?

AGAIN (1):
Since the Skype site is not being offered in es-ar, it should check my second language: "en-us", right?

AGAIN (2):
THE MAIN QUESTION HERE IS: "en-us" AND "en-US" ARE THE SAME THING OR THEY AREN'T?

NOTE: If you want to test this again, you have to delete your Skype cookies because they content your last selected language, so if you enter just "skype.com", the site will display your manually selected language.

Thank you very much.
Lowercase is ok if you look at the http rfc:
http://www.w3.org/Protocols/rfc2616/rfc2616-sec14.html#sec14.4

You should notify skype about your issues, it's a website bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.