If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Reply / Fwd with attachment doesn't carry over body / addresses

VERIFIED WORKSFORME

Status

MailNews Core
MIME
VERIFIED WORKSFORME
17 years ago
9 years ago

People

(Reporter: Gareth King, Assigned: Jean-Francois Ducarroz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
More description:

If you try to reply or forward a message from an IMAP mailbox where the body has
been downloaded but not the attachment (e.g. a larger attachment say 125 kb)
then the body of the message and the addresses are not caryied over (e.g. get a
blank new message). If the attachment is small (e.g. 36 kb) then it works as
expected. Also if the complete email (with attachment) is downloaded it also
works OK.

Steps to reproduce:

In an IMAP folder select a new message with a large attachment (e.g. 125 kb).
CLick on the reply or forward button in the toolbar.
Message compose window appears but message body and addresses not carried over.

Expect:

Message body and addresses to appear if reply.
Message body, addresses and attachment to appear if forward.
over to ducarroz to investigate.
Assignee: sspitzer → ducarroz
Component: Mail Window Front End → MIME

Updated

17 years ago
QA Contact: esther → sheelar

Comment 2

17 years ago
Reporter,
which build are you using?
I tested this on 2001053009 commercial build on win98. I was able to reply and 
forward with an attachment which is not downloaded. 
I did see the body of the original message in the compose window carried over in 
both forwarding and replying.
While forwarding I also see the body and the attachement. The addressee is not 
filled in case of forwarding a message.
While replying I see the body of the message and the content type information 
below the body and the addresse is filled while replying.  
This is working for me on the above build.

I tried attaching word document(word documents don't get downloaded) and also 
attached a .mov file 14MB and worked fine for me on the above build.  
(Reporter)

Comment 3

17 years ago
Sorry, my mistake - I was too impatient.

Build 2001052404

Reply does work although I was confused because the compose window appears and
then the whole message has to be downloaded from the IMAP server before the
addresses and body get filled in. I was confused because I didn't notice that
the message was being downloaded and therefore just thought that it wasn't
working. As the attachment isn't sent when you reply does the whole message have
to be downloaded? I assume that it would be a lot quicker if just the body was
downloaded and used to populate the compose window when replying.

If you forward a message then the compose window doesn't appear until the
message is downloaded. This can take a long time with a big attachment and I'm
not sure that this is better behaviour because you could assume that the forward
button didn't work.

For completion, if you are offline and forward or reply to an IMAP message that
hasn't been downloaded (although the body has) you also get an empty compose
window (which is a bit confusing). Perhaps in this case you should get a message
box saying that you need to be online to do this. Although I would have thought
if the body has been downloaded then you should be able to reply (not forward)?

Perhaps the behavior should be that you get a message in the status bar that
something is being downloaded and the compose window doesn't appear until it can
be populated. This could be faster for a reply than forward as (presumably) only
the body needs to be downloaded.

What do you think? Gareth
(Reporter)

Comment 4

17 years ago
Just to correct an inacuracy:

> For completion, if you are offline and forward or reply to an IMAP message that
> hasn't been downloaded (although the body has) you also get an empty compose
> window (which is a bit confusing). Perhaps in this case you should get a message
> box saying that you need to be online to do this. Although I would have thought
> if the body has been downloaded then you should be able to reply (not forward)?

You only get an empty compose window if you try to reply to a message that isn't
downloaded (forward doesn't work - as you would expect).

Comment 5

17 years ago
Reporter,
As per your comments in 2001-05-31 08:32 I am marking this bug as worksforme.  
As far as your request for a dlg when offline and etc. please log seperate bugs 
and select the component as offline to do so.  Please don't combine 2 to 3 
different problems in one bug. Log a separate bug for each one of them.  
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 6

17 years ago
verified worksforme.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.