[B2G] crash in JSStructuredCloneReader::read @ nsXPConnect::GetXPConnect

RESOLVED DUPLICATE of bug 828992

Status

Firefox OS
General
--
critical
RESOLVED DUPLICATE of bug 828992
6 years ago
6 years ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

({crash, unagi})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [b2g-crash], crash signature)

(Reporter)

Description

6 years ago
It's #5 top crasher in B2G 18.0.

Frame 	Module 	Signature 	Source
0 	libxul.so 	nsXPConnect::GetXPConnect 	nsXPConnect.cpp:142
1 	libxul.so 	XPCJSRuntime::Get 	nsXPConnect.cpp:244
2 	libxul.so 	nsXPConnect::Peek 	nsXPConnect.cpp:2283
3 	libxul.so 	nsContentUtils::WrapNative 	nsContentUtils.cpp:6182
4 	libxul.so 	mozilla::dom::indexedDB::IDBObjectStore::StructuredCloneReadCallback 	nsContentUtils.h:1752
5 	libxul.so 	JSStructuredCloneReader::read 	jsclone.cpp:1077
6 	libxul.so 	js::ReadStructuredClone 	jsclone.cpp:145
7 	libxul.so 	JS_ReadStructuredClone 	jsapi.cpp:6456
8 	libxul.so 	JSAutoStructuredCloneBuffer::read 	jsapi.cpp:6576
9 	libxul.so 	CreateIndexHelper::DoDatabaseWork 	IDBObjectStore.cpp:3648
10 	libxul.so 	mozilla::dom::indexedDB::AsyncConnectionHelper::Run 	AsyncConnectionHelper.cpp:300
11 	libxul.so 	mozilla::dom::indexedDB::TransactionThreadPool::TransactionQueue::Run 	TransactionThreadPool.cpp:639
12 	libxul.so 	nsThreadPool::Run 	nsThreadPool.cpp:187
13 	libxul.so 	nsThread::ProcessNextEvent 	nsThread.cpp:620
14 	libxul.so 	NS_ProcessNextEvent_P 	nsThreadUtils.cpp:237
15 	libxul.so 	nsThread::ThreadFunc 	nsThread.cpp:258
16 	libnspr4.so 	_pt_root 	ptthread.c:156
17 	libc.so 	__thread_entry 	pthread.c:217
18 	libc.so 	pthread_create 	pthread.c:357 

More reports at:
https://crash-stats.mozilla.com/report/list?product=B2G&signature=nsXPConnect%3A%3AGetXPConnect
(Reporter)

Updated

6 years ago
blocking-b2g: --- → tef?

Comment 1

6 years ago
Note that this is a crash of the main Gecko process.
Keywords: qawanted
I mentioned to jsmith earlier that this is not a crash I have encountered during testing and it will be difficult to repro unless someone can give me a set of steps to try or a dev can look at the code and give us some ideas of what areas to probe.
(Reporter)

Comment 3

6 years ago
It's now #2 top crasher in B2G 18.0.
It first showed up in 18.0/20130110070201.
There are no crashes after 18.0/20130111034521 so we can assume it's fixed if that persists.
Keywords: qawanted
(Reporter)

Comment 4

6 years ago
It was a two-day spike.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
blocking-b2g: tef? → ---
This was almost certainly bug 828992.
(Reporter)

Comment 6

6 years ago
(In reply to ben turner [:bent] from comment #5)
> This was almost certainly bug 828992.
Yes, the working ranges match.
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 828992
(Reporter)

Updated

6 years ago
tracking-b2g18: ? → ---
You need to log in before you can comment on or make changes to this bug.