More links in Transifex website not opening correctly (pop-up webpage)

RESOLVED FIXED

Status

()

--
major
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: raul.malea, Unassigned)

Tracking

20 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

6 years ago
Opened URL> https://www.transifex.com/projects/p/gaia-l10n/language/ro/
Click on shared/date for example.

Expected: New page/forms opened.

Result: Nothing.

Also same problem in login page. When click on social login not appear list with social networks.
(Reporter)

Comment 1

6 years ago
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130112 Firefox/21.0 ID:20130112030947

about:buildconfig
Build Machine

w64-ix-slave101
Source

Built from http://hg.mozilla.org/mozilla-central/rev/1761f4a9081c
Build platform
target
i686-pc-mingw32
Build tools
Compiler 	Version 	Compiler flags
e:/builds/moz2_slave/m-cen-w32-ntly/build/obj-firefox/_virtualenv/Scripts/python.exe -O e:/builds/moz2_slave/m-cen-w32-ntly/build/build/cl.py cl 	16.00.30319.01 	-TC -nologo -W3 -Gy -Fdgenerated.pdb -wd4819 -we4553 -DNDEBUG -DTRIMMED -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1 -Oy-
e:/builds/moz2_slave/m-cen-w32-ntly/build/obj-firefox/_virtualenv/Scripts/python.exe -O e:/builds/moz2_slave/m-cen-w32-ntly/build/build/cl.py cl 	16.00.30319.01 	-TP -nologo -W3 -Gy -Fdgenerated.pdb -wd4345 -wd4351 -wd4800 -wd4819 -we4553 -GR- -DNDEBUG -DTRIMMED -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1 -Oy-
Configure arguments

--enable-update-channel=nightly --enable-update-packaging --enable-jemalloc --enable-signmar --enable-profiling --enable-js-diagnostics --enable-warnings-as-errors
(Reporter)

Comment 2

6 years ago
Error console:

Timp: 12.01.2013 21:25:41
Eroare: Value not an object.
Fișier sursă: chrome://broceliand/content/controller/buttons/RecordButtonController.js
Rândul: 96

Timp: 12.01.2013 21:25:42
Eroare: TypeError: C.style is undefined
Fișier sursă: https://cdn.optimizely.com/js/56622771.js
Rândul: 47

Timp: 12.01.2013 21:25:42
Eroare: TypeError: e.style is undefined
Fișier sursă: https://ajax.googleapis.com/ajax/libs/jquery/1.7/jquery.min.js
Rândul: 2

Timp: 12.01.2013 21:25:42
Eroare: ReferenceError: jQuery is not defined
Fișier sursă: https://ds0k0en9abmn1.cloudfront.net/static/CACHE/js/0933aa5e7e6b.js
Rândul: 8

Timp: 12.01.2013 21:25:42
Eroare: ReferenceError: $ is not defined
Fișier sursă: https://www.transifex.com/projects/p/gaia-l10n/language/ro/
Rândul: 2290

Timp: 12.01.2013 21:25:42
Eroare: TypeError: TRANSIFEX.namespace is not a function
Fișier sursă: https://ds0k0en9abmn1.cloudfront.net/static/js/tablesorted.b8124c39f9b7.js
Rândul: 1


Timp: 12.01.2013 21:26:05
Eroare: Value not an object.
Fișier sursă: chrome://broceliand/content/controller/buttons/RecordButtonController.js
Rândul: 96

Timp: 12.01.2013 21:26:33
Eroare: TypeError: invalid 'instanceof' operand Ci.nsIDOMCSSValueList
Fișier sursă: resource://gre/modules/XPIProvider.jsm -> jar:file:///C:/Users/RaulM/AppData/Roaming/Mozilla/Firefox/Profiles/91becm0h.default/extensions/%7Bd10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d%7D.xpi!/bootstrap.js -> jar:file:///C:/Users/RaulM/AppData/Roaming/Mozilla/Firefox/Profiles/91becm0h.default/extensions/%7Bd10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d%7D.xpi!/lib/ui.js
Rândul: 1716
(Reporter)

Comment 3

6 years ago
I tested also in safe mode/clean profile.

I think I was not well understood. After the site starts and loads the page, if I clicked on one of subprojects (click for translation for apps/costcontrol for example) nothing was happening. Normally should appear a new window / page. Same problem is here: https://www.transifex.com/projects/p/mozillahispano/resource/asksumo-fb/ , for example. If I click on any language, does not open anything.

In Google Chrome work fine. Popup webpage appear.
Summary: Transifex website not running correctly → More links in Transifex website not opening correctly (pop-up webpage)
(Reporter)

Comment 4

6 years ago
Details and confirmations here: http://forums.mozillazine.org/viewtopic.php?f=23&t=2641805&p=12598259
Looks like another site with 'optimizely javascript' issues.

see https://bugzilla.mozilla.org/show_bug.cgi?id=824301 

this bug is likely Tech Evang, and the site will have to fix the scripts now that Optimizely has fixed 'something' on their end.
(Reporter)

Updated

6 years ago
See Also: → bug 811701
(Reporter)

Comment 6

6 years ago
I informed here: http://support.transifex.com/requests/2115 this issue.

Comment 7

6 years ago
I can reproduce this issue on Aurora (Firefox 20), but not on Beta, both on Linux. This also doesn't reproduce on other browsers. 

See also: https://twitter.com/tomer/status/295492257811931136
OS: Windows 7 → All
Hardware: x86_64 → All
Version: 21 Branch → 20 Branch

Comment 8

6 years ago
I can no longer reproduce this problem, so it is probably fixed on their side. 

Can you please confirm that this problem doesn't reproduce on your browser(s) so we could close this bug and sleep well? ☺
(Reporter)

Comment 9

6 years ago
In Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130213 Firefox/21.0 ID:20130213031137 this bug is resolved.

Comment 10

6 years ago
I am on Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20130218 Firefox/20.0 which mean it should work well on the beta channel. Resolving…
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
I'm not a 100% sure, but I may be experiencing the same or a similar issue.

https://bugzilla.mozilla.org/show_bug.cgi?id=952309
I can reproduce this on Windows as well and on other browswers as well.
You need to log in before you can comment on or make changes to this bug.