BLOCKER: typing doesn't display on same line

VERIFIED FIXED in M7

Status

()

P3
normal
VERIFIED FIXED
20 years ago
17 years ago

People

(Reporter: sujay, Assigned: mozeditor)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: joe is looking into this, it is a candidate for M7)

(Reporter)

Description

20 years ago
using 6/15 build of apprunner on all platforms.


1) launch apprunner
2) launch editor

start typing something in the editor. You'll notice that you have
to hit carriage return to get the text to display on the line you
were typing...As you're typing the text shows up on the line below.

all platforms

Updated

20 years ago
Assignee: buster → jfrancis
Summary: typing doesn't display on same line → BLOCKER: typing doesn't display on same line
Whiteboard: joe is looking into this, it is a candidate for M7
Target Milestone: M7

Comment 1

20 years ago
marked a blocker/M7 because it is a major usabililty issue.
The problem is the editor rules code incorrectly inserts NBSP's in text nodes
that are directly in the body.  This doesn't seem to happen for text nodes in
paragraphs or other blocks.
happens in apprunner as well as viewer editor mode.
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 2

20 years ago
accepting bug
(Assignee)

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED
(Assignee)

Comment 3

20 years ago
fixed; rvd: floppy moose; apvd: chofmann
(Reporter)

Updated

20 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

20 years ago
okay this bug is fixed however...now after hitting return we jump two
lines and then when you enter text is goes to the normal position..
filing separate bug...
You need to log in before you can comment on or make changes to this bug.