[B2G][Cost Control]: Cost Control widget is loaded at the startup of the system.

VERIFIED INVALID

Status

Firefox OS
Gaia::Cost Control
VERIFIED INVALID
5 years ago
5 years ago

People

(Reporter: mlevin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Description: Cost Control application is being launched during the Unagi start-up.
Suite Name: Cost Control
Moztrap Test Case #: N/A 

Repro:
1) Update to Unagi build 201301120702022
2) Power off the Unagi.
3) Power on the Unagi
4) Connect the device via USB
5) Use adb to open a shell in the device
6) Issue the command b2g-ps

Expected: No Cost Control is started during start-up, only when needed (CC application launched or widget shown)

Sample output:

Application      USER     PID   PPID  VSIZE  RSS     WCHAN    PC         NAME
b2g              root      3275  1     180612 60244 ffffffff 400f8330 S /system/b2g/b2g
Messages         app_0     3344  3275  57132  18684 ffffffff 40e1cb88 R /system/b2g/plugin-container
Homescreen       app_0     3453  3275  71648  25632 ffffffff 400d7594 R /system/b2g/plugin-container
(Preallocated a  app_0     3518  3275  38156  7716  ffffffff 400d1d86 R /system/b2g/plugin-container

Actual:
mlevin@QAnalystsL55 ~
$ adb shell
root@android:/ # b2g-ps
b2g-ps
APPLICATION      USER     PID   PPID  VSIZE  RSS     WCHAN    PC         NAME
b2g              root      107   1     193932 70432 ffffffff 40099330 S /system/b2g/b2g
Cost Control     app_331   331   107   59268  21592 ffffffff 400c4330 S /system/b2g/plugin-container
Homescreen       app_395   395   107   73052  25268 ffffffff 40061330 S /system/b2g/plugin-container
(Preallocated a  app_419   419   107   55736  17348 ffffffff 4006b330 S /system/b2g/plugin-container
root@android:/ #

Repro frequency:
(1/1 on 2 separate devices)

Notes:
Depends on bug 813243
(Reporter)

Updated

5 years ago
Whiteboard: testrun 2
Thanks mlevin. Feel free to nom these bugs as well if you think they are bad enough to stop ship (tef?) or would not block, but would definitely be worth tracking to get fixed (tracking-b2g18?).
blocking-b2g: --- → tef?
tracking-b2g18: --- → ?
This is not a bug. I need to check a SIM change as soon as the device starts so the widget is loaded and it triggers the check-SIM operation.
I know last time I filed this like a bug (bug 813243) but now is a must or data usage could not work.
(Reporter)

Comment 4

5 years ago
So to clarify is Cost Control widget suppose to start up when the Unagi boots up?
From my point of view, yes: it is suppose to start when Unagi boots. If not, data usage could be inaccurate.
invalid per comment 5
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
blocking-b2g: tef? → ---

Updated

5 years ago
Whiteboard: testrun 2
(Reporter)

Updated

5 years ago
Status: RESOLVED → VERIFIED

Updated

5 years ago
tracking-b2g18: ? → ---
You need to log in before you can comment on or make changes to this bug.