unagi 18 nightly doesn't update

RESOLVED DUPLICATE of bug 830126

Status

RESOLVED DUPLICATE of bug 830126
6 years ago
6 years ago

People

(Reporter: Pike, Unassigned)

Tracking

unspecified
x86
Mac OS X

Firefox Tracking Flags

(blocking-b2g:-)

Details

(Reporter)

Description

6 years ago
I'm running into an update problem with my unagi phone on the nightly channel of b2g18:

I check for updates, it finds an update, it fails to download the mar, and then ends up a an endless loop not even trying to download the nightly.

adb logcat | grep GeckoCon
says:

E/GeckoConsole(  108): Content JS INFO at app://system.gaiamobile.org/js/window_manager.js:1095 in createFrame: %%%%% Launching Homescreen as remote (OOP)
E/GeckoConsole(  395): [JavaScript Warning: "Unknown property '-moz-align-self'.  Declaration dropped." {file: "resource://gre-resources/ua.css" line: 44}]
E/GeckoConsole(  108): Content JS INFO at app://system.gaiamobile.org/js/window_manager.js:1095 in createFrame: %%%%% Launching Calendar as remote (OOP)
E/GeckoConsole(  424): [JavaScript Warning: "Unknown property '-moz-align-self'.  Declaration dropped." {file: "resource://gre-resources/ua.css" line: 44}]
E/GeckoConsole(  438): [JavaScript Warning: "Unknown property '-moz-align-self'.  Declaration dropped." {file: "resource://gre-resources/ua.css" line: 44}]
E/GeckoConsole(  108): Content JS WARN at app://keyboard.gaiamobile.org/js/keyboard.js:664 in modifyLayout: No space key found. No special keys will be added.
E/GeckoConsole(  108): Content JS INFO at app://system.gaiamobile.org/js/window_manager.js:1095 in createFrame: %%%%% Launching Settings as remote (OOP)
E/GeckoConsole(  438): [JavaScript Warning: "Expected pseudo-element but found '-moz-placeholder'.  Ruleset ignored due to bad selector." {file: "app://settings.gaiamobile.org/shared/style/input_areas.css" line: 39}]
E/GeckoConsole(  492): [JavaScript Warning: "Unknown property '-moz-align-self'.  Declaration dropped." {file: "resource://gre-resources/ua.css" line: 44}]
E/GeckoConsole(  108): AUS:SVC Checker: checkForUpdates, force: true
E/GeckoConsole(  108): AUS:SVC Checker:getUpdateURL - update URL: http://update.boot2gecko.org/nightly/update.xml?build_id=20130111230201&version=18.0&dogfood_id=14437&force=1
E/GeckoConsole(  108): AUS:SVC Checker:checkForUpdates - sending request to: http://update.boot2gecko.org/nightly/update.xml?build_id=20130111230201&version=18.0&dogfood_id=14437&force=1
E/GeckoConsole(  108): AUS:SVC Checker:onProgress - 636/636
E/GeckoConsole(  108): AUS:SVC Checker:onLoad - request completed downloading document
E/GeckoConsole(  108): AUS:SVC Checker:getUpdateURL - update URL: http://update.boot2gecko.org/nightly/update.xml?build_id=20130111230201&version=18.0&dogfood_id=14437&force=1
E/GeckoConsole(  108): AUS:SVC Checker:onLoad - number of updates available: 1
E/GeckoConsole(  108): AUS:SVC Creating Downloader
E/GeckoConsole(  108): AUS:SVC UpdateService:_downloadUpdate
E/GeckoConsole(  108): AUS:SVC readStringFromFile - file doesn't exist: /data/local/updates/0/update.status
E/GeckoConsole(  108): AUS:SVC readStatusFile - status: null, path: /data/local/updates/0/update.status
E/GeckoConsole(  108): AUS:SVC Downloader:downloadUpdate - downloading from http://update.boot2gecko.org/nightly/b2g_update_20130113070202.mar?build_id=20130113070202&version=18.0&dogfooding_prerelease_id=14437 to /mnt/sdcard/updates/0/update.mar
E/GeckoConsole(  438): Content JS WARN at app://settings.gaiamobile.org/shared/js/l10n.js:52 in consoleWarn: [l10n] #byteUnit-undefined is undefined.
E/GeckoConsole(  108): AUS:SVC Downloader:onStartRequest - original URI spec: http://update.boot2gecko.org/nightly/b2g_update_20130113070202.mar?build_id=20130113070202&version=18.0&dogfooding_prerelease_id=14437, final URI spec: http://update.boot2gecko.org/nightly/b2g_update_20130113070202.mar?build_id=20130113070202&version=18.0&dogfooding_prerelease_id=14437
E/GeckoConsole(  108): AUS:SVC Downloader:onStopRequest - original URI spec: http://update.boot2gecko.org/nightly/b2g_update_20130113070202.mar?build_id=20130113070202&version=18.0&dogfooding_prerelease_id=14437, final URI spec: http://update.boot2gecko.org/nightly/b2g_update_20130113070202.mar?build_id=20130113070202&version=18.0&dogfooding_prerelease_id=14437, status: 0
E/GeckoConsole(  108): AUS:SVC Downloader:onStopRequest - status: 0, current fail: 0, max fail: 20, retryTimeout: 30000
E/GeckoConsole(  108): AUS:SVC Downloader:_verifyDownload called
E/GeckoConsole(  108): AUS:SVC Downloader:_verifyDownload downloaded size != expected size.
E/GeckoConsole(  108): AUS:SVC Downloader:onStopRequest - download verification failed
E/GeckoConsole(  108): AUS:SVC getStatusTextFromCode - transfer error: The integrity of the update could not be verified, code: verification_failed
E/GeckoConsole(  108): AUS:SVC Downloader:onStopRequest - setting state to: download-failed
E/GeckoConsole(  108): AUS:SVC Downloader:onStopRequest - all update patch downloads failed
E/GeckoConsole(  108): AUS:SVC Creating Downloader
E/GeckoConsole(  108): AUS:SVC UpdateService:_downloadUpdate
E/GeckoConsole(  108): AUS:SVC readStringFromFile - file doesn't exist: /data/local/updates/0/update.status
E/GeckoConsole(  108): AUS:SVC readStatusFile - status: null, path: /data/local/updates/0/update.status
E/GeckoConsole(  108): AUS:SVC Downloader:_selectPatch - found existing patch with state: null
E/GeckoConsole(  108): AUS:SVC Downloader:_selectPatch - failed to apply complete patch!
E/GeckoConsole(  108): AUS:SVC Downloader:downloadUpdate - no patch to download
E/GeckoConsole(  108): AUS:SVC readStatusFile - status: null, path: /data/local/updates/0/update.status


I get out of that loop by removing the updates files via adb shell, but that doesn't get me an update.

I downloaded the mar successfully on my laptop via wget.

Comment 1

6 years ago
Dupe of bug 830126?

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 830126

Updated

6 years ago
blocking-b2g: tef? → tef+

Updated

6 years ago
blocking-b2g: tef+ → -

Updated

6 years ago
tracking-b2g18: ? → ---
You need to log in before you can comment on or make changes to this bug.