stroke-dasharray="0 1" (or "0 <anything-nonzero>") paints dashes at corners when it shouldn't, at certain zoom levels (including the default one)

RESOLVED DUPLICATE of bug 418880

Status

()

Core
SVG
RESOLVED DUPLICATE of bug 418880
5 years ago
5 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

({testcase})

Trunk
x86_64
Linux
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 701611 [details]
testcase 1

STR:
  Load attached testcase.

EXPECTED RESULTS: No red should be visible (because in my <dasharray> specification, I've specified "0" as the lengths of all the dashes) 

ACTUAL RESULTS: Red rectangles (bits of 'stroke') are visible, at each corner of the rect.

Interestingly, if you zoom in or zoom out, the red notches will go away at most zoom levels. (though if I hold Ctrl and hit '+' 4 times, or 6 times, or 8 times, then I see red squares at each corner. Similarly, if I hold Ctrl and hit '-' 4 times, then I see red squares at each corner.)



I get EXPECTED RESULTS from Opera 12.12 & Chrome 25.0.1364.29 dev.

I get ACTUAL RESULTS from Nightly:
 Mozilla/5.0 (X11; Linux x86_64; rv:21.0) Gecko/20130113 Firefox/21.0
(Reporter)

Comment 1

5 years ago
I see the same behavior in Firefox 4.0, FWIW:
 Mozilla/5.0 (X11; Linux x86_64; rv:2.0) Gecko/20100101 Firefox/4.0

And Firefox 3.6 is even more broken -- it fails to parse any stroke-dasharray value that has more than than 1 entry.

So, this isn't a regression (or it's not a recent one, at least).
Keywords: testcase
(Reporter)

Updated

5 years ago
Summary: stroke-dasharray="0 1" (or "0 <anything-nonzero>") paints dashes at corners, only at 100% zoom level → stroke-dasharray="0 1" (or "0 <anything-nonzero>") paints dashes at corners, at certain zoom levels
(Reporter)

Updated

5 years ago
Summary: stroke-dasharray="0 1" (or "0 <anything-nonzero>") paints dashes at corners, at certain zoom levels → stroke-dasharray="0 1" (or "0 <anything-nonzero>") paints dashes at corners when it shouldn't, at certain zoom levels (including the default one)
In 3.6 stroke-dasharray had to be comma separated IIRC.
Seems rather like a duplicate of bug 304795, no?
Make that bug 418880.
(Reporter)

Comment 5

5 years ago
Yup -- I think the testcase here is basically the same as the lower-right rect in the testcase on bug 418880. Thanks!
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 418880
You need to log in before you can comment on or make changes to this bug.