Location/URL/address bar's help text/hint/emptytext ("Go to a Website") should disappear on focus (be removed/erased/cleared/deleted)

RESOLVED DUPLICATE of bug 758996

Status

()

Firefox
Address Bar
--
minor
RESOLVED DUPLICATE of bug 758996
5 years ago
5 years ago

People

(Reporter: keepitsimplestupid, Unassigned)

Tracking

({ux-userfeedback})

19 Branch
x86_64
All
ux-userfeedback
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130109111322

Steps to reproduce:

When you open a new Window or tab there is now greyed out that that says "Go to a Website"

When you click on something such as the address bar, I expect something to happen.  When I click on the entry called "Enter a Website", I get the impression I have a broken mouse or broken click or that my trackpad is turned off.

I "EXPECT" the "Go to a Website" to get erased.


Aside: It could say "Enter URL", but I'm not complaining about the wording because you could enter ftp://etc and that isn't a Website.


Actual results:

Clicking on the address bar when "Go to a Website" is displayed as greyed, nothing happens.


Expected results:

I would expect the "Go to a Website" to be erased.

I would like the address bar to behave like "Product Search" does on this URL.  http://www.newark.com/jsp/home/homepage.jsp

Note that when you click on the "product Search" entry box, the greyed out "Keyword/Part # Search" dissapears.  In Firefox, the URL entry will dissapear on the first character typed, not when the address bar is in focus.

Reasoning: Behaving like Firefox does makes it appear that my trackpad is turned off which is easy to do.

Comment 1

5 years ago
Confirmed with 2013-01-15-03-09-36-mozilla-central-firefox-21.0a1.en-US.linux-x86_64.

On the wording of the text itself: bug 624788.
Severity: normal → minor
Status: UNCONFIRMED → NEW
Component: Untriaged → Location Bar
Ever confirmed: true
OS: Windows 7 → All
Summary: Request a behavior change - blank page → Location/URL/address bar's help text/hint/emptytext ("Go to a Website") should disappear on focus (be removed/erased/cleared/deleted)

Comment 2

5 years ago
This affects the search bar, too.
Keywords: ux-userfeedback

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 758996
You need to log in before you can comment on or make changes to this bug.