SMS Messages says "X and 1 other" for most SMS threads

RESOLVED INVALID

Status

Firefox OS
Gaia::SMS
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: jaws, Assigned: borjasalguero)

Tracking

unspecified
All
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-)

Details

When entering the SMS app, the default view is the Messages overview. Four out of the six message threads that I have show "X and 1 other", where X is the name of the person that I have been messaging.

The "1 other" might be me since these are not group messages, however one of the threads that doesn't have this "and 1 other" does have messages from myself and the recipient.

This started appearing in either the 20130110070201 build or the prior one. I am currently running the 20130110070201 build on the beta channel with my Unagi device.

I also tried erasing all messages on the phone because I thought maybe this was a migration issue but the problem did not go away. I also checked and made sure that I don't have a Contact entry for myself.
Assignee: nobody → fbsc
blocking-b2g: --- → tef+
(Assignee)

Comment 1

5 years ago
Hi Jared, 
I need more info because it's not quite detailed in your comment. If you have, for example, 4 contacts with the same phone number, and you send a SMS to one of them, when coming back to SMS App you should see a thread with the text 'X and 3 others'. This it's a UX requirement and it was working properly.

If you are using the test-app, where a lot of contacts share the same phone number, you are gonna see this behaviour, but it's not working wrong, in fact it's the desirable behaviour.

Im gonna close this bug as invalid because this it's not a bug, it's a UX requirement. On the other hand probably the specs are not updated in the Wiki or something, so Im gonna try to talk with UX team in order to check that the available info it's up-to-date.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
blocking-basecamp: ? → ---
Thank you, that indeed was the case. For some reason, and I don't know how, I had duplicate entries in my Contacts. Perhaps this was from a bad migration during an update?

Removing the duplicates removed the "and 1 other" text.

Updated

5 years ago
blocking-b2g: tef+ → -
You need to log in before you can comment on or make changes to this bug.