Remove nsIDOMDOMImplementation

RESOLVED FIXED in Firefox 60

Status

()

defect
RESOLVED FIXED
6 years ago
3 months ago

People

(Reporter: dzbarsky, Assigned: adrian17)

Tracking

(Blocks 1 bug)

unspecified
mozilla60
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox60 fixed)

Details

Attachments

(3 attachments)

Reporter

Description

6 years ago
Posted patch PatchSplinter Review
It's used by 2 addons, but they both list a maxVersion of 3.6
Reporter

Updated

6 years ago
Attachment #701677 - Flags: review?(bzbarsky)
Reporter

Updated

6 years ago
Attachment #701677 - Attachment is patch: true
Peanut gallery here:  what's the rationale for this?
Removing no-longer-needed code.
Comment on attachment 701677 [details] [diff] [review]
Patch

r=me if you've tested that trying to install those addons from AMO on a current build fails.
Attachment #701677 - Flags: review?(bzbarsky) → review+
https://hg.mozilla.org/mozilla-central/rev/d88715bba2ca
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla21
Hmm.  Binary addons can still use mozilla::dom::DOMImplementation.  But if you feel like making them do that is not reasonable then we do in fact need to back this out.  :(

Peter?
Flags: needinfo?(peterv)
How can binary addons use DOMImplementation?
Hmm.  I guess the main stumbling block is that CreateDocument is non-virtual?  Or is there something else I'm missing?
Yes, we need some way to create documents in binary addons.
Reporter

Comment 11

6 years ago
Backed out in https://hg.mozilla.org/integration/mozilla-inbound/rev/ccc0d4c2ad6f
Status: RESOLVED → REOPENED
Flags: needinfo?(peterv)
Resolution: FIXED → ---
Reporter

Comment 12

6 years ago
Posted patch Backout patchSplinter Review
[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: Breaks some binary addons
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):  Low risk
String or UUID changes made by this patch: None
Attachment #724139 - Flags: approval-mozilla-aurora?
Reporter

Updated

6 years ago
Attachment #724139 - Attachment description: Patch → Backout patch
Attachment #724139 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Target Milestone: mozilla21 → ---
Assignee

Updated

a year ago
Blocks: 1387169
Comment hidden (mozreview-request)
Assignee: dzbarsky → adrian.wielgosik

Comment 16

a year ago
mozreview-review
Comment on attachment 8950359 [details]
Bug 830221 - Remove nsIDOMDOMImplementation.

https://reviewboard.mozilla.org/r/219586/#review225388

r=me, given that binary addons are no more.
Attachment #8950359 - Flags: review?(bzbarsky) → review+

Comment 17

a year ago
Pushed by bzbarsky@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5e234a362e55
Remove nsIDOMDOMImplementation. r=bz

Comment 18

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/5e234a362e55
Status: REOPENED → RESOLVED
Last Resolved: 6 years agoa year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
Component: DOM → DOM: Core & HTML
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.